aboutsummaryrefslogtreecommitdiff
path: root/graphics/png
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2003-01-29 20:20:56 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2003-01-29 20:20:56 +0000
commit52f7e4ba0e7b067b8bb6ed51de218226c435737e (patch)
tree78986abdce92b9236a86cc40b2b509ca5d95e587 /graphics/png
parentd8de079d4362ec252d83043415dc2ceb754b0d8a (diff)
downloadports-52f7e4ba0e7b067b8bb6ed51de218226c435737e.tar.gz
ports-52f7e4ba0e7b067b8bb6ed51de218226c435737e.zip
Install pkg-config data
Submitted by: Joe Marcus Clarke <marcus@marcuscom.com> (sligtly edited)
Notes
Notes: svn path=/head/; revision=74222
Diffstat (limited to 'graphics/png')
-rw-r--r--graphics/png/Makefile9
-rw-r--r--graphics/png/files/patch-ab10
-rw-r--r--graphics/png/pkg-plist1
3 files changed, 20 insertions, 0 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index e0964e46bc05..9bc737be122a 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -7,6 +7,7 @@
PORTNAME= png
PORTVERSION= 1.2.5
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.libpng.org/pub/png/src/ \
ftp://swrinde.nde.swri.edu/pub/png/src/ \
@@ -38,5 +39,13 @@ post-extract:
pre-install:
@[ -d ${PREFIX}/include/libpng ] || ${MKDIR} ${PREFIX}/include/libpng
+ @[ -d ${PREFIX}/libdata/pkgconfig ] || \
+ ${MKDIR} ${PREFIX}/libdata/pkgconfig
+
+post-install:
+ ${CAT} ${WRKSRC}/scripts/libpng.pc.in | ${SED} -e \
+ 's|@PREFIX@|${PREFIX}|' > ${WRKSRC}/scripts/libpng.pc
+ ${INSTALL_DATA} ${WRKSRC}/scripts/libpng.pc \
+ ${PREFIX}/libdata/pkgconfig/libpng12.pc
.include <bsd.port.post.mk>
diff --git a/graphics/png/files/patch-ab b/graphics/png/files/patch-ab
new file mode 100644
index 000000000000..d36b99a474c9
--- /dev/null
+++ b/graphics/png/files/patch-ab
@@ -0,0 +1,10 @@
+--- scripts/libpng.pc.in.orig Wed Dec 11 13:25:12 2002
++++ scripts/libpng.pc.in Wed Dec 11 13:25:35 2002
+@@ -7,5 +7,5 @@
+ Name: libpng12
+ Description: Loads and saves PNG files
+ Version: 1.2.5
+-Libs: -L${libdir} -lpng12 -lz -lm
+-Cflags: -I${includedir}/libpng12
++Libs: -L${libdir} -lpng -lz -lm
++Cflags: -I${includedir}/libpng
diff --git a/graphics/png/pkg-plist b/graphics/png/pkg-plist
index 12775e3a2420..0d7d6c0d7d3d 100644
--- a/graphics/png/pkg-plist
+++ b/graphics/png/pkg-plist
@@ -6,6 +6,7 @@ include/libpng/pngconf.h
@unexec rm -f %D/include/%f
lib/libpng.a
lib/libpng.so.%%SHLIB_VER%%
+libdata/pkgconfig/libpng12.pc
@exec ln -sf %f %B/libpng.so
@unexec rm -f %B/libpng.so
@dirrm include/libpng