aboutsummaryrefslogtreecommitdiff
path: root/graphics/png
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2007-05-21 11:21:09 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2007-05-21 11:21:09 +0000
commit19e154fd5f3d3c3f377ef9c56c15e17a5f73d969 (patch)
treef0ccf62f434bfabfb6a18e09daeee0e756646098 /graphics/png
parentf8e2a239acc2207c1addecc400221e51a8df0382 (diff)
downloadports-19e154fd5f3d3c3f377ef9c56c15e17a5f73d969.tar.gz
ports-19e154fd5f3d3c3f377ef9c56c15e17a5f73d969.zip
Update to 1.2.18
PR: 112725 Submitted by: Nick Barkas <snb@threerings.net> Approved by: portmgr (pav) Security: VuXML ID 4cb9c513-03ef-11dc-a51d-0019b95d4f14
Notes
Notes: svn path=/head/; revision=191582
Diffstat (limited to 'graphics/png')
-rw-r--r--graphics/png/Makefile2
-rw-r--r--graphics/png/distinfo6
-rw-r--r--graphics/png/files/patch-aa2
-rw-r--r--graphics/png/files/patch-ab2
-rw-r--r--graphics/png/files/patch-ad12
-rw-r--r--graphics/png/files/patch-ae18
6 files changed, 30 insertions, 12 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index 7b73049bdda2..ec474deab1cc 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= png
-PORTVERSION= 1.2.14
+PORTVERSION= 1.2.18
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= lib${PORTNAME}
diff --git a/graphics/png/distinfo b/graphics/png/distinfo
index 0f1740137731..7f2c876f1692 100644
--- a/graphics/png/distinfo
+++ b/graphics/png/distinfo
@@ -1,3 +1,3 @@
-MD5 (libpng-1.2.14.tar.bz2) = 2ec1e1beb2e6376b09d090f74d259160
-SHA256 (libpng-1.2.14.tar.bz2) = 2678855a235ed02d5b30831a70dff84d5b562c5de388f1323bd680ac5cdd1722
-SIZE (libpng-1.2.14.tar.bz2) = 620379
+MD5 (libpng-1.2.18.tar.bz2) = 25a7f2f101eaaf2eb18c4987e0fbe39d
+SHA256 (libpng-1.2.18.tar.bz2) = 6fce62f9e67e951c38672bf520c062a2be742e893d240d150748a00c32f20c62
+SIZE (libpng-1.2.18.tar.bz2) = 623690
diff --git a/graphics/png/files/patch-aa b/graphics/png/files/patch-aa
index 0005b7d28395..e42a97dc39d6 100644
--- a/graphics/png/files/patch-aa
+++ b/graphics/png/files/patch-aa
@@ -31,7 +31,7 @@
-CFLAGS+= -I. -DPNG_USE_PNGGCCRD
-.if (${MACHINE_ARCH} != "i386")
--CFLAGS+= -DPNG_NO_ASSEMBLER_CODE
+-CFLAGS+= -DPNG_NO_MMX_CODE
-.endif
-
SRCS= png.c pngset.c pngget.c pngrutil.c pngtrans.c pngwutil.c \
diff --git a/graphics/png/files/patch-ab b/graphics/png/files/patch-ab
index 87ec0a816951..e07387daf8ef 100644
--- a/graphics/png/files/patch-ab
+++ b/graphics/png/files/patch-ab
@@ -12,7 +12,7 @@
Name: libpng
Description: Loads and saves PNG files
- Version: 1.2.14
+ Version: 1.2.18
-Libs: -L${libdir} -lpng12
+Libs: -L${libdir} -lpng -lz -lm
Cflags: -I${includedir}
diff --git a/graphics/png/files/patch-ad b/graphics/png/files/patch-ad
index 4e01c471a28c..08efacae5b75 100644
--- a/graphics/png/files/patch-ad
+++ b/graphics/png/files/patch-ad
@@ -1,9 +1,9 @@
---- pngconf.h.bak Wed Jun 28 00:22:34 2006
-+++ pngconf.h Thu Jul 27 22:01:04 2006
-@@ -722,7 +722,7 @@
-
- /* PNG_ASSEMBLER_CODE was enabled by default in version 1.2.0
- even when PNG_USE_PNGVCRD or PNG_USE_PNGGCCRD is not defined */
+--- pngconf.h.orig Wed May 16 03:52:22 2007
++++ pngconf.h Mon May 21 13:25:03 2007
+@@ -729,7 +729,7 @@
+ * PNG_NO_MMX_CODE disables the use of MMX code without changing the API.
+ * When MMX code is off, then optimized C replacement functions are used.
+ */
-#if defined(PNG_READ_SUPPORTED) && !defined(PNG_NO_ASSEMBLER_CODE)
+#if defined(PNG_READ_SUPPORTED) && !defined(PNG_NO_ASSEMBLER_CODE) && defined(__i386__)
# ifndef PNG_ASSEMBLER_CODE_SUPPORTED
diff --git a/graphics/png/files/patch-ae b/graphics/png/files/patch-ae
new file mode 100644
index 000000000000..cb24f17da2b1
--- /dev/null
+++ b/graphics/png/files/patch-ae
@@ -0,0 +1,18 @@
+--- pnggccrd.c.bak Wed May 16 03:52:23 2007
++++ pnggccrd.c Mon May 21 13:04:54 2007
+@@ -359,6 +359,7 @@
+ _pctemp = _pctemp;
+ _MMXLength = _MMXLength;
+ #endif
++#if 0
+ _const4 = _const4;
+ _const6 = _const6;
+ _mask8_0 = _mask8_0;
+@@ -377,6 +378,7 @@
+ _mask48_2 = _mask48_2;
+ _mask48_1 = _mask48_1;
+ _mask48_0 = _mask48_0;
++#endif
+ }
+ #endif /* PNG_MMX_CODE_SUPPORTED */
+