aboutsummaryrefslogtreecommitdiff
path: root/graphics/poppler
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
commitf76d32b8e89fed7c0e459c1a7fe7a4b57661b01c (patch)
treead29e6808ff698f84e08dab8e047f0ae72838df9 /graphics/poppler
parent873cae3ab41a109b6f9cf9f4149f101d6d996235 (diff)
downloadports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.tar.gz
ports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.zip
Presenting GNOME 2.28.1 for FreeBSD. The official release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.28/ . Officially, this is mostly a polishing release in preparation for GNOME 3.0 due in about a year. On the FreeBSD front, though, a lot went into this release. Major thanks goes to kwm and avl who did a lot of the porting work for this release. In particular, kwm brought in Evolution MAPI support for better Microsoft Exchange integration. Avl made sure that the new gobject introspection repository ports were nicely compartmentalized so that large dependencies aren't brought in wholesale. But, every GNOME team member (ahze, avl, bland, kwm, mezz, and myself) contributed to this release. Other major improvements include an updated HAL with better volume probing code, ufsid integration, and support for volume names containing spaces (big thanks to J.R. Oldroyd); a new WebKit; updated AbiWord; an updated Gimp; and a preview of the new GNOME Shell project (thanks to Pawel Worach). The FreeBSD GNOME Team would like to that the following additional contributors to this release whose patches and testing really helped make it a success: Andrius Morkunas Dominique Goncalves Eric L. Chen J.R. Oldroyd Joseph S. Atkinson Li Pawel Worach Romain Tartière Thomas Vogt Yasuda Keisuke Rui Paulo Martin Wilke (and an extra shout out to miwi and pav for pointyhat runs) We would like to send this release out to Alexander Loginov (avl) in hopes that he feels better soon. PR: 136676 136967 138872 (obsolete with new epiphany-webkit) 139160 134737 139941 140097 140838 140929
Notes
Notes: svn path=/head/; revision=244923
Diffstat (limited to 'graphics/poppler')
-rw-r--r--graphics/poppler/Makefile21
-rw-r--r--graphics/poppler/distinfo6
-rw-r--r--graphics/poppler/files/patch-utils_Makefile.in21
-rw-r--r--graphics/poppler/pkg-plist12
4 files changed, 41 insertions, 19 deletions
diff --git a/graphics/poppler/Makefile b/graphics/poppler/Makefile
index 1655ecbd0e8a..d3758582c102 100644
--- a/graphics/poppler/Makefile
+++ b/graphics/poppler/Makefile
@@ -3,12 +3,12 @@
# Whom: marcus@FreeBSD.org
#
# $FreeBSD$
-# $MCom: ports/graphics/poppler/Makefile,v 1.44 2009/03/14 05:12:31 marcus Exp $
+# $MCom: ports/graphics/poppler/Makefile,v 1.56 2009/11/22 04:24:49 marcus Exp $
#
PORTNAME= poppler
-PORTVERSION= 0.10.6
-PORTREVISION?= 1
+PORTVERSION= 0.12.2
+PORTREVISION?= 0
CATEGORIES= graphics print
MASTER_SITES= http://poppler.freedesktop.org/
@@ -16,7 +16,8 @@ MAINTAINER?= gnome@FreeBSD.org
COMMENT?= A PDF rendering library
LIB_DEPENDS= jpeg.10:${PORTSDIR}/graphics/jpeg \
- fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+ fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
+ lcms.1:${PORTSDIR}/graphics/lcms
RUN_DEPENDS= poppler-data>0:${PORTSDIR}/graphics/poppler-data
USE_GMAKE= yes
@@ -30,13 +31,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
.if !defined(SLAVEPORT)
-OPTIONS= CAIRO "Enable cairo output backend" on
+OPTIONS= CAIRO "Enable cairo output backend" on \
+ OPENJPEG "Enable JPEG 2000 support" on
.endif
.include <bsd.port.pre.mk>
.if defined(SLAVEPORT)
-LIB_DEPENDS+= poppler.4:${PORTSDIR}/graphics/poppler
+LIB_DEPENDS+= poppler.5:${PORTSDIR}/graphics/poppler
.if ${SLAVEPORT}=="gtk"
CONFIGURE_ARGS+=--enable-poppler-glib
@@ -95,6 +97,13 @@ PLIST_SUB+= CAIRO="@comment "
LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
PLIST_SUB+= CAIRO=""
.endif
+
+.if defined(WITHOUT_OPENJPEG)
+CONFIGURE_ARGS+=--disable-libopenjpeg
+.else
+CONFIGURE_ARGS+=--enable-libopenjpeg
+LIB_DEPENDS+= openjpeg.2:${PORTSDIR}/graphics/openjpeg
+.endif
.endif
post-patch:
diff --git a/graphics/poppler/distinfo b/graphics/poppler/distinfo
index 6fb5fcf40115..bb6a38c85184 100644
--- a/graphics/poppler/distinfo
+++ b/graphics/poppler/distinfo
@@ -1,3 +1,3 @@
-MD5 (poppler-0.10.6.tar.gz) = e1a2d98ba5a4199f20d7637a7d79a829
-SHA256 (poppler-0.10.6.tar.gz) = bcd78d674c4166af069afdb27af810c012e13cfd2b7b21f9dce63dd3f62bded1
-SIZE (poppler-0.10.6.tar.gz) = 1527715
+MD5 (poppler-0.12.2.tar.gz) = 60c00b55acf7dd389bf256d178af70bf
+SHA256 (poppler-0.12.2.tar.gz) = bebfb8c0b091f44026a0c0d61790a0490b04b3c0132f82bd0b39e861bdaf2719
+SIZE (poppler-0.12.2.tar.gz) = 1614984
diff --git a/graphics/poppler/files/patch-utils_Makefile.in b/graphics/poppler/files/patch-utils_Makefile.in
index e0faea3d198e..4a621ba6eec3 100644
--- a/graphics/poppler/files/patch-utils_Makefile.in
+++ b/graphics/poppler/files/patch-utils_Makefile.in
@@ -1,13 +1,15 @@
---- utils/Makefile.in.orig 2009-02-26 18:44:48.000000000 -0500
-+++ utils/Makefile.in 2009-02-26 18:45:57.000000000 -0500
-@@ -61,50 +61,50 @@ am_pdffonts_OBJECTS = pdffonts.$(OBJEXT)
+--- utils/Makefile.in.orig 2009-10-22 20:33:17.000000000 +0200
++++ utils/Makefile.in 2009-10-22 20:33:49.000000000 +0200
+@@ -64,7 +64,7 @@ am_pdffonts_OBJECTS = pdffonts.$(OBJEXT)
pdffonts_OBJECTS = $(am_pdffonts_OBJECTS)
pdffonts_LDADD = $(LDADD)
am__DEPENDENCIES_1 =
-pdffonts_DEPENDENCIES = $(top_builddir)/poppler/libpoppler.la \
+pdffonts_DEPENDENCIES = \
$(am__DEPENDENCIES_1)
- am_pdfimages_OBJECTS = pdfimages.$(OBJEXT) ImageOutputDev.$(OBJEXT) \
+ AM_V_lt = $(am__v_lt_$(V))
+ am__v_lt_ = $(am__v_lt_$(AM_DEFAULT_VERBOSITY))
+@@ -73,19 +73,19 @@ am_pdfimages_OBJECTS = pdfimages.$(OBJEX
$(am__objects_1)
pdfimages_OBJECTS = $(am_pdfimages_OBJECTS)
pdfimages_LDADD = $(LDADD)
@@ -25,11 +27,12 @@
@BUILD_ABIWORD_OUTPUT_TRUE@am_pdftoabw_OBJECTS = pdftoabw.$(OBJEXT) \
@BUILD_ABIWORD_OUTPUT_TRUE@ $(am__objects_1)
pdftoabw_OBJECTS = $(am_pdftoabw_OBJECTS)
- pdftoabw_LDADD = $(LDADD)
--pdftoabw_DEPENDENCIES = $(top_builddir)/poppler/libpoppler.la \
-+pdftoabw_DEPENDENCIES = \
+-am__DEPENDENCIES_2 = $(top_builddir)/poppler/libpoppler.la \
++am__DEPENDENCIES_2 = \
$(am__DEPENDENCIES_1)
- am_pdftohtml_OBJECTS = pdftohtml.$(OBJEXT) HtmlFonts.$(OBJEXT) \
+ @BUILD_ABIWORD_OUTPUT_TRUE@pdftoabw_DEPENDENCIES = \
+ @BUILD_ABIWORD_OUTPUT_TRUE@ $(am__DEPENDENCIES_2) \
+@@ -94,25 +94,25 @@ am_pdftohtml_OBJECTS = pdftohtml.$(OBJEX
HtmlLinks.$(OBJEXT) HtmlOutputDev.$(OBJEXT) $(am__objects_1)
pdftohtml_OBJECTS = $(am_pdftohtml_OBJECTS)
pdftohtml_LDADD = $(LDADD)
@@ -59,7 +62,7 @@
$(am__DEPENDENCIES_1)
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir) -I$(top_builddir)/poppler
depcomp = $(SHELL) $(top_srcdir)/depcomp
-@@ -320,7 +320,7 @@ INCLUDES = \
+@@ -382,7 +382,7 @@ INCLUDES = \
$(ABIWORD_CFLAGS)
LDADD = \
diff --git a/graphics/poppler/pkg-plist b/graphics/poppler/pkg-plist
index 1ea3318716f2..5ccd2f4ab8da 100644
--- a/graphics/poppler/pkg-plist
+++ b/graphics/poppler/pkg-plist
@@ -20,6 +20,7 @@ include/poppler/Function.h
include/poppler/Gfx.h
include/poppler/GfxFont.h
include/poppler/GfxState.h
+include/poppler/GfxState_helpers.h
include/poppler/GlobalParams.h
include/poppler/JArithmeticDecoder.h
include/poppler/JBIG2Stream.h
@@ -39,6 +40,7 @@ include/poppler/PSTokenizer.h
include/poppler/Page.h
include/poppler/PageTransition.h
include/poppler/Parser.h
+include/poppler/PopplerCache.h
include/poppler/PreScanOutputDev.h
include/poppler/ProfileData.h
include/poppler/SecurityHandler.h
@@ -56,6 +58,11 @@ include/poppler/UnicodeMapTables.h
include/poppler/UnicodeTypeTable.h
include/poppler/XRef.h
include/poppler/XpdfPluginAPI.h
+include/poppler/fofi/FoFiBase.h
+include/poppler/fofi/FoFiEncodings.h
+include/poppler/fofi/FoFiTrueType.h
+include/poppler/fofi/FoFiType1.h
+include/poppler/fofi/FoFiType1C.h
include/poppler/goo/FixedPoint.h
include/poppler/goo/GooHash.h
include/poppler/goo/GooList.h
@@ -63,8 +70,10 @@ include/poppler/goo/GooMutex.h
include/poppler/goo/GooString.h
include/poppler/goo/GooTimer.h
include/poppler/goo/GooVector.h
+include/poppler/goo/PNGWriter.h
include/poppler/goo/gfile.h
include/poppler/goo/gmem.h
+include/poppler/goo/gstrtod.h
include/poppler/goo/gtypes.h
include/poppler/poppler-config.h
include/poppler/splash/Splash.h
@@ -93,10 +102,11 @@ include/poppler/splash/SplashXPathScanner.h
lib/libpoppler.a
lib/libpoppler.la
lib/libpoppler.so
-lib/libpoppler.so.4
+lib/libpoppler.so.5
%%CAIRO%%libdata/pkgconfig/poppler-cairo.pc
libdata/pkgconfig/poppler-splash.pc
libdata/pkgconfig/poppler.pc
@dirrm include/poppler/splash
@dirrm include/poppler/goo
+@dirrm include/poppler/fofi
@dirrm include/poppler