aboutsummaryrefslogtreecommitdiff
path: root/graphics/potrace
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-14 16:09:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-14 16:09:19 +0000
commit8f998ba5d3b090307ca56ab6205bf3991e26bc1a (patch)
tree47eb6dd1232f1ad8265c0dea9c6363103a3932d7 /graphics/potrace
parent359a13588b8880f79097c559a95ee8462bdf1aa6 (diff)
downloadports-8f998ba5d3b090307ca56ab6205bf3991e26bc1a.tar.gz
ports-8f998ba5d3b090307ca56ab6205bf3991e26bc1a.zip
Add potrace, utility for converting (tracing) bitmap images into vectors.
PR: ports/57197 Submitted by: Piotr Smyrak <piotr.smyrak@heron.pl>
Notes
Notes: svn path=/head/; revision=95800
Diffstat (limited to 'graphics/potrace')
-rw-r--r--graphics/potrace/Makefile43
-rw-r--r--graphics/potrace/distinfo1
-rw-r--r--graphics/potrace/pkg-descr13
-rw-r--r--graphics/potrace/pkg-plist1
4 files changed, 58 insertions, 0 deletions
diff --git a/graphics/potrace/Makefile b/graphics/potrace/Makefile
new file mode 100644
index 000000000000..7c5d63146799
--- /dev/null
+++ b/graphics/potrace/Makefile
@@ -0,0 +1,43 @@
+# Ports collection makefile for: potrace
+# Date created: 24 September 2003
+# Whom: Piotr Smyrak <smyru@heron.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= potrace
+PORTVERSION= 1.1
+CATEGORIES= graphics
+MASTER_SITES= http://potrace.sourceforge.net/download/
+
+MAINTAINER= smyru@heron.pl
+COMMENT= Transforms bitmaps into vector graphics
+
+GNU_CONFIGURE= yes
+
+MAN1= potrace.1
+
+.if defined(A4)
+CONFIGURE_ARGS+= --enable-a4
+.endif
+
+.if defined(WITH_LZW) || defined(HAVE_UNISYS_LICENSE) || defined(WITH_GIF_LZW_COMPRESSION)
+CONFIGURE_ARGS+= --enable-compress
+.else
+CONFIGURE_ARGS+= --disable-compress
+.endif
+
+.if defined(WITH_METRIC)
+CONFIGURE_ARGS+= --enable-metric
+.endif
+
+pre-everything::
+ @${ECHO} ""
+ @${ECHO} "You may define the following build options:"
+ @${ECHO} ""
+ @${ECHO} " WITH_LZW Enable patented external LZW compression"
+ @${ECHO} " WITH_METRIC Enable use of metric units (centimeters) as default"
+ @${ECHO} " A4 Enable use of A4 as the default papersize"
+ @${ECHO} ""
+
+.include <bsd.port.mk>
diff --git a/graphics/potrace/distinfo b/graphics/potrace/distinfo
new file mode 100644
index 000000000000..4b2ca1d8bd4c
--- /dev/null
+++ b/graphics/potrace/distinfo
@@ -0,0 +1 @@
+MD5 (potrace-1.1.tar.gz) = 50d72e4c5a76ffd7da092995594e4187
diff --git a/graphics/potrace/pkg-descr b/graphics/potrace/pkg-descr
new file mode 100644
index 000000000000..6db98b420d63
--- /dev/null
+++ b/graphics/potrace/pkg-descr
@@ -0,0 +1,13 @@
+potrace is a Peter Selinger's GPLed utility for tracing
+bitmaps - converting them into smooth, scalable images.
+
+It accepts as input a bitmap B/W images (PBM, PGM, PPM
+and BMP formats), and returns encapsulated PostScript
+(EPS) as the default output. Other output format are
+available: PS, SVG and also PGM.
+
+You can create scalable image formats from scans, such
+as logos, hand taken notes, etc. The resulting smooth
+images can then be rendered at any resolution.
+
+WWW: http://potrace.sourceforge.net
diff --git a/graphics/potrace/pkg-plist b/graphics/potrace/pkg-plist
new file mode 100644
index 000000000000..a51bb8b8d332
--- /dev/null
+++ b/graphics/potrace/pkg-plist
@@ -0,0 +1 @@
+bin/potrace