aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-graph-dot
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2009-07-14 07:22:57 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2009-07-14 07:22:57 +0000
commitef6013d2a87f1b9ff07911b1bc8822fe02f1b739 (patch)
tree30ce7e5d6f480f63012a120a0743784c816dd73a /graphics/py-graph-dot
parentea9c0451d31f36b8bf80810d81a99ea11721d32b (diff)
downloadports-ef6013d2a87f1b9ff07911b1bc8822fe02f1b739.tar.gz
ports-ef6013d2a87f1b9ff07911b1bc8822fe02f1b739.zip
- Update to 1.6.1
PR: ports/136732 Submitted by: Yi-Jheng Lin <yzlin AT cs.nctu.edu.tw> (maintainer)
Notes
Notes: svn path=/head/; revision=237763
Diffstat (limited to 'graphics/py-graph-dot')
-rw-r--r--graphics/py-graph-dot/Makefile6
-rw-r--r--graphics/py-graph-dot/distinfo6
-rw-r--r--graphics/py-graph-dot/files/patch-setup.py10
-rw-r--r--graphics/py-graph-dot/pkg-plist75
4 files changed, 49 insertions, 48 deletions
diff --git a/graphics/py-graph-dot/Makefile b/graphics/py-graph-dot/Makefile
index 79754b5ec2ef..71c9e46f7cf1 100644
--- a/graphics/py-graph-dot/Makefile
+++ b/graphics/py-graph-dot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= graph
-PORTVERSION= 1.5.0
+PORTVERSION= 1.6.1
CATEGORIES= graphics python
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,9 +20,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pydot>=0:${PORTSDIR}/graphics/py-pydot
PROJECTHOST= python-graph
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
-PYDISTUTILS_PKGNAME= python-graph
-
-WRKSRC= ${WRKDIR}/${PYDISTUTILS_PKGNAME}
+PYDISTUTILS_PKGNAME= python_graph
USE_BZIP2= yes
diff --git a/graphics/py-graph-dot/distinfo b/graphics/py-graph-dot/distinfo
index 3f3f9046851b..23e589b9ce49 100644
--- a/graphics/py-graph-dot/distinfo
+++ b/graphics/py-graph-dot/distinfo
@@ -1,3 +1,3 @@
-MD5 (python-graph-1.5.0.tar.bz2) = fc349565a013286a4cb20297cd00364b
-SHA256 (python-graph-1.5.0.tar.bz2) = f7bf5d9e7233d75b72defc724c9678abed54a54633dab0e700c7aec47a390532
-SIZE (python-graph-1.5.0.tar.bz2) = 53892
+MD5 (python-graph-1.6.1.tar.bz2) = 4c52cb006e139e7578f9bdf2338d166d
+SHA256 (python-graph-1.6.1.tar.bz2) = 33279db94653f83ba58c3cc114b99c55d9fbd187caeff2c8998e95a36c02487a
+SIZE (python-graph-1.6.1.tar.bz2) = 54402
diff --git a/graphics/py-graph-dot/files/patch-setup.py b/graphics/py-graph-dot/files/patch-setup.py
index 3e1fedeb3a42..89d543f758fd 100644
--- a/graphics/py-graph-dot/files/patch-setup.py
+++ b/graphics/py-graph-dot/files/patch-setup.py
@@ -1,6 +1,6 @@
--- setup.py.orig
+++ setup.py
-@@ -4,11 +4,7 @@
+@@ -4,12 +4,7 @@
import os
import logging
@@ -9,18 +9,18 @@
-except ImportError, ie:
- import ez_setup
- ez_setup.use_setuptools()
+- from setuptools import setup, find_packages
+from setuptools import setup, find_packages
# Startup
appname = "python-graph"
-@@ -37,8 +33,8 @@
+@@ -40,9 +35,6 @@
name = appname,
version = appversion,
- packages = ['graph', 'graph.algorithms', 'graph.algorithms.filters', 'graph.algorithms.heuristics', 'graph.classes'],
+ packages = ['pygraph', 'pygraph.algorithms', 'pygraph.algorithms.filters', 'pygraph.algorithms.heuristics', 'pygraph.classes', 'pygraph.readwrite'],
- data_files = [(docsdir,docsfiles),
- (datadir,datafiles)],
-+# data_files = [(docsdir,docsfiles),
-+# (datadir,datafiles)],
+- install_requires = ['pydot'],
author = "Pedro Matiello",
author_email = "pmatiello@gmail.com",
description = "A library for working with graphs in Python",
diff --git a/graphics/py-graph-dot/pkg-plist b/graphics/py-graph-dot/pkg-plist
index 3df4e3e5aaf9..13223b5f9c46 100644
--- a/graphics/py-graph-dot/pkg-plist
+++ b/graphics/py-graph-dot/pkg-plist
@@ -17,45 +17,48 @@
%%PORTDOCS%%%%DOCSDIR%%/crarr.png
%%PORTDOCS%%%%DOCSDIR%%/epydoc.css
%%PORTDOCS%%%%DOCSDIR%%/epydoc.js
-%%PORTDOCS%%%%DOCSDIR%%/graph-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.accessibility-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.critical-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.cycles-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.exceptions-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.exceptions.python_graph_exception-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.exceptions.unreachable-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Find-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Find.find-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Null-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Null.null-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Radius-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.filters.Radius.radius-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.generators-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics.Chow-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics.Chow.chow-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics.Euclidean-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.heuristics.Euclidean.euclidean-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.minmax-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.readwrite-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.searching-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.sorting-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.traversal-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.utils-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.utils.HeapItem-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.algorithms.utils.priority_queue-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.classes-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Digraph-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Digraph.digraph-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Graph-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Graph.graph-class.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Hypergraph-module.html
-%%PORTDOCS%%%%DOCSDIR%%/graph.classes.Hypergraph.hypergraph-class.html
%%PORTDOCS%%%%DOCSDIR%%/help.html
%%PORTDOCS%%%%DOCSDIR%%/identifier-index.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/module-tree.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.accessibility-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.critical-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.cycles-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.filters-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.filters.Find-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.filters.Find.find-class.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.filters.Null-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.filters.Null.null-class.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.filters.Radius-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.filters.Radius.radius-class.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.generators-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.heuristics-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.heuristics.Chow-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.heuristics.Chow.chow-class.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.heuristics.Euclidean-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.heuristics.Euclidean.euclidean-class.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.minmax-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.searching-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.sorting-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.traversal-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.utils-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.utils.HeapItem-class.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.algorithms.utils.priority_queue-class.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Digraph-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Digraph.digraph-class.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Exceptions-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Exceptions.GraphError-class.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Exceptions.InvalidGraphType-class.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Exceptions.NodeUnreachable-class.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Graph-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Graph.graph-class.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Hypergraph-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.classes.Hypergraph.hypergraph-class.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.readwrite-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.readwrite.dot-module.html
+%%PORTDOCS%%%%DOCSDIR%%/pygraph.readwrite.markup-module.html
%%PORTDOCS%%%%DOCSDIR%%/redirect.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%