aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-pillow6
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2020-02-24 11:36:15 +0000
committerKai Knoblich <kai@FreeBSD.org>2020-02-24 11:36:15 +0000
commit74174b26616baa21c285c0515b591e7d738c5c0f (patch)
tree1c10419849a595f8ebfa59836f2e676bb7ec3469 /graphics/py-pillow6
parent45b08b671d6459dc7e71950a89cac654920ec089 (diff)
downloadports-74174b26616baa21c285c0515b591e7d738c5c0f.tar.gz
ports-74174b26616baa21c285c0515b591e7d738c5c0f.zip
graphics/py-pillow: Update to 7.0.0
* Repo-Copy the Pillow 6.2.2 release to graphics/py-pillow6 to retain backwards compatibility for Python 2 consumers as the Pillow 7.0.0 release dropped the support for Python 2. * Apply conditional statements to use either Pillow 7.x or Pillow 6.x for consumers that can be built for Python 2 or newer. * Exceptions are ports that can be built only for either Python 2 or Python 3. For the first case, consumers are just assigned to the repo-copied graphics/py-pillow6. * Also remove Pillow from BUILD_DEPENDS of math/py-PyWavelets as it is not listed in setup.py as a build dependency [1] and relax the version requirements of Pillow for www/py-wagtail. Release Notes: * https://pillow.readthedocs.io/en/latest/releasenotes/index.html Backward Incompatible Changes (7.0.0): * https://pillow.readthedocs.io/en/latest/releasenotes/7.0.0.html#backwards-incompatible-changes Detailed Changelog: * https://github.com/python-pillow/Pillow/blob/7.0.0/CHANGES.rst PR: 243665 Submitted by: sunpoet (patch for 7.0.0 and repo-copied version) Reviewed by: koobs [1], sunpoet Approved by: koobs (maintainer) Differential Revision: https://reviews.freebsd.org/D23713
Notes
Notes: svn path=/head/; revision=526962
Diffstat (limited to 'graphics/py-pillow6')
-rw-r--r--graphics/py-pillow6/Makefile83
-rw-r--r--graphics/py-pillow6/distinfo3
-rw-r--r--graphics/py-pillow6/pkg-descr5
3 files changed, 91 insertions, 0 deletions
diff --git a/graphics/py-pillow6/Makefile b/graphics/py-pillow6/Makefile
new file mode 100644
index 000000000000..3569559c60e0
--- /dev/null
+++ b/graphics/py-pillow6/Makefile
@@ -0,0 +1,83 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pillow
+PORTVERSION= 6.2.2
+CATEGORIES= graphics python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 6
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Fork of the Python Imaging Library (PIL)
+
+LICENSE= PIL
+LICENSE_NAME= Standard PIL License
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${PY_FLAVOR}
+
+# Python 2.7,3.5+
+USES= cpe python
+USE_GITHUB= yes
+USE_PYTHON= autoplist concurrent distutils
+
+GH_ACCOUNT= python-${PORTNAME}
+GH_PROJECT= ${PORTNAME:C/p/P/}
+
+CONFLICTS_INSTALL= ${PYTHON_PKGNAMEPREFIX}pillow
+
+OPTIONS_DEFINE= FREETYPE JPEG JPEG2000 LCMS OLE PNG TIFF TKINTER WEBP
+OPTIONS_DEFAULT= FREETYPE JPEG JPEG2000 LCMS OLE PNG TIFF TKINTER WEBP
+
+LCMS_DESC= Little Color Management System
+OLE_DESC= Microsoft OLE2 file format support
+TKINTER_DESC= Tkinter (Tcl/Tk) BitmapImage & PhotoImage support
+
+FREETYPE_LIB_DEPENDS= libfreetype.so:print/freetype2
+FREETYPE_VARS= PYDISTUTILS_BUILDARGS+=--enable-freetype
+FREETYPE_VARS_OFF= PYDISTUTILS_BUILDARGS+=--disable-freetype
+
+JPEG_USES= jpeg
+JPEG_VARS= PYDISTUTILS_BUILDARGS+=--enable-jpeg
+JPEG_VARS_OFF= PYDISTUTILS_BUILDARGS+=--disable-jpeg
+
+JPEG2000_LIB_DEPENDS= libopenjp2.so:graphics/openjpeg
+JPEG2000_VARS= PYDISTUTILS_BUILDARGS+=--enable-jpeg2000
+JPEG2000_VARS_OFF= PYDISTUTILS_BUILDARGS+=--disable-jpeg2000
+
+LCMS_LIB_DEPENDS= liblcms2.so:graphics/lcms2
+LCMS_VARS= PYDISTUTILS_BUILDARGS+=--enable-lcms
+LCMS_VARS_OFF= PYDISTUTILS_BUILDARGS+=--disable-lcms
+
+OLE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}olefile>0:devel/py-olefile@${PY_FLAVOR}
+
+PNG_VARS= PYDISTUTILS_BUILDARGS+=--enable-zlib
+PNG_VARS_OFF= PYDISTUTILS_BUILDARGS+=--disable-zlib
+
+TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
+TIFF_VARS= PYDISTUTILS_BUILDARGS+=--enable-tiff
+TIFF_VARS_OFF= PYDISTUTILS_BUILDARGS+=--disable-tiff
+
+TKINTER_USES= tk
+TKINTER_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
+TKINTER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
+TKINTER_VARS= PYDISTUTILS_BUILDARGS+="--include-dirs=${TCL_INCLUDEDIR}:${TK_INCLUDEDIR}"
+
+WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
+WEBP_VARS= PYDISTUTILS_BUILDARGS+="--enable-webp --enable-webpmux"
+WEBP_VARS_OFF= PYDISTUTILS_BUILDARGS+="--disable-webp --disable-webpmux"
+
+.include <bsd.port.pre.mk>
+
+PYDISTUTILS_BUILD_TARGET= build build_ext
+PYDISTUTILS_BUILDARGS+= saveopts
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PIL/*.so
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.post.mk>
diff --git a/graphics/py-pillow6/distinfo b/graphics/py-pillow6/distinfo
new file mode 100644
index 000000000000..22f4c9a333ee
--- /dev/null
+++ b/graphics/py-pillow6/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1579047758
+SHA256 (python-pillow-Pillow-6.2.2_GH0.tar.gz) = cc4ec754ddcc98b7166a1afe062c6355c841776145f0f23bdd3bea1eaa41e2db
+SIZE (python-pillow-Pillow-6.2.2_GH0.tar.gz) = 37538464
diff --git a/graphics/py-pillow6/pkg-descr b/graphics/py-pillow6/pkg-descr
new file mode 100644
index 000000000000..0249c5723e14
--- /dev/null
+++ b/graphics/py-pillow6/pkg-descr
@@ -0,0 +1,5 @@
+Pillow is the "friendly" PIL fork. PIL is the Python Imaging Library. Pillow
+was started for and is currently maintained by the Plone community. But it is
+used by many other folks in the Python web community.
+
+WWW: https://python-pillow.org/