aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-pyproj
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2016-12-08 22:44:41 +0000
committerJason E. Hale <jhale@FreeBSD.org>2016-12-08 22:44:41 +0000
commit69bb45e2a068f53cbc3ba78ae510a65dd257430e (patch)
treea74230ac86d74f99be201f8718953335c9869932 /graphics/py-pyproj
parent619a575db04d0f992159a7374b678cae8ab09c97 (diff)
downloadports-69bb45e2a068f53cbc3ba78ae510a65dd257430e.tar.gz
ports-69bb45e2a068f53cbc3ba78ae510a65dd257430e.zip
Update to 1.9.5.1
Unbreak fetch Add LICENSE (MIT) Use ports version of graphics/proj instead of bundled version Update pkg-descr/WWW PR: 210534 (based on) Submitted by: <fmysh@iijmio-mail.jp> (maintainer) Reported by: Dusan Vejnovic <freebsd@dussan.org>
Notes
Notes: svn path=/head/; revision=428160
Diffstat (limited to 'graphics/py-pyproj')
-rw-r--r--graphics/py-pyproj/Makefile28
-rw-r--r--graphics/py-pyproj/distinfo5
-rw-r--r--graphics/py-pyproj/pkg-descr28
3 files changed, 44 insertions, 17 deletions
diff --git a/graphics/py-pyproj/Makefile b/graphics/py-pyproj/Makefile
index 4ed9e6854cdf..b275d4a4aa5f 100644
--- a/graphics/py-pyproj/Makefile
+++ b/graphics/py-pyproj/Makefile
@@ -2,29 +2,39 @@
# $FreeBSD$
PORTNAME= pyproj
-PORTVERSION= 1.9.3
+PORTVERSION= 1.9.5.1
CATEGORIES= graphics python geography
-MASTER_SITES= GOOGLE_CODE
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= fmysh@iijmio-mail.jp
-COMMENT= Pyrex wrapper to provide python interfaces to PROJ.4
+COMMENT= Cython wrapper to provide python interfaces to PROJ.4 functions
-BROKEN= Unfetchable (google code has gone away)
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libproj.so:graphics/proj
-WRKSRC= ${WRKDIR}/${DISTNAME:C/[a-z]$//}
USES= python
-USE_PYTHON= distutils autoplist
+USE_PYTHON= distutils autoplist concurrent
+
+MAKE_ENV= PROJ_DIR=${LOCALBASE}
-PORTDOCS= Changelog README LICENSE_proj4
+PORTDOCS= *
+PORTDOCS1= Changelog README.md docs/*
PORTEXAMPLES= datum_shift.py geodtest.py sample.out \
- test.py test2.py test_transform.py
+ test.py test2.py test_datum.py test_transform.py
OPTIONS_DEFINE= DOCS EXAMPLES
post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME}/_proj.so
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_MAN} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS1:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/test/,} ${STAGEDIR}${EXAMPLESDIR}
diff --git a/graphics/py-pyproj/distinfo b/graphics/py-pyproj/distinfo
index a90b3ca0d176..a053f5294e15 100644
--- a/graphics/py-pyproj/distinfo
+++ b/graphics/py-pyproj/distinfo
@@ -1,2 +1,3 @@
-SHA256 (pyproj-1.9.3.tar.gz) = 912ed86c5e407f091d0f3d076594af4fb569e27c68199b7d71651edd522aaa0c
-SIZE (pyproj-1.9.3.tar.gz) = 2687498
+TIMESTAMP = 1481180431
+SHA256 (pyproj-1.9.5.1.tar.gz) = 53fa54c8fa8a1dfcd6af4bf09ce1aae5d4d949da63b90570ac5ec849efaf3ea8
+SIZE (pyproj-1.9.5.1.tar.gz) = 4424543
diff --git a/graphics/py-pyproj/pkg-descr b/graphics/py-pyproj/pkg-descr
index 6a417d07a1a7..fd9a16dbf203 100644
--- a/graphics/py-pyproj/pkg-descr
+++ b/graphics/py-pyproj/pkg-descr
@@ -1,8 +1,24 @@
-Pyrex wrapper to provide python interfaces to
-PROJ.4 (http://proj.maptools.org) functions.
+Cython wrapper to provide python interfaces to PROJ.4 functions.
-Performs cartographic transformations (converts from longitude,latitude
-to native map projection x,y coordinates and vice versa, or from
-one map projection coordinate system directly to another).
+Performs cartographic transformations and geodetic computations.
-WWW: http://code.google.com/p/pyproj
+The Proj class can convert from geographic (longitude,latitude)
+to native map projection (x,y) coordinates and vice versa, or
+from one map projection coordinate system directly to another.
+The module variable pj_list is a dictionary containing all the
+available projections and their descriptions.
+
+The Geod class can perform forward and inverse geodetic, or
+Great Circle, computations. The forward computation involves
+determining latitude, longitude and back azimuth of a terminus
+point given the latitude and longitude of an initial point,
+plus azimuth and distance. The inverse computation involves
+determining the forward and back azimuths and distance given
+the latitudes and longitudes of an initial and terminus point.
+
+Input coordinates can be given as python arrays, lists/tuples,
+scalars or numpy/Numeric/numarray arrays. Optimized for objects
+that support the Python buffer protocol (regular python and
+numpy array objects).
+
+WWW: https://github.com/jswhit/pyproj