aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-sane
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-09-30 20:36:56 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-09-30 20:36:56 +0000
commit746d51c0d4ea2447e242f3f14ccad79dcc83ac41 (patch)
tree0509a155629723310b6af15c4c8dac489febf328 /graphics/py-sane
parenta4db6a05c695250dabe54ea9d467f270ca739e7b (diff)
downloadports-746d51c0d4ea2447e242f3f14ccad79dcc83ac41.tar.gz
ports-746d51c0d4ea2447e242f3f14ccad79dcc83ac41.zip
Add py-sane 2.0, the Python binding for Sane.
PR: ports/159544 Submitted by: Kuan-Chung Chiu <buganini@gmail.com> Approved by: miwi, wen (mentors implicit)
Notes
Notes: svn path=/head/; revision=282691
Diffstat (limited to 'graphics/py-sane')
-rw-r--r--graphics/py-sane/Makefile31
-rw-r--r--graphics/py-sane/distinfo2
-rw-r--r--graphics/py-sane/files/patch-setup.py19
-rw-r--r--graphics/py-sane/pkg-descr15
-rw-r--r--graphics/py-sane/pkg-plist4
5 files changed, 71 insertions, 0 deletions
diff --git a/graphics/py-sane/Makefile b/graphics/py-sane/Makefile
new file mode 100644
index 000000000000..8cd4bb0fcc29
--- /dev/null
+++ b/graphics/py-sane/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: py-sane
+# Date created: 5 August 2011
+# Whom: buganini@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= sane
+PORTVERSION= 2.0
+CATEGORIES= graphics python
+MASTER_SITES= http://effbot.org/media/downloads/ \
+ http://www.pythonware.net/storage/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Imaging-1.1.7
+
+MAINTAINER= buganini@gmail.com
+COMMENT= The Python binding for Sane
+
+LIB_DEPENDS= sane.1:${PORTSDIR}/graphics/sane-backends
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}imaging>=1.1.7:${PORTSDIR}/graphics/py-imaging
+
+DIST_SUBDIR= python
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/Sane
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/graphics/py-sane/distinfo b/graphics/py-sane/distinfo
new file mode 100644
index 000000000000..032e41c036ee
--- /dev/null
+++ b/graphics/py-sane/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python/Imaging-1.1.7.tar.gz) = 895bc7c2498c8e1f9b99938f1a40dc86b3f149741f105cf7c7bd2e0725405211
+SIZE (python/Imaging-1.1.7.tar.gz) = 498749
diff --git a/graphics/py-sane/files/patch-setup.py b/graphics/py-sane/files/patch-setup.py
new file mode 100644
index 000000000000..785e5d2528cc
--- /dev/null
+++ b/graphics/py-sane/files/patch-setup.py
@@ -0,0 +1,19 @@
+--- setup.py.orig 2009-11-01 08:44:12.000000000 +0800
++++ setup.py 2011-08-05 16:18:06.000000000 +0800
+@@ -11,13 +11,13 @@
+ pass
+
+ sane = Extension('_sane',
+- include_dirs = [PIL_IMAGING_DIR],
++ include_dirs = [PIL_IMAGING_DIR, '/usr/local/include'],
+ libraries = ['sane'],
+- library_dirs = [PIL_IMAGING_DIR],
++ library_dirs = [PIL_IMAGING_DIR, '/usr/local/lib'],
+ define_macros = defs,
+ sources = ['_sane.c'])
+
+-setup (name = 'pysane',
++setup (name = 'sane',
+ version = '2.0',
+ description = 'This is the pysane package',
+ py_modules = ['sane'],
diff --git a/graphics/py-sane/pkg-descr b/graphics/py-sane/pkg-descr
new file mode 100644
index 000000000000..10daabc9a095
--- /dev/null
+++ b/graphics/py-sane/pkg-descr
@@ -0,0 +1,15 @@
+The Python binding for Sane is part of Python Imaging Library.
+
+The Python Imaging Library adds image processing capabilities to your
+Python interpreter. This library provides extensive file format
+support, an efficient internal representation, and fairly powerful
+image processing capabilities.
+
+The main distribution site for this software is:
+
+WWW: http://www.pythonware.com/products/pil/index.htm
+
+The PIL handbook is not included in this distribution; to get the
+latest version, check:
+
+ http://www.pythonware.com/library.htm
diff --git a/graphics/py-sane/pkg-plist b/graphics/py-sane/pkg-plist
new file mode 100644
index 000000000000..ef295e994453
--- /dev/null
+++ b/graphics/py-sane/pkg-plist
@@ -0,0 +1,4 @@
+%%PYTHON_SITELIBDIR%%/_sane.so
+%%PYTHON_SITELIBDIR%%/sane.py
+%%PYTHON_SITELIBDIR%%/sane.pyc
+%%PYTHON_SITELIBDIR%%/sane.pyo