aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-soya3d/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-09 00:17:17 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-09 00:17:17 +0000
commitada16c01ece321041b825e913b76a1a12761cbc0 (patch)
treea6decdd95e973cb684266590e35791e3770360f3 /graphics/py-soya3d/Makefile
parent3ed936d756a57f7a23fd2774a9a248cf29da16ba (diff)
downloadports-ada16c01ece321041b825e913b76a1a12761cbc0.tar.gz
ports-ada16c01ece321041b825e913b76a1a12761cbc0.zip
Soya 3D is a very high level 3D engine for Python.
Soya aims at being to 3D what Python is to programming : fast to learn, easy to use, while keeping good performances PR: 87008 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
Notes
Notes: svn path=/head/; revision=144625
Diffstat (limited to 'graphics/py-soya3d/Makefile')
-rw-r--r--graphics/py-soya3d/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/graphics/py-soya3d/Makefile b/graphics/py-soya3d/Makefile
new file mode 100644
index 000000000000..180fe780ecf4
--- /dev/null
+++ b/graphics/py-soya3d/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: py-soya3d
+# Date created: 2005-10-04
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= soya3d
+PORTVERSION= 0.10.1
+CATEGORIES= graphics
+MASTER_SITES= http://download.gna.org/soya/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Soya-${PORTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Soya 3D is a very high level 3D engine for Python
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging \
+ ${PYTHON_SITELIBDIR}/_openal.so:${PORTSDIR}/audio/py-openal \
+ ${PYTHON_SITELIBDIR}/pysdl_mixer/sdl_mixer.so:${PORTSDIR}/audio/py-sdl_mixer \
+ pyrexc:${PORTSDIR}/devel/pyrex
+LIB_DEPENDS= cal3d.11:${PORTSDIR}/graphics/cal3d \
+ GLEW.1:${PORTSDIR}/graphics/glew \
+ freetype.9:${PORTSDIR}/print/freetype2
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/editobj/editor.py:${PORTSDIR}/graphics/py-editobj \
+ ${PYTHON_SITELIBDIR}/tofu/client.py:${PORTSDIR}/net/py-tofu
+
+USE_BZIP2= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_GL= yes
+USE_GMAKE= yes
+
+MANDIR= ${WRKDIR}/${DISTNAME}/manpage/man1
+MAN1= soya_editor.1
+INSTALL_DIR= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m ${BINMODE}
+
+.if !defined(NOPORTDOCS)
+DISTFILES+= SoyaTutorial-${PORTVERSION}${EXTRACT_SUFX}
+.endif
+
+post-install:
+ @${INSTALL_DIR} ${EXAMPLESDIR}
+ @${CP} -R ${WRKDIR}/SoyaTutorial-${PORTVERSION}/tutorial/* ${EXAMPLESDIR}
+.if !defined(NOPORTDOCS)
+ @${INSTALL_DIR} ${DOCSDIR}
+ @${CP} -R ${WRKDIR}/SoyaTutorial-${PORTVERSION}/doc/* ${DOCSDIR}
+ @${FIND} ${EXAMPLESDIR}/* -type f -print0 | \
+ ${XARGS} -0 ${CHMOD} ${SHAREMODE}
+.for f in ${MAN1}
+ ${INSTALL_MAN} ${MANDIR}/${f} ${PREFIX}/man/man1
+.endfor
+.endif
+
+.include <bsd.port.mk>