aboutsummaryrefslogtreecommitdiff
path: root/graphics/qslim/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /graphics/qslim/Makefile
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'graphics/qslim/Makefile')
-rw-r--r--graphics/qslim/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/graphics/qslim/Makefile b/graphics/qslim/Makefile
index 1a41e7574595..73bd97a1dfab 100644
--- a/graphics/qslim/Makefile
+++ b/graphics/qslim/Makefile
@@ -17,20 +17,20 @@ COMMENT= SlimKit Surface Modeling Tools
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
- forms.1:${PORTSDIR}/x11-toolkits/xforms \
- glut.4:${PORTSDIR}/graphics/libglut
+ forms.1:${PORTSDIR}/x11-toolkits/xforms
CONFIGURE_WRKSRC= ${WRKSRC}/mixkit/build
BUILD_WRKSRC= ${WRKSRC}/mixkit/src
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_GL= glut
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
ALL_TARGET= # none
-CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include \
- -I${X11BASE}/include/X11 ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS= -I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/X11 ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CFLAGS+= -DMIX_ANSI_IOSTREAMS -fpermissive