aboutsummaryrefslogtreecommitdiff
path: root/graphics/radius-engine/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-18 04:40:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-18 04:40:50 +0000
commitcb208bc502607f6ffd5bc251b7e84cce4f1b8a10 (patch)
treed1acf53ae0656db74859f511d1239b66e083441d /graphics/radius-engine/Makefile
parent49b6b9e46a709d4aaf3345e58384068769ff5336 (diff)
downloadports-cb208bc502607f6ffd5bc251b7e84cce4f1b8a10.tar.gz
ports-cb208bc502607f6ffd5bc251b7e84cce4f1b8a10.zip
Radius Engine is a Lua script-based real-time 2D graphics engine designed
for rapidly prototyping games. Built on top of SDL and OpenGL, games made with Radius Engine are portable to both Windows and Linux. WWW: http://radius-engine.sourceforge.net/ PR: ports/168083 Submitted by: nemysis@gmx.ch
Notes
Notes: svn path=/head/; revision=296880
Diffstat (limited to 'graphics/radius-engine/Makefile')
-rw-r--r--graphics/radius-engine/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/graphics/radius-engine/Makefile b/graphics/radius-engine/Makefile
new file mode 100644
index 000000000000..2163fc6fae1c
--- /dev/null
+++ b/graphics/radius-engine/Makefile
@@ -0,0 +1,39 @@
+# New Ports collection makefile for: Radius Engine
+# Date created: 2012-05-17
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= radius-engine
+PORTVERSION= 1.1
+CATEGORIES= graphics devel
+MASTER_SITES= SF/${PORTNAME}/
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Lua script-based 2D engine built on top of OpenGL and SDL
+
+LICENSE= MIT
+
+LIB_DEPENDS= lua-5.1:${PORTSDIR}/lang/lua \
+ png:${PORTSDIR}/graphics/png \
+ physfs.1:${PORTSDIR}/devel/physfs
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CFLAGS+= -I${LOCALBASE}/include
+USE_SDL= sdl sound
+USE_GL= glu
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= include/radius.h \
+ lib/libradius-engine.a \
+ libdata/pkgconfig/radius-engine.pc
+PLIST_DIRSTRY= libdata/pkgconfig
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|lua5.1|lua-5.1|g' \
+ ${WRKSRC}/acinclude.m4 ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|(pkgconfigdir)|{PREFIX}/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>