aboutsummaryrefslogtreecommitdiff
path: root/graphics/rawtherapee
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-10-07 18:28:48 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-10-07 18:28:48 +0000
commitd3657c4a8cc0fae434ea289551ac05f709dda4df (patch)
treeeca4cb31a05d4f899f384b7808e6d67652b7974d /graphics/rawtherapee
parentf4b2d5508ee0bcb7330e07525b74e7307a70e567 (diff)
downloadports-d3657c4a8cc0fae434ea289551ac05f709dda4df.tar.gz
ports-d3657c4a8cc0fae434ea289551ac05f709dda4df.zip
Support staging, revise LIB_DEPENDS.
Notes
Notes: svn path=/head/; revision=329722
Diffstat (limited to 'graphics/rawtherapee')
-rw-r--r--graphics/rawtherapee/Makefile24
-rw-r--r--graphics/rawtherapee/pkg-plist15
2 files changed, 26 insertions, 13 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index d017c533f814..92f1c53c63a4 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -11,22 +11,21 @@ COMMENT= A powerful RAW image processing application
LICENSE= GPLv3
-LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
- iptcdata:${PORTSDIR}/graphics/libiptcdata \
- jpeg:${PORTSDIR}/graphics/jpeg \
- lcms2:${PORTSDIR}/graphics/lcms2 \
- png15:${PORTSDIR}/graphics/png \
- tiff:${PORTSDIR}/graphics/tiff \
- sigc-2.0:${PORTSDIR}/devel/libsigc++20 \
- fftw3:${PORTSDIR}/math/fftw3 \
- fftw3f:${PORTSDIR}/math/fftw3-float \
- canberra-gtk3:${PORTSDIR}/audio/libcanberra-gtk3
+LIB_DEPENDS= libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ libiptcdata.so:${PORTSDIR}/graphics/libiptcdata \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2 \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20 \
+ libfftw3.so:${PORTSDIR}/math/fftw3 \
+ libfftw3f.so:${PORTSDIR}/math/fftw3-float \
+ libcanberra-gtk3.so:${PORTSDIR}/audio/libcanberra-gtk3
USES= cmake:outsource pkgconfig
USE_XZ= yes
USE_GNOME= gtk20 glib20
USE_LDCONFIG= yes
-NO_STAGE= yes
# base GCC and clang in 9.1-RELEASE are insufficient:
USE_GCC= yes
CFLAGS+= -I${LOCALBASE}/include -fPIC ${PTHREAD_CFLAGS}
@@ -44,7 +43,6 @@ CMAKE_ARGS+= -DDOCDIR="${DOCSDIR}" \
SUB_FILES= rawtherapee
SUB_LIST= RTDIR="${RTDIR}"
INSTALLS_ICONS= yes
-MAN1= rawtherapee.1
RTDIR= ${PREFIX}/libdata/${PORTNAME}
@@ -62,7 +60,7 @@ post-patch:
# paranoia: run rawtherapee --help to be sure it finds all its
# shared libraries (this hinges on proper RPATH setting and propagation)
post-install:
- ${PREFIX}/bin/rawtherapee --help 2>&1 \
+ ${SETENV} HOME=/dev/null ${STAGEDIR}${PREFIX}/bin/rawtherapee --help 2>&1 \
| ${EGREP} -q "RawTherapee, version ${PKGVERSION:C/_.*//:C/,.*//}"
.include <bsd.port.pre.mk>
diff --git a/graphics/rawtherapee/pkg-plist b/graphics/rawtherapee/pkg-plist
index 0b6ead0353ba..9c98bbb21cb0 100644
--- a/graphics/rawtherapee/pkg-plist
+++ b/graphics/rawtherapee/pkg-plist
@@ -1,4 +1,5 @@
bin/rawtherapee
+man/man1/rawtherapee.1.gz
share/applications/rawtherapee.desktop
%%DOCSDIR%%/AUTHORS.txt
%%DOCSDIR%%/AboutThisBuild.txt
@@ -765,4 +766,18 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
@dirrm %%DATADIR%%/dcpprofiles
@dirrm %%DATADIR%%
@dirrm %%DOCSDIR%%
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/256x256/apps
+@dirrmtry share/icons/hicolor/256x256
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/24x24
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor/128x128/apps
+@dirrmtry share/icons/hicolor/128x128
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
@dirrmtry share/applications