aboutsummaryrefslogtreecommitdiff
path: root/graphics/reallyslick/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-26 07:03:25 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-26 07:03:25 +0000
commite539569db18162db024510937e548046f8010a87 (patch)
tree9a0e00b598ea856a1eb17c12f8be947392805b82 /graphics/reallyslick/Makefile
parent4a64a01f61cb276a512a6f6e9e20d1eb3e0d240b (diff)
downloadports-e539569db18162db024510937e548046f8010a87.tar.gz
ports-e539569db18162db024510937e548046f8010a87.zip
Fix build with linker that does not copy the dt_need from libraries it links
with like recent binutils. [1] Trim header Convert to USES=gmake Obtained from: DPorts [1]
Notes
Notes: svn path=/head/; revision=323700
Diffstat (limited to 'graphics/reallyslick/Makefile')
-rw-r--r--graphics/reallyslick/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/graphics/reallyslick/Makefile b/graphics/reallyslick/Makefile
index 054dfe784b25..1ef7d34555dc 100644
--- a/graphics/reallyslick/Makefile
+++ b/graphics/reallyslick/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: reallyslick
-# Date created: 24 Nov 2002
-# Whom: David Yeske <dyeske@gmail.com>
-#
+# Created by: David Yeske <dyeske@gmail.com>
# $FreeBSD$
-#
PORTNAME= reallyslick
PORTVERSION= 0.9.1
@@ -24,8 +20,7 @@ GLEW_DESC= Enable GLEW support
USE_BZIP2= yes
USE_GL= glut
-USES= pathfix
-USE_GMAKE= yes
+USES= pathfix gmake
GNU_CONFIGURE= yes
MAN1= biof.1 busyspheres.1 colorfire.1 cyclone.1 drempels.1 \
@@ -35,7 +30,7 @@ MAN1= biof.1 busyspheres.1 colorfire.1 cyclone.1 drempels.1 \
solarwinds.1 spirographx.1 sundancer2.1
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib -lXext
.include <bsd.port.options.mk>