aboutsummaryrefslogtreecommitdiff
path: root/graphics/ruby-ming
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-10-16 09:38:27 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-10-16 09:38:27 +0000
commitc698265f5c18e66ec0ef024decd43a8d2e59634d (patch)
tree25ea05ab058cda5565978a0461d4f4bdfb49d07e /graphics/ruby-ming
parent2c023b45faec592702a5f2ee64f0cc87ac6e006d (diff)
downloadports-c698265f5c18e66ec0ef024decd43a8d2e59634d.tar.gz
ports-c698265f5c18e66ec0ef024decd43a8d2e59634d.zip
Add ruby-ming, Ruby module for the Ming library which allows you to
create Flash (TM) movies.
Notes
Notes: svn path=/head/; revision=33888
Diffstat (limited to 'graphics/ruby-ming')
-rw-r--r--graphics/ruby-ming/Makefile43
-rw-r--r--graphics/ruby-ming/files/patch-depend17
-rw-r--r--graphics/ruby-ming/pkg-comment1
-rw-r--r--graphics/ruby-ming/pkg-descr4
-rw-r--r--graphics/ruby-ming/pkg-plist5
5 files changed, 70 insertions, 0 deletions
diff --git a/graphics/ruby-ming/Makefile b/graphics/ruby-ming/Makefile
new file mode 100644
index 000000000000..f651b011bbf2
--- /dev/null
+++ b/graphics/ruby-ming/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: Ruby/Ming
+# Date created: 16 Oct 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ming
+PORTVERSION= 0.0.2e
+CATEGORIES= graphics ruby
+MASTER_SITES= http://www.opaque.net/ming/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= swig1.3:${PORTSDIR}/devel/SWIG-devel
+LIB_DEPENDS= ming.0:${PORTSDIR}/graphics/ming
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+MD5_FILE= ${PORTSDIR}/graphics/ming/distinfo
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/rb_ext
+CONFIGURE_ARGS= --with-ming-include="${LOCALBASE}/include/ming"
+INSTALL_TARGET= site-install
+
+EXAMPLES= shape.rb test.rb
+
+post-extract:
+ ${LN} -sf ${WRKSRC}/../py_ext/*.i ${WRKSRC}/
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/ming.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/ming
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/ming/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/ruby-ming/files/patch-depend b/graphics/ruby-ming/files/patch-depend
new file mode 100644
index 000000000000..3af7c1ae3ad6
--- /dev/null
+++ b/graphics/ruby-ming/files/patch-depend
@@ -0,0 +1,17 @@
+--- depend.orig Fri Oct 13 15:26:31 2000
++++ depend Mon Oct 16 17:55:07 2000
+@@ -1,4 +1,4 @@
+-SWIGINC= ../py_ext
++SWIGINC= .
+
+ OBJS+= ming_wrap.o
+
+@@ -7,7 +7,7 @@
+ ming_wrap.o: ming_wrap.c
+
+ ming_wrap.c: ${SWIGINC}/blocklist.i ${SWIGINC}/blocktypes.i ${SWIGINC}/ming.i ${SWIGINC}/swf.i
+- swig -I${SWIGINC} -ruby ${SWIGINC}/ming.i
++ swig1.3 -I${SWIGINC} -ruby ${SWIGINC}/ming.i
+
+ clean: clean_local
+
diff --git a/graphics/ruby-ming/pkg-comment b/graphics/ruby-ming/pkg-comment
new file mode 100644
index 000000000000..f562bd6b0fd4
--- /dev/null
+++ b/graphics/ruby-ming/pkg-comment
@@ -0,0 +1 @@
+Ruby module for the Ming library which allows you to create Flash (TM) movies
diff --git a/graphics/ruby-ming/pkg-descr b/graphics/ruby-ming/pkg-descr
new file mode 100644
index 000000000000..d4e542f5df44
--- /dev/null
+++ b/graphics/ruby-ming/pkg-descr
@@ -0,0 +1,4 @@
+This is a Ruby module for the Ming library based on Python module.
+Ming allows you to create Flash (TM) movies.
+
+Author: Kazuki Sakamoto <sakamoto@splhack.org>
diff --git a/graphics/ruby-ming/pkg-plist b/graphics/ruby-ming/pkg-plist
new file mode 100644
index 000000000000..f2307c0763fd
--- /dev/null
+++ b/graphics/ruby-ming/pkg-plist
@@ -0,0 +1,5 @@
+%%RUBY_SITEARCHLIBDIR%%/mingc.so
+%%RUBY_SITELIBDIR%%/ming.rb
+%%RUBY_EXAMPLESDIR%%/ming/shape.rb
+%%RUBY_EXAMPLESDIR%%/ming/test.rb
+@dirrm %%RUBY_EXAMPLESDIR%%/ming