aboutsummaryrefslogtreecommitdiff
path: root/graphics/ruby-qt2gl
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-19 22:15:52 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-19 22:15:52 +0000
commit6abf760566c8eae0c89d0fed5cca2a9a0fc03b5c (patch)
tree2c8f25241d1d2e433fa822ee05905813062a7f77 /graphics/ruby-qt2gl
parent60efde8367ec048ce37709d84cfc81c34518f197 (diff)
downloadports-6abf760566c8eae0c89d0fed5cca2a9a0fc03b5c.tar.gz
ports-6abf760566c8eae0c89d0fed5cca2a9a0fc03b5c.zip
Use the threaded version of Qt2 library for 5-CURRENT.
Mark ruby-qt2gl broken for 4-STABLE due to the thread library problem.
Notes
Notes: svn path=/head/; revision=40071
Diffstat (limited to 'graphics/ruby-qt2gl')
-rw-r--r--graphics/ruby-qt2gl/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/graphics/ruby-qt2gl/Makefile b/graphics/ruby-qt2gl/Makefile
index ece13250f31e..21dc4ea40040 100644
--- a/graphics/ruby-qt2gl/Makefile
+++ b/graphics/ruby-qt2gl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qt2gl
PORTVERSION= ${RUBY_QT2_PORTVERSION}
+PORTREVISION= 1
CATEGORIES= graphics x11-toolkits ruby
MASTER_SITES= ${RUBY_QT2_MASTER_SITES}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -25,13 +26,11 @@ USE_RUBY_EXTCONF= yes
USE_GMAKE= yes
+.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../x11-toolkits/ruby-qt2/Makefile.common"
WRKSRC= ${RUBY_QT2_WRKSRC}/modules/opengl
-CONFIGURE_ARGS= --with-qt2-include=${X11BASE}/include/qt2 \
- --with-qt2-lib=${X11BASE}/lib \
- --with-qt2=qt2 \
- --with-x11-dir=${X11BASE}
+CONFIGURE_ARGS= ${RUBY_QT2_CONFIGURE_ARGS}
MAKE_ARGS= LOCAL_LIBS=-lgcc
INSTALL_TARGET= site-install
@@ -46,4 +45,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/${PORTNAME}/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>