aboutsummaryrefslogtreecommitdiff
path: root/graphics/rubygem-graphviz
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-22 12:56:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-22 12:56:16 +0000
commit366d9419094b1729dd03243895ada625f8564506 (patch)
tree9a5bc4844ec9098b41250a146dae0facbd85b56a /graphics/rubygem-graphviz
parent5b4bbe44aeb3b552e8619aba5c6caf9d9b6e0654 (diff)
downloadports-366d9419094b1729dd03243895ada625f8564506.tar.gz
ports-366d9419094b1729dd03243895ada625f8564506.zip
This modules provides an interface to layout and generate images
of directed graphs in a variety of formats (PostScript, PNG, etc.) using GraphViz. WWW: http://raa.ruby-lang.org/project/ruby-graphviz/ PR: ports/132918 Submitted by: Wen Heping <wenheping at gmail.com>
Notes
Notes: svn path=/head/; revision=230657
Diffstat (limited to 'graphics/rubygem-graphviz')
-rw-r--r--graphics/rubygem-graphviz/Makefile28
-rw-r--r--graphics/rubygem-graphviz/distinfo3
-rw-r--r--graphics/rubygem-graphviz/pkg-descr5
3 files changed, 36 insertions, 0 deletions
diff --git a/graphics/rubygem-graphviz/Makefile b/graphics/rubygem-graphviz/Makefile
new file mode 100644
index 000000000000..4a7b9efbeb30
--- /dev/null
+++ b/graphics/rubygem-graphviz/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: graphviz
+# Date created: 21 march, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= graphviz
+PORTVERSION= 0.9.0
+CATEGORIES= graphics ruby
+MASTER_SITES= RF
+MASTER_SITE_SUBDIR= ruby-asp
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Ruby Interface to the GraphViz Graphing Tool
+
+RUN_DEPENDS= ${LOCALBASE}/bin/gxl2dot:${PORTSDIR}/graphics/graphviz
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+GEM_NAME= ${DISTNAME}
+RUBYGEM_AUTOPLIST= yes
+
+post-install:
+ @${ECHO} 'bin/ruby2gv' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/graphics/rubygem-graphviz/distinfo b/graphics/rubygem-graphviz/distinfo
new file mode 100644
index 000000000000..a2bf8464f7d6
--- /dev/null
+++ b/graphics/rubygem-graphviz/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/ruby-graphviz-0.9.0.gem) = cf1517ec27480a980ae0f20a39b9860d
+SHA256 (rubygem/ruby-graphviz-0.9.0.gem) = bf24e1179a45ec064d0748c744055bc18283dcd0e4eeafdc804488a8836eab0d
+SIZE (rubygem/ruby-graphviz-0.9.0.gem) = 34816
diff --git a/graphics/rubygem-graphviz/pkg-descr b/graphics/rubygem-graphviz/pkg-descr
new file mode 100644
index 000000000000..af7b7404edbe
--- /dev/null
+++ b/graphics/rubygem-graphviz/pkg-descr
@@ -0,0 +1,5 @@
+This modules provides an interface to layout and generate images
+of directed graphs in a variety of formats (PostScript, PNG, etc.)
+using GraphViz.
+
+WWW: http://raa.ruby-lang.org/project/ruby-graphviz/