aboutsummaryrefslogtreecommitdiff
path: root/graphics/seom
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2010-01-14 19:11:45 +0000
committerBruce M Simpson <bms@FreeBSD.org>2010-01-14 19:11:45 +0000
commit351b7b50fe2297e131af61783e6b72c9374c5f70 (patch)
tree623e89986976e70b75d710526d63bb3c6aa39ac2 /graphics/seom
parent1d924da9fe462c8ed5dc4d90d01a9ced86fdf81b (diff)
downloadports-351b7b50fe2297e131af61783e6b72c9374c5f70.tar.gz
ports-351b7b50fe2297e131af61783e6b72c9374c5f70.zip
seom is a library to allow OpenGL application output to be captured.
Notes
Notes: svn path=/head/; revision=247876
Diffstat (limited to 'graphics/seom')
-rw-r--r--graphics/seom/Makefile55
-rw-r--r--graphics/seom/distinfo3
-rw-r--r--graphics/seom/files/patch-Makefile53
-rw-r--r--graphics/seom/pkg-descr9
-rw-r--r--graphics/seom/pkg-plist19
5 files changed, 139 insertions, 0 deletions
diff --git a/graphics/seom/Makefile b/graphics/seom/Makefile
new file mode 100644
index 000000000000..6ce2ae1d41fb
--- /dev/null
+++ b/graphics/seom/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: seom
+# Date created: 12th January 2010
+# Whom: bms
+#
+# $FreeBSD$
+#
+
+PORTNAME= seom
+PORTVERSION= 2010011201
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= bms
+DISTNAME= seom-${PORTVERSION}
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Real-time capture library for OpenGL applications
+
+NOMAN= defined
+
+USE_BZIP2= yes
+USE_GCC= 4.2+
+USE_GMAKE= yes
+USE_XORG= x11 xv
+USE_GL= yes
+USE_LDCONFIG= yes
+
+MAKE_JOBS_SAFE= defined
+MAKE_ENV+= DATADIR="${DATADIR}" PREFIX="${PREFIX}"
+
+#
+# To roll snapshot: as bms: make BOOTSTRAP=defined fetch
+#
+.if defined(BOOTSTRAP)
+FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+SVN_REV= 196 # svn tip at epoch 2009120801
+SVNROOT_URI= https://devel.neopsis.com/svn/seom
+
+do-fetch:
+ ${MKDIR} ${WRKDIR}
+ svn export -r ${SVN_REV} ${SVNROOT_URI}/trunk ${WRKSRC}
+ cd ${WRKDIR}; tar cvfy ${DISTDIR}/${DISTNAME}.tar.bz2 ${DISTNAME}
+.if ${USER} == bms
+ ${CHMOD} ugo+r ${DISTDIR}/${DISTNAME}.tar.bz2
+ scp -p ${DISTDIR}/${DISTNAME}.tar.bz2 \
+ freefall.freebsd.org:public_distfiles/
+.endif
+.endif # defined(BOOTSTRAP)
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+IGNORE= unsupported on FreeBSD versions prior to 7.0
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/seom/distinfo b/graphics/seom/distinfo
new file mode 100644
index 000000000000..379f6c46753a
--- /dev/null
+++ b/graphics/seom/distinfo
@@ -0,0 +1,3 @@
+MD5 (seom-2010011201.tar.bz2) = ba4ff6771f895fa18a15ceacacf9ad26
+SHA256 (seom-2010011201.tar.bz2) = fcfb18f4aaf6f221eef1ea765fbbec965fb6180ac35879f9a3a19319a8f20bb0
+SIZE (seom-2010011201.tar.bz2) = 24242
diff --git a/graphics/seom/files/patch-Makefile b/graphics/seom/files/patch-Makefile
new file mode 100644
index 000000000000..ed0f0ea945fc
--- /dev/null
+++ b/graphics/seom/files/patch-Makefile
@@ -0,0 +1,53 @@
+Index: Makefile
+===================================================================
+--- Makefile (revision 196)
++++ Makefile (working copy)
+@@ -2,8 +2,11 @@
+ MAJOR = 0
+ LIBRARY = libseom.so
+
+-DESTDIR =
++DESTDIR ?=
++
++# XXX override passed in
+ LIBDIR = lib
++LIBDATADIR = libdata
+
+ CC = gcc
+ ASM = yasm
+@@ -11,8 +14,11 @@
+ CFLAGS = -Iinclude -std=c99
+ LDFLAGS = -Wl,--as-needed
+
+-include config.make
++###include config.make
+
++ARCH = C
++CFLAGS += -I${LOCALBASE}/include -L${LOCALBASE}/lib
++
+ OBJS = src/buffer.o src/client.o src/codec.o src/frame.o src/opengl.o \
+ src/server.o src/stream.o src/arch/$(ARCH)/frame.o
+
+@@ -29,7 +35,7 @@
+ $(CC) $(CFLAGS) -fPIC -c -o $@ $<
+
+ $(LIBRARY): $(OBJS)
+- $(CC) -shared $(LDFLAGS) -Wl,-soname,$@.$(MAJOR) -o $@ $(OBJS) -ldl -lpthread
++ $(CC) -shared $(LDFLAGS) -Wl,-soname,$@.$(MAJOR) -o $@ $(OBJS) -lpthread
+
+ $(APPS): $(LIBRARY)
+ $(CC) $(CFLAGS) $(LDFLAGS) -L. -o $@ src/$@/main.c -lseom $($@LIBS)
+@@ -39,11 +45,11 @@
+
+ inst = install -m 755 -d $(DESTDIR)$(3); install -m $(1) $(2) $(DESTDIR)$(3)$(if $(4),/$(4));
+ install: $(LIBRARY) $(APPS) seom.pc
+- $(call inst,644,seom.pc,$(PREFIX)/$(LIBDIR)/pkgconfig)
++ $(call inst,644,seom.pc,$(PREFIX)/$(LIBDATADIR)/pkgconfig)
+ $(call inst,755,$(LIBRARY),$(PREFIX)/$(LIBDIR),$(LIBRARY).$(MAJOR))
+ ln -sf $(LIBRARY).$(MAJOR) $(DESTDIR)$(PREFIX)/$(LIBDIR)/$(LIBRARY)
+
+- $(call inst,644,art/seom.svg,$(PREFIX)/share/seom,seom.svg)
++ $(call inst,644,art/seom.svg,$(DATADIR),seom.svg)
+ $(call inst,644,include/seom/*,$(PREFIX)/include/seom)
+ $(call inst,755,src/scripts/backup,$(PREFIX)/bin,seom-backup)
+ $(foreach app,$(APPS),$(call inst,755,$(app),$(PREFIX)/bin,seom-$(app)))
diff --git a/graphics/seom/pkg-descr b/graphics/seom/pkg-descr
new file mode 100644
index 000000000000..89ad3b124418
--- /dev/null
+++ b/graphics/seom/pkg-descr
@@ -0,0 +1,9 @@
+Yukon is a set of libraries and applications that are designed to
+capture realtime videos of OpenGL applications (games). The original
+design idea is based on Anandtech's FrameGetter, but was extended
+to suit today's high-performance computers.
+
+WWW: https://devel.neopsis.com/projects/yukon/
+
+Bruce
+bms@FreeBSD.org
diff --git a/graphics/seom/pkg-plist b/graphics/seom/pkg-plist
new file mode 100644
index 000000000000..51951bb59c54
--- /dev/null
+++ b/graphics/seom/pkg-plist
@@ -0,0 +1,19 @@
+bin/seom-backup
+bin/seom-filter
+bin/seom-player
+bin/seom-server
+lib/libseom.so
+lib/libseom.so.0
+libdata/pkgconfig/seom.pc
+include/seom/buffer.h
+include/seom/client.h
+include/seom/codec.h
+include/seom/frame.h
+include/seom/seom.h
+include/seom/server.h
+include/seom/stream.h
+%%DATADIR%%/seom.svg
+@dirrmtry libdata/pkgconfig
+@dirrmtry libdata
+@dirrm include/seom
+@dirrm share/seom