aboutsummaryrefslogtreecommitdiff
path: root/graphics/skencil
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-04-18 08:18:24 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-04-18 08:18:24 +0000
commitb1a77e3423b036caacfa0a417a27ae8c67b4b84b (patch)
tree1c85ccf0ca08b3a71d3926b2c3d9f79c476b3de1 /graphics/skencil
parentd5d2b7649bbaa03192defdec55146a31ed918621 (diff)
downloadports-b1a77e3423b036caacfa0a417a27ae8c67b4b84b.tar.gz
ports-b1a77e3423b036caacfa0a417a27ae8c67b4b84b.zip
Add patch to make skencil work with python 2.4.
PR: ports/79280 Submitted by: Marian Cerny <jojo@matfyz.cz> Approved by: clement (mentor)
Notes
Notes: svn path=/head/; revision=133563
Diffstat (limited to 'graphics/skencil')
-rw-r--r--graphics/skencil/Makefile9
-rw-r--r--graphics/skencil/files/py24-patch-Pax_paxtkinter.c25
2 files changed, 33 insertions, 1 deletions
diff --git a/graphics/skencil/Makefile b/graphics/skencil/Makefile
index 5e7336f645d8..09febcdf4a12 100644
--- a/graphics/skencil/Makefile
+++ b/graphics/skencil/Makefile
@@ -7,6 +7,7 @@
PORTNAME= skencil
PORTVERSION= 0.6.16
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sketch
@@ -23,6 +24,12 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinte
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_VERSION} == "python2.4"
+EXTRA_PATCHES= ${FILESDIR}/py24-patch-Pax_paxtkinter.c
+.endif
+
CONFFLAGS= --tk-autoconf --tk-flags="-I${X11BASE}/include -I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include/tk8.4 -L${LOCALBASE}/lib -ltk84 -ltcl84 -L${X11BASE}/lib -lX11"
SKETCHDOCS= BUGS Doc NEWS PROJECTS README TODO
@@ -56,4 +63,4 @@ do-install:
${CHOWN} ${BINOWN}:${BINGROUP} ${PREFIX}/bin/${exec}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/skencil/files/py24-patch-Pax_paxtkinter.c b/graphics/skencil/files/py24-patch-Pax_paxtkinter.c
new file mode 100644
index 000000000000..cd1ea8d6ab85
--- /dev/null
+++ b/graphics/skencil/files/py24-patch-Pax_paxtkinter.c
@@ -0,0 +1,25 @@
+--- Pax/paxtkinter.c.orig Sun May 4 04:55:36 2003
++++ Pax/paxtkinter.c Mon Apr 18 12:40:08 2005
+@@ -1866,6 +1866,9 @@
+ char *className = NULL;
+ int interactive = 0;
+
++ int ignored_int = 0;
++ char *ignored_charp = NULL;
++
+ baseName = strrchr(Py_GetProgramName(), '/');
+ if (baseName != NULL)
+ baseName++;
+@@ -1873,9 +1876,10 @@
+ baseName = Py_GetProgramName();
+ className = "Tk";
+
+- if (!PyArg_ParseTuple(args, "|zssi",
++ if (!PyArg_ParseTuple(args, "|zssiiiiz:create",
+ &screenName, &baseName, &className,
+- &interactive))
++ &interactive, &ignored_int, &ignored_int,
++ &ignored_int, &ignored_charp))
+ return NULL;
+
+ return (PyObject *) Tkapp_New(screenName, baseName, className,