aboutsummaryrefslogtreecommitdiff
path: root/graphics/sng
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-20 11:47:11 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-03-20 11:47:11 +0000
commit0705706341cac86a725fd6d09339bc5dfa30e200 (patch)
tree39e4e5e93f95d682be23dbf96ba593be635d84a7 /graphics/sng
parent6c70d3fc1eb1af725f9ccf4a2809008688a1628f (diff)
downloadports-0705706341cac86a725fd6d09339bc5dfa30e200.tar.gz
ports-0705706341cac86a725fd6d09339bc5dfa30e200.zip
add sng
The sng program translates between PNG (Portable Network Graphics) format and SNG (Scriptable Network Graphics) format.
Notes
Notes: svn path=/head/; revision=40096
Diffstat (limited to 'graphics/sng')
-rw-r--r--graphics/sng/Makefile27
-rw-r--r--graphics/sng/distinfo1
-rw-r--r--graphics/sng/pkg-comment1
-rw-r--r--graphics/sng/pkg-descr8
-rw-r--r--graphics/sng/pkg-plist2
5 files changed, 39 insertions, 0 deletions
diff --git a/graphics/sng/Makefile b/graphics/sng/Makefile
new file mode 100644
index 000000000000..ca79dbd09eaa
--- /dev/null
+++ b/graphics/sng/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: sng
+# Date created: Mar 20, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sng
+PORTVERSION= 0.9.4
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-png-inc=${LOCALBASE}/include
+
+USE_GMAKE= yes
+
+MAN1= sng.1
+
+.include <bsd.port.mk>
diff --git a/graphics/sng/distinfo b/graphics/sng/distinfo
new file mode 100644
index 000000000000..034678f29413
--- /dev/null
+++ b/graphics/sng/distinfo
@@ -0,0 +1 @@
+MD5 (sng-0.9.4.tar.gz) = da494aaa1e88f50228474691931bf765
diff --git a/graphics/sng/pkg-comment b/graphics/sng/pkg-comment
new file mode 100644
index 000000000000..ae7bb01b33bc
--- /dev/null
+++ b/graphics/sng/pkg-comment
@@ -0,0 +1 @@
+compiler/decompiler for Scriptable Network Graphics
diff --git a/graphics/sng/pkg-descr b/graphics/sng/pkg-descr
new file mode 100644
index 000000000000..323bbd7a906a
--- /dev/null
+++ b/graphics/sng/pkg-descr
@@ -0,0 +1,8 @@
+The sng program translates between PNG (Portable Network Graphics) format
+and SNG (Scriptable Network Graphics) format. SNG is a printable and
+editable minilanguage for describing PNG files. With sng, it is easy to
+view and edit exotic PNG chunks not supported by graphics editors; also,
+since SNG is easy to generate from scripts, sng may be useful at the end
+of a pipeline that programmatically generates PNG images.
+
+WWW: http://sng.sourceforge.net/
diff --git a/graphics/sng/pkg-plist b/graphics/sng/pkg-plist
new file mode 100644
index 000000000000..7f35477e2fc9
--- /dev/null
+++ b/graphics/sng/pkg-plist
@@ -0,0 +1,2 @@
+bin/sng
+bin/sng_regress