aboutsummaryrefslogtreecommitdiff
path: root/graphics/swftools
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-02-08 22:35:40 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-02-08 22:35:40 +0000
commit897e73951876210990508ccf9621e76b1ef86ac1 (patch)
tree49180ee9c740b209abf0b53ecc2f2ea6b3d6261e /graphics/swftools
parentba145dde76952f28161067f7292201e4fe2030af (diff)
downloadports-897e73951876210990508ccf9621e76b1ef86ac1.tar.gz
ports-897e73951876210990508ccf9621e76b1ef86ac1.zip
- Fix LIB_DEPENDS
- Add common patch for Xpdf library - Bump PORTREVISION PR: 108882 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=184631
Diffstat (limited to 'graphics/swftools')
-rw-r--r--graphics/swftools/Makefile20
-rw-r--r--graphics/swftools/files/patch-Makefile.in17
-rw-r--r--graphics/swftools/files/patch-lib__pdf__xpdf__gmem.c50
-rw-r--r--graphics/swftools/files/patch-lib__pdf__xpdf__gmem.h29
4 files changed, 108 insertions, 8 deletions
diff --git a/graphics/swftools/Makefile b/graphics/swftools/Makefile
index 1589e306c4b8..70cb61d323c7 100644
--- a/graphics/swftools/Makefile
+++ b/graphics/swftools/Makefile
@@ -8,6 +8,7 @@
PORTNAME= swftools
PORTVERSION= 0.8.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.swftools.org/
@@ -17,28 +18,31 @@ COMMENT= SWF manipulation and generation utilities
LIB_DEPENDS= t1.5:${PORTSDIR}/devel/t1lib \
jpeg.9:${PORTSDIR}/graphics/jpeg \
ungif.5:${PORTSDIR}/graphics/libungif \
- freetype.9:${PORTSDIR}/print/freetype2 \
- fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+ freetype.9:${PORTSDIR}/print/freetype2
-USE_BISON= yes
-USE_GNOME= pkgconfig
+USE_GNOME= gnometarget pkgconfig
+USE_GCC= 3.4+
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
-CPPFLAGS= `pkg-config --cflags-only-I fontconfig freetype2` \
- -I${LOCALBASE}/include
-LDFLAGS= `pkg-config --libs-only-L fontconfig freetype2` \
- -L${LOCALBASE}/lib
MAN1= font2swf.1 gif2swf.1 jpeg2swf.1 pdf2swf.1 png2swf.1 \
swfbbox.1 swfc.1 swfcombine.1 swfdump.1 swfextract.1 \
swfstrings.1 wav2swf.1
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
.if defined(WITH_LAME) || exists(${LOCALBASE}/lib/libmp3lame.a)
LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
.else
CONFIGURE_ARGS+= --disable-lame
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's| -O | |g ; \
+ s|/usr/local/include|${LOCALBASE}/include|g ; \
+ s|/usr/local/lib|${LOCALBASE}/lib|g' ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/graphics/swftools/files/patch-Makefile.in b/graphics/swftools/files/patch-Makefile.in
new file mode 100644
index 000000000000..c8609a1842a3
--- /dev/null
+++ b/graphics/swftools/files/patch-Makefile.in
@@ -0,0 +1,17 @@
+--- Makefile.in.orig Mon Jan 22 06:12:53 2007
++++ Makefile.in Mon Jan 22 12:51:20 2007
+@@ -8,14 +8,10 @@
+ cd m4;$(MAKE) $@
+ @echo making $@ in lib...
+ cd lib;$(MAKE) $@
+- @echo making $@ in lib/python...
+- cd lib/python;$(MAKE) $@
+ @echo making $@ in src...
+ cd src;$(MAKE) $@
+ @echo making $@ in pdf2swf...
+ cd pdf2swf/fonts;$(MAKE) $@
+- @echo making $@ in avi2swf...
+- cd avi2swf;$(MAKE) $@
+ @echo making $@ in swfs...
+ cd swfs;$(MAKE) $@
+ @$(MAKE) $@-local
diff --git a/graphics/swftools/files/patch-lib__pdf__xpdf__gmem.c b/graphics/swftools/files/patch-lib__pdf__xpdf__gmem.c
new file mode 100644
index 000000000000..51552825999d
--- /dev/null
+++ b/graphics/swftools/files/patch-lib__pdf__xpdf__gmem.c
@@ -0,0 +1,50 @@
+--- lib/pdf/xpdf/gmem.c.orig Wed Oct 11 02:54:28 2006
++++ lib/pdf/xpdf/gmem.c Mon Jan 22 13:06:47 2007
+@@ -47,9 +47,9 @@
+
+ #endif /* DEBUG_MEM */
+
+-void *gmalloc(int size) {
++void *gmalloc(size_t size) {
+ #ifdef DEBUG_MEM
+- int size1;
++ size_t size1;
+ char *mem;
+ GMemHdr *hdr;
+ void *data;
+@@ -98,11 +98,11 @@
+ #endif
+ }
+
+-void *grealloc(void *p, int size) {
++void *grealloc(void *p, size_t size) {
+ #ifdef DEBUG_MEM
+ GMemHdr *hdr;
+ void *q;
+- int oldSize;
++ size_t oldSize;
+
+ if (size <= 0) {
+ if (p) {
+@@ -142,8 +142,8 @@
+ #endif
+ }
+
+-void *gmallocn(int nObjs, int objSize) {
+- int n;
++void *gmallocn(int nObjs, size_t objSize) {
++ size_t n;
+
+ if (nObjs == 0) {
+ return NULL;
+@@ -156,8 +156,8 @@
+ return gmalloc(n);
+ }
+
+-void *greallocn(void *p, int nObjs, int objSize) {
+- int n;
++void *greallocn(void *p, int nObjs, size_t objSize) {
++ size_t n;
+
+ if (nObjs == 0) {
+ if (p) {
diff --git a/graphics/swftools/files/patch-lib__pdf__xpdf__gmem.h b/graphics/swftools/files/patch-lib__pdf__xpdf__gmem.h
new file mode 100644
index 000000000000..eb4266840923
--- /dev/null
+++ b/graphics/swftools/files/patch-lib__pdf__xpdf__gmem.h
@@ -0,0 +1,29 @@
+--- lib/pdf/xpdf/gmem.h.orig Wed Oct 11 02:54:28 2006
++++ lib/pdf/xpdf/gmem.h Mon Jan 22 13:07:59 2007
+@@ -19,13 +19,13 @@
+ * Same as malloc, but prints error message and exits if malloc()
+ * returns NULL.
+ */
+-extern void *gmalloc(int size);
++extern void *gmalloc(size_t size);
+
+ /*
+ * Same as realloc, but prints error message and exits if realloc()
+ * returns NULL. If <p> is NULL, calls malloc instead of realloc().
+ */
+-extern void *grealloc(void *p, int size);
++extern void *grealloc(void *p, size_t size);
+
+ /*
+ * These are similar to gmalloc and grealloc, but take an object count
+@@ -33,8 +33,8 @@
+ * bytes, but there is an additional error check that the total size
+ * doesn't overflow an int.
+ */
+-extern void *gmallocn(int nObjs, int objSize);
+-extern void *greallocn(void *p, int nObjs, int objSize);
++extern void *gmallocn(int nObjs, size_t objSize);
++extern void *greallocn(void *p, int nObjs, size_t objSize);
+
+ /*
+ * Same as free, but checks for and ignores NULL pointers.