aboutsummaryrefslogtreecommitdiff
path: root/graphics/swftools
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-06 20:04:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-06 20:04:18 +0000
commitc8bb787b992a1ad3895b460f23518a6ef768f36f (patch)
treeca1f873c0618e81f8f5b63d552070ac2462b1c11 /graphics/swftools
parent4875f8d1bf60cefdc3792c63f6f629c973b7ed85 (diff)
downloadports-c8bb787b992a1ad3895b460f23518a6ef768f36f.tar.gz
ports-c8bb787b992a1ad3895b460f23518a6ef768f36f.zip
- Update to 0.8.1
PR: 109801 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=186716
Diffstat (limited to 'graphics/swftools')
-rw-r--r--graphics/swftools/Makefile3
-rw-r--r--graphics/swftools/distinfo6
-rw-r--r--graphics/swftools/files/patch-lib__pdf__xpdf__gmem.c50
-rw-r--r--graphics/swftools/files/patch-lib__pdf__xpdf__gmem.h29
4 files changed, 4 insertions, 84 deletions
diff --git a/graphics/swftools/Makefile b/graphics/swftools/Makefile
index 70cb61d323c7..0a35284ea74a 100644
--- a/graphics/swftools/Makefile
+++ b/graphics/swftools/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= swftools
-PORTVERSION= 0.8.0
-PORTREVISION= 1
+PORTVERSION= 0.8.1
CATEGORIES= graphics
MASTER_SITES= http://www.swftools.org/
diff --git a/graphics/swftools/distinfo b/graphics/swftools/distinfo
index ac2b490da98f..b3856c9af661 100644
--- a/graphics/swftools/distinfo
+++ b/graphics/swftools/distinfo
@@ -1,3 +1,3 @@
-MD5 (swftools-0.8.0.tar.gz) = acc720839689fbf75c1b119fd00d555d
-SHA256 (swftools-0.8.0.tar.gz) = 2db4d7b88864e81727f8c8b36629749fbeaa5bc3c9ec1d8f74bc4c67837e8948
-SIZE (swftools-0.8.0.tar.gz) = 1734013
+MD5 (swftools-0.8.1.tar.gz) = 932f4e5fce551ed70c0390fdc0eb1af6
+SHA256 (swftools-0.8.1.tar.gz) = 54b067fe8f644be7bc6d2b037d10679166d7c2cee1c2876d7a4434bee260e550
+SIZE (swftools-0.8.1.tar.gz) = 1743477
diff --git a/graphics/swftools/files/patch-lib__pdf__xpdf__gmem.c b/graphics/swftools/files/patch-lib__pdf__xpdf__gmem.c
deleted file mode 100644
index 51552825999d..000000000000
--- a/graphics/swftools/files/patch-lib__pdf__xpdf__gmem.c
+++ /dev/null
@@ -1,50 +0,0 @@
---- lib/pdf/xpdf/gmem.c.orig Wed Oct 11 02:54:28 2006
-+++ lib/pdf/xpdf/gmem.c Mon Jan 22 13:06:47 2007
-@@ -47,9 +47,9 @@
-
- #endif /* DEBUG_MEM */
-
--void *gmalloc(int size) {
-+void *gmalloc(size_t size) {
- #ifdef DEBUG_MEM
-- int size1;
-+ size_t size1;
- char *mem;
- GMemHdr *hdr;
- void *data;
-@@ -98,11 +98,11 @@
- #endif
- }
-
--void *grealloc(void *p, int size) {
-+void *grealloc(void *p, size_t size) {
- #ifdef DEBUG_MEM
- GMemHdr *hdr;
- void *q;
-- int oldSize;
-+ size_t oldSize;
-
- if (size <= 0) {
- if (p) {
-@@ -142,8 +142,8 @@
- #endif
- }
-
--void *gmallocn(int nObjs, int objSize) {
-- int n;
-+void *gmallocn(int nObjs, size_t objSize) {
-+ size_t n;
-
- if (nObjs == 0) {
- return NULL;
-@@ -156,8 +156,8 @@
- return gmalloc(n);
- }
-
--void *greallocn(void *p, int nObjs, int objSize) {
-- int n;
-+void *greallocn(void *p, int nObjs, size_t objSize) {
-+ size_t n;
-
- if (nObjs == 0) {
- if (p) {
diff --git a/graphics/swftools/files/patch-lib__pdf__xpdf__gmem.h b/graphics/swftools/files/patch-lib__pdf__xpdf__gmem.h
deleted file mode 100644
index eb4266840923..000000000000
--- a/graphics/swftools/files/patch-lib__pdf__xpdf__gmem.h
+++ /dev/null
@@ -1,29 +0,0 @@
---- lib/pdf/xpdf/gmem.h.orig Wed Oct 11 02:54:28 2006
-+++ lib/pdf/xpdf/gmem.h Mon Jan 22 13:07:59 2007
-@@ -19,13 +19,13 @@
- * Same as malloc, but prints error message and exits if malloc()
- * returns NULL.
- */
--extern void *gmalloc(int size);
-+extern void *gmalloc(size_t size);
-
- /*
- * Same as realloc, but prints error message and exits if realloc()
- * returns NULL. If <p> is NULL, calls malloc instead of realloc().
- */
--extern void *grealloc(void *p, int size);
-+extern void *grealloc(void *p, size_t size);
-
- /*
- * These are similar to gmalloc and grealloc, but take an object count
-@@ -33,8 +33,8 @@
- * bytes, but there is an additional error check that the total size
- * doesn't overflow an int.
- */
--extern void *gmallocn(int nObjs, int objSize);
--extern void *greallocn(void *p, int nObjs, int objSize);
-+extern void *gmallocn(int nObjs, size_t objSize);
-+extern void *greallocn(void *p, int nObjs, size_t objSize);
-
- /*
- * Same as free, but checks for and ignores NULL pointers.