aboutsummaryrefslogtreecommitdiff
path: root/graphics/threeDS
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-01-18 19:28:48 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-01-18 19:28:48 +0000
commita318676894555e0051689bb070c6cfdb24d27561 (patch)
tree533ee1f9d93341281a2fb33a9ac3b51093888ee8 /graphics/threeDS
parentf12751a5d733c868fb427905a51f9dada487718d (diff)
downloadports-a318676894555e0051689bb070c6cfdb24d27561.tar.gz
ports-a318676894555e0051689bb070c6cfdb24d27561.zip
Two fixes:
- Properly import PIL module; - don't try to do os.chdir() with empty argument.
Notes
Notes: svn path=/head/; revision=37306
Diffstat (limited to 'graphics/threeDS')
-rw-r--r--graphics/threeDS/Makefile1
-rw-r--r--graphics/threeDS/files/patch-threeDS.py24
2 files changed, 25 insertions, 0 deletions
diff --git a/graphics/threeDS/Makefile b/graphics/threeDS/Makefile
index a6c298d0a759..58229db5bc66 100644
--- a/graphics/threeDS/Makefile
+++ b/graphics/threeDS/Makefile
@@ -7,6 +7,7 @@
PORTNAME= threeDS
PORTVERSION= 0.2
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= http://www.demonseed.net/~jp/code/threeDS/
diff --git a/graphics/threeDS/files/patch-threeDS.py b/graphics/threeDS/files/patch-threeDS.py
new file mode 100644
index 000000000000..a593642562c2
--- /dev/null
+++ b/graphics/threeDS/files/patch-threeDS.py
@@ -0,0 +1,24 @@
+
+$FreeBSD$
+
+--- threeDS.py 2001/01/18 19:26:14 1.1
++++ threeDS.py 2001/01/18 19:26:19
+@@ -82,7 +82,7 @@
+ self.imgfile = readStr(f)
+ # print "texture: " + self.imgfile
+ try:
+- from Imaging import Image
++ from PIL import Image
+ except:
+ print 'Can\'t load texture without PIL!!'
+ continue
+@@ -370,7 +370,8 @@
+
+ def __init__(self, filename):
+ (path, filename) = os.path.split(filename)
+- os.chdir(path)
++ if path != '':
++ os.chdir(path)
+ f = open(filename, "rb")
+ if f is None:
+ print "error loading " + str(filename) + "."