aboutsummaryrefslogtreecommitdiff
path: root/graphics/tiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-10-12 04:23:23 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-10-12 04:23:23 +0000
commit0da9234eb7dac7a0cf46c4ec2ec047f9953327ee (patch)
treedd89ec0612fb939304d6cf6b9e08980a6e6abc5c /graphics/tiff
parent7bac1ad54ad972d28523002c20eda75919cbe34e (diff)
downloadports-0da9234eb7dac7a0cf46c4ec2ec047f9953327ee.tar.gz
ports-0da9234eb7dac7a0cf46c4ec2ec047f9953327ee.zip
- Enable LZW compression kit for users who are able to use LZW
PR: 72039 Submitted by: Michael Johnson
Notes
Notes: svn path=/head/; revision=118772
Diffstat (limited to 'graphics/tiff')
-rw-r--r--graphics/tiff/Makefile30
-rw-r--r--graphics/tiff/distinfo2
2 files changed, 31 insertions, 1 deletions
diff --git a/graphics/tiff/Makefile b/graphics/tiff/Makefile
index cc7692ceaeba..8919984d8a52 100644
--- a/graphics/tiff/Makefile
+++ b/graphics/tiff/Makefile
@@ -14,6 +14,8 @@ CATEGORIES= graphics
MASTER_SITES= ftp://ftp.remotesensing.org/pub/libtiff/ \
http://libtiff.maptools.org/dl/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
+DISTFILES= ${PORTNAME}-v${PORTVERSION}${EXTRACT_SUFX} ${LZW_DIST}
+PKGNAMESUFFIX?= ${TIFF_SUFFIX}${PKGNAMESUFFIX2}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Tools and library routines for working with TIFF images
@@ -113,4 +115,30 @@ MLINKS= TIFFError.3t TIFFSetErrorHandler.3t \
TIFFtile.3t TIFFTileRowSize.3t \
TIFFtile.3t TIFFVTileSize.3t
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_TIFF_LZW_KIT)
+TIFF_SUFFIX= -lzw
+LZKIT= libtiff-lzw-compression-kit
+LZKIT_VER= 1.5
+LZW_DIST= ${LZKIT}-${LZKIT_VER}${EXTRACT_SUFX}
+RESTRICTED= "Redistribution not allowed"
+
+.if !exists(${DISTDIR}/${LZW_DIST})
+IGNORE= Due to patent enforcement from Unisys you must manually\
+ fetch ${LZW_DIST} from ftp://ftp.remotesensing.org/libtiff\
+ and place it in ${DISTDIR}. \
+ To use this patch legally you must live in a country where the patent\
+ does not apply or you must obtain a license from Unisys
+.endif
+
+post-patch:
+ @${CP} -f ${WRKDIR}/${LZKIT}-${LZKIT_VER}/tif_lzw.c ${WRKSRC}/libtiff
+.else
+
+pre-everything::
+ @${ECHO_MSG} "===> Enable LZW Compression by defining WITH_TIFF_LZW_KIT"
+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/tiff/distinfo b/graphics/tiff/distinfo
index 22224cb36e4c..933dc83b58d7 100644
--- a/graphics/tiff/distinfo
+++ b/graphics/tiff/distinfo
@@ -1,2 +1,4 @@
MD5 (tiff-v3.6.1.tar.gz) = b3f0ee7617593c2703755672fb1bfed3
SIZE (tiff-v3.6.1.tar.gz) = 1072165
+MD5 (libtiff-lzw-compression-kit-1.5.tar.gz) = 2cd1c94d237d47104106de3bf4f08baa
+SIZE (libtiff-lzw-compression-kit-1.5.tar.gz) = 9646