aboutsummaryrefslogtreecommitdiff
path: root/graphics/tulip/Makefile
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-02-22 10:28:47 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-02-22 10:28:47 +0000
commit4c045b983856046880d369291b0c886b81f3ecdb (patch)
tree0bfe158309bac81d0c809d9b8ef3b27119af5398 /graphics/tulip/Makefile
parentc1528b770a4056657cbcccdf85247fe0950f8cfa (diff)
downloadports-4c045b983856046880d369291b0c886b81f3ecdb.tar.gz
ports-4c045b983856046880d369291b0c886b81f3ecdb.zip
Unbreak by removing bin/tlprender from pkg-plist and explicitly
disabling it with --disable-tlprender. Building it with the current version of libOSMesa looks impossible, see ports/93667 Approved by: garga (mentor)
Notes
Notes: svn path=/head/; revision=156654
Diffstat (limited to 'graphics/tulip/Makefile')
-rw-r--r--graphics/tulip/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/graphics/tulip/Makefile b/graphics/tulip/Makefile
index d4c9a61712b1..1442f28e18fc 100644
--- a/graphics/tulip/Makefile
+++ b/graphics/tulip/Makefile
@@ -18,8 +18,6 @@ COMMENT= A system dedicated to the visualization of huge graphs
LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
-BROKEN= Incorrect pkg-plist (does not compile completely?)
-
USE_BZIP2= yes
USE_QT_VER= 3
QT_NONSTANDARD= yes
@@ -32,6 +30,12 @@ CONFIGURE_ENV= MOC="${MOC}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-qt-includes=${QT_PREFIX}/include \
--with-qt-libraries=${QT_PREFIX}/lib \
--with-extra-libs=${LOCALBASE}/lib
+# libOSMesa, installed by the xorg-libraries-6.9.0 port is causing
+# /usr/X11R6/lib/libOSMesa.so: undefined reference to `driDispatchRemapTable'
+# during the configure step which results in tlprender not being build.
+# So we remove it from pkg-plist and disable it here to make sure it does not
+# get build somehow, causing plist problems
+CONFIGURE_ARGS+= --disable-tlprender
INSTALLS_SHLIB= yes
CPPFLAGS= -I${LOCALBASE}/include -I${PREFIX}/include \