aboutsummaryrefslogtreecommitdiff
path: root/graphics/ufraw
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-11-30 06:15:03 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-11-30 06:15:03 +0000
commit5670f942eab3297be40964245250a2ffeef147a3 (patch)
tree5022e4a5fba3f40dbcbc6fb7e0c4960828df212c /graphics/ufraw
parentbfdf4cc7cf10090e748c3cee628ff64a4a7fdcf3 (diff)
downloadports-5670f942eab3297be40964245250a2ffeef147a3.tar.gz
ports-5670f942eab3297be40964245250a2ffeef147a3.zip
In sight of upcoming update, cleanup things a bit (reformat, fix whitespace,
reorder some knobs, add LICENSE, etc). Feature safe: yes
Notes
Notes: svn path=/head/; revision=286653
Diffstat (limited to 'graphics/ufraw')
-rw-r--r--graphics/ufraw/Makefile42
1 files changed, 25 insertions, 17 deletions
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index 49a77a90e6d7..76aa36322bd7 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -1,6 +1,6 @@
# New ports collection makefile for: UFRaw
# Date created: Sun 10 Apr 2005 14:44:15 BST
-# Whom: markm@FreeBSD.org
+# Whom: Mark Murray <markm@FreeBSD.org>
#
# $FreeBSD$
#
@@ -14,6 +14,8 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Read and manipulate raw images from digital cameras
+LICENSE= GPLv2
+
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
png.6:${PORTSDIR}/graphics/png \
@@ -25,15 +27,17 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gtk20 glib20 gnomehack intltool intlhack libartlgpl2 pkgconfig
-LDFLAGS+= -L"${LOCALBASE}/lib" ${PTHREAD_LIBS}
-CPPFLAGS+= -I"${LOCALBASE}/include"
-PC_FALSE+= cinepaint
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+PC_FALSE= cinepaint
+
+MAN1= ufraw.1
-OPTIONS= CONTRAST "Enable contrast setting" on \
- DST "Use local time for timestamps" off \
- EXIV2 "EXIF support via exiv2 library" on \
- FITS "Enable FITS output support" off \
- GIMP "Install GIMP UFRaw plugin" on \
+OPTIONS= CONTRAST "Enable contrast setting" on \
+ DST "Use local time for timestamps" off \
+ EXIV2 "EXIF support via exiv2 library" on \
+ FITS "Enable FITS output support" off \
+ GIMP "Install GIMP UFRaw plugin" on \
LENSFUN "Build with LensFun library support" on
.include <bsd.port.pre.mk>
@@ -43,6 +47,7 @@ LIB_DEPENDS+= exiv2.10:${PORTSDIR}/graphics/exiv2
.else
PC_FALSE+= exiv2
.endif
+
.if !defined(WITHOUT_GIMP)
LIB_DEPENDS+= gimp-2.0.0:${PORTSDIR}/graphics/gimp-app
PLIST_SUB+= GIMP=""
@@ -50,32 +55,35 @@ PLIST_SUB+= GIMP=""
PC_FALSE+= gimp
PLIST_SUB+= GIMP="@comment "
.endif
+
.if !defined(WITHOUT_LENSFUN) || exists(${LOCALBASE}/lib/lensfun.so.2)
LIB_DEPENDS+= lensfun.2:${PORTSDIR}/graphics/lensfun
.endif
+
.if defined(WITH_FITS) || exists(${LOCALBASE}/lib/libcfitsio.so)
LIB_DEPENDS+= cfitsio.0:${PORTSDIR}/astro/cfitsio
.endif
+
.if !defined(WITHOUT_CONTRAST)
CONFIGURE_ARGS+= --enable-contrast
.endif
+
.if defined(WITH_DST)
CONFIGURE_ARGS+= --enable-dst-correction
.endif
-MAN1= ufraw.1
-
post-patch:
- @${REINPLACE_CMD} -e '18s|^$$|#include <sys/types.h>|' ${WRKSRC}/dcraw.h
+ @${REINPLACE_CMD} -e '18s|^$$|#include <sys/types.h>|' \
+ ${WRKSRC}/dcraw.h
@${REINPLACE_CMD} -e '/@schemasdir/s|datadir|sysconfdir|' \
- ${WRKSRC}/Makefile.in
+ ${WRKSRC}/Makefile.in
.for i in ${PC_FALSE}
- @${REINPLACE_CMD} -e '/PKG_CONFIG.*$i/s|$$PKG_CONFIG|${FALSE}|' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/PKG_CONFIG.*${i}/s|$$PKG_CONFIG|${FALSE}|' \
+ ${WRKSRC}/configure
.endfor
pre-build:
- ${INSTALL_SCRIPT} ${LOCALBASE}/share/glib-2.0/gettext/mkinstalldirs \
- ${WRKSRC}/
+ @${INSTALL_SCRIPT} ${LOCALBASE}/share/glib-2.0/gettext/mkinstalldirs \
+ ${WRKSRC}
.include <bsd.port.post.mk>