aboutsummaryrefslogtreecommitdiff
path: root/graphics/urt
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-10-05 03:06:04 +0000
committerSteve Price <steve@FreeBSD.org>1998-10-05 03:06:04 +0000
commit802ef209411e50dc00c963a289649adcab3fa50e (patch)
tree4a734eabbc448ce164a8e88250ffbfcf9b2f0ffe /graphics/urt
parent9db5d22a99cc8629a1eabc0aa0593f263a0b77d4 (diff)
downloadports-802ef209411e50dc00c963a289649adcab3fa50e.tar.gz
ports-802ef209411e50dc00c963a289649adcab3fa50e.zip
Convert to ELF.
Notes
Notes: svn path=/head/; revision=13649
Diffstat (limited to 'graphics/urt')
-rw-r--r--graphics/urt/files/patch-aa2
-rw-r--r--graphics/urt/files/patch-ab91
-rw-r--r--graphics/urt/files/patch-ad101
-rw-r--r--graphics/urt/pkg-plist5
4 files changed, 106 insertions, 93 deletions
diff --git a/graphics/urt/files/patch-aa b/graphics/urt/files/patch-aa
index f7014db08c8a..49bae83dca5f 100644
--- a/graphics/urt/files/patch-aa
+++ b/graphics/urt/files/patch-aa
@@ -153,7 +153,7 @@
-LIBTIFF = $(TIFFDIR)/libtiff.a
+##defpath TIFFDIR
+INCTIFF = -I${PREFIX}/include/tiff34
-+LIBTIFF = -L${PREFIX}/lib -ltiff34
++LIBTIFF = -L${PREFIX}/lib -ltiff34 -ljpeg
#endif
#ifdef X10
diff --git a/graphics/urt/files/patch-ab b/graphics/urt/files/patch-ab
index bdb7827cc980..bb0a51a01bf6 100644
--- a/graphics/urt/files/patch-ab
+++ b/graphics/urt/files/patch-ab
@@ -37,97 +37,6 @@ diff -ur ../urt-3.1b-orig/lib/buildmap.c ./lib/buildmap.c
#include "rle.h"
#include <math.h>
-diff -ur ../urt-3.1b-orig/lib/makefile.src ./lib/makefile.src
---- ../urt-3.1b-orig/lib/makefile.src Wed Mar 4 16:32:53 1992
-+++ ./lib/makefile.src Sat Sep 16 10:44:35 1995
-@@ -26,7 +26,10 @@
- vaxshort.o \
- $(OPT_OBJS)
-
--LIBNAME = librle.a
-+SOOBJS = $(OBJS:.o=.so)
-+
-+LIBANAME = librle.a
-+LIBSONAME = librle.so.1.0
-
- # Just rebuild the object files.
- objs: $(OBJS)
-@@ -37,23 +40,13 @@
- # Do nothing if $(DEST) is empty (or not defined)
- install: buildlib
- @sh -c "if test '$(DEST)x' != x ; then \
-- echo cp $(LIBNAME) $(DEST)/$(LIBNAME) ; \
-- cp $(LIBNAME) $(DEST)/$(LIBNAME) ; \
-+ echo cp $(LIBANAME) $(DEST)/$(LIBANAME) ; \
-+ cp $(LIBANAME) $(DEST)/$(LIBANAME) ; \
-+ echo cp $(LIBSONAME) $(DEST)/$(LIBSONAME) ; \
-+ cp $(LIBSONAME) $(DEST)/$(LIBSONAME) ; \
- if test x$(RANLIB) != x ; then \
-- echo ranlib $(DEST)/$(LIBNAME) ; \
-- ranlib $(DEST)/$(LIBNAME) ; \
-- else \
-- true ; \
-- fi ; \
-- if test -d $(DEST)/debug ; then \
-- echo cp $(LIBNAME) $(DEST)/debug/$(LIBNAME) ; \
-- if test x$(RANLIB) != x ; then \
-- cp $(LIBNAME) $(DEST)/debug/$(LIBNAME) ; \
-- echo ranlib $(DEST)/debug/$(LIBNAME) ; \
-- else \
-- true ; \
-- fi ; \
-- ranlib $(DEST)/debug/$(LIBNAME) ; \
-+ echo ranlib $(DEST)/$(LIBANAME) ; \
-+ ranlib $(DEST)/$(LIBANAME) ; \
- else \
- true ; \
- fi ; \
-@@ -63,14 +56,24 @@
- touch install
-
- # Rebuild the library from all the .o files.
--buildlib: $(OBJS)
-- -rm -f $(LIBNAME)
-- ar rc $(LIBNAME)
-- ar q $(LIBNAME) $(OBJS)
-+buildlib: $(LIBANAME) $(LIBSONAME)
-+
-+$(LIBANAME): $(OBJS)
-+ -rm -f $@
-+ ar rc $@ $?
- #ifndef NO_RANLIB
-- ranlib $(LIBNAME)
-+ ranlib $@
- #endif
-- touch buildlib
-+
-+.SUFFIXES: .so .o
-+
-+.c.so:
-+ $(CC) -fPIC -DPIC $(CFLAGS) -c $*.c -o $*.so
-+ $(LD) -X -r $*.so
-+
-+$(LIBSONAME): $(SOOBJS)
-+ -rm -f $@
-+ ld -Bshareable -o $@ $>
-
- # Clean up installed stuff and binaries
- pristine: clean
-@@ -86,9 +89,12 @@
- # Get rid of everything which must be recompiled on a different computer.
- clean:
- -rm -f *.o
-+ -rm -f *.so
- -@if test x$(DEST) != x ; then \
-- echo rm -f $(LIBNAME) ; \
-- rm -f $(LIBNAME) ; \
-+ echo rm -f $(LIBANAME) ; \
-+ rm -f $(LIBANAME) ; \
-+ echo rm -f $(LIBSONAME) ; \
-+ rm -f $(LIBSONAME) ; \
- else \
- true ; \
- fi
diff -ur ../urt-3.1b-orig/makefile.src ./makefile.src
--- ../urt-3.1b-orig/makefile.src Fri Jun 7 11:58:13 1991
+++ ./makefile.src Fri Sep 15 22:09:01 1995
diff --git a/graphics/urt/files/patch-ad b/graphics/urt/files/patch-ad
new file mode 100644
index 000000000000..4ca49d6b5d8e
--- /dev/null
+++ b/graphics/urt/files/patch-ad
@@ -0,0 +1,101 @@
+--- lib/makefile.src.orig Wed Mar 4 13:32:53 1992
++++ lib/makefile.src Sat Oct 3 23:57:51 1998
+@@ -26,7 +26,14 @@
+ vaxshort.o \
+ $(OPT_OBJS)
+
+-LIBNAME = librle.a
++SOOBJS = $(OBJS:.o=.so)
++
++LIBANAME = librle.a
++.if $(PORTOBJFORMAT) == "elf"
++LIBSONAME = librle.so.1
++.else
++LIBSONAME = librle.so.1.0
++.endif
+
+ # Just rebuild the object files.
+ objs: $(OBJS)
+@@ -37,23 +44,14 @@
+ # Do nothing if $(DEST) is empty (or not defined)
+ install: buildlib
+ @sh -c "if test '$(DEST)x' != x ; then \
+- echo cp $(LIBNAME) $(DEST)/$(LIBNAME) ; \
+- cp $(LIBNAME) $(DEST)/$(LIBNAME) ; \
++ echo cp $(LIBANAME) $(DEST)/$(LIBANAME) ; \
++ cp $(LIBANAME) $(DEST)/$(LIBANAME) ; \
++ echo cp $(LIBSONAME) $(DEST)/$(LIBSONAME) ; \
++ cp $(LIBSONAME) $(DEST)/$(LIBSONAME) ; \
++ ln -sf $(LIBSONAME) $(DEST)/librle.so ; \
+ if test x$(RANLIB) != x ; then \
+- echo ranlib $(DEST)/$(LIBNAME) ; \
+- ranlib $(DEST)/$(LIBNAME) ; \
+- else \
+- true ; \
+- fi ; \
+- if test -d $(DEST)/debug ; then \
+- echo cp $(LIBNAME) $(DEST)/debug/$(LIBNAME) ; \
+- if test x$(RANLIB) != x ; then \
+- cp $(LIBNAME) $(DEST)/debug/$(LIBNAME) ; \
+- echo ranlib $(DEST)/debug/$(LIBNAME) ; \
+- else \
+- true ; \
+- fi ; \
+- ranlib $(DEST)/debug/$(LIBNAME) ; \
++ echo ranlib $(DEST)/$(LIBANAME) ; \
++ ranlib $(DEST)/$(LIBANAME) ; \
+ else \
+ true ; \
+ fi ; \
+@@ -63,14 +61,30 @@
+ touch install
+
+ # Rebuild the library from all the .o files.
+-buildlib: $(OBJS)
+- -rm -f $(LIBNAME)
+- ar rc $(LIBNAME)
+- ar q $(LIBNAME) $(OBJS)
++buildlib: $(LIBANAME) $(LIBSONAME)
++
++$(LIBANAME): $(OBJS)
++ -rm -f $@
++ ar rc $@ $?
+ #ifndef NO_RANLIB
+- ranlib $(LIBNAME)
++ ranlib $@
+ #endif
+- touch buildlib
++
++.SUFFIXES: .so .o
++
++.c.so:
++ $(CC) -fPIC -DPIC $(CFLAGS) -c $*.c -o $*.so
++ $(LD) -X -r $*.so
++
++.if $(PORTOBJFORMAT) == "elf"
++$(LIBSONAME): $(SOOBJS)
++ -rm -f $@
++ ld -shared -soname $@ -o $@ $>
++.else
++$(LIBSONAME): $(SOOBJS)
++ -rm -f $@
++ ld -Bshareable -o $@ $>
++.endif
+
+ # Clean up installed stuff and binaries
+ pristine: clean
+@@ -86,9 +100,12 @@
+ # Get rid of everything which must be recompiled on a different computer.
+ clean:
+ -rm -f *.o
++ -rm -f *.so
+ -@if test x$(DEST) != x ; then \
+- echo rm -f $(LIBNAME) ; \
+- rm -f $(LIBNAME) ; \
++ echo rm -f $(LIBANAME) ; \
++ rm -f $(LIBANAME) ; \
++ echo rm -f $(LIBSONAME) ; \
++ rm -f $(LIBSONAME) ; \
+ else \
+ true ; \
+ fi
diff --git a/graphics/urt/pkg-plist b/graphics/urt/pkg-plist
index a27cce2be720..da47e8a78247 100644
--- a/graphics/urt/pkg-plist
+++ b/graphics/urt/pkg-plist
@@ -74,7 +74,10 @@ include/rle_config.h
include/rle_put.h
include/rle_raw.h
lib/librle.a
-lib/librle.so.1.0
+lib/librle.so
+lib/librle.so.1
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
@comment if compressed RLE.5 doesn't work.
man/man5/RLE.5
man/man5/rle.5