aboutsummaryrefslogtreecommitdiff
path: root/graphics/vertex/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /graphics/vertex/Makefile
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'graphics/vertex/Makefile')
-rw-r--r--graphics/vertex/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/graphics/vertex/Makefile b/graphics/vertex/Makefile
index d10caa42ed23..e5296f7c1156 100644
--- a/graphics/vertex/Makefile
+++ b/graphics/vertex/Makefile
@@ -41,10 +41,9 @@ post-patch:
s|%%CXX%%|${CXX}|g ; \
s|%%CXXFLAGS%%|${CXXFLAGS}|g ; \
s|%%PREFIX%%|${PREFIX}|g ; \
- s|%%LOCALBASE%%|${LOCALBASE}|g ; \
- s|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/vertex/platforms.ini
+ s|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/vertex/platforms.ini
@${REINPLACE_CMD} -e \
- 's|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/vertex/vmahelp.c
+ 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/vertex/vmahelp.c
@${REINPLACE_CMD} -e \
's|CC =|CC ?=|g' ${WRKSRC}/pconf/Makefile