aboutsummaryrefslogtreecommitdiff
path: root/graphics/vp
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
commitb185046be2ec03555daaf4f26d38542c403a9955 (patch)
tree0274ce607614533de66837fc1f70d4c35770d9e1 /graphics/vp
parent88d002074007544d532f2495aeb93729291e6275 (diff)
downloadports-b185046be2ec03555daaf4f26d38542c403a9955.tar.gz
ports-b185046be2ec03555daaf4f26d38542c403a9955.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead.
Notes
Notes: svn path=/head/; revision=84842
Diffstat (limited to 'graphics/vp')
-rw-r--r--graphics/vp/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/graphics/vp/Makefile b/graphics/vp/Makefile
index 36a031c21d30..d447985628f9 100644
--- a/graphics/vp/Makefile
+++ b/graphics/vp/Makefile
@@ -7,19 +7,22 @@
PORTNAME= vp
PORTVERSION= 1.5
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://math.smsu.edu/~erik/files/
MAINTAINER= markp@FreeBSD.org
COMMENT= An image viewer for X
-LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+USE_GETOPT_LONG=yes
USE_LIBTOOL= yes
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lgnugetopt" \
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ SDL_CONFIG="${SDL_CONFIG}" \
ac_cv_func_getopt_long=yes
USE_REINPLACE= yes
MAN1= vp.1