aboutsummaryrefslogtreecommitdiff
path: root/graphics/wildmagic
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /graphics/wildmagic
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'graphics/wildmagic')
-rw-r--r--graphics/wildmagic/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/graphics/wildmagic/Makefile b/graphics/wildmagic/Makefile
index 31ac830c8df5..1e778bf48675 100644
--- a/graphics/wildmagic/Makefile
+++ b/graphics/wildmagic/Makefile
@@ -16,7 +16,7 @@ COMMENT= The Wild Magic Real-Time 3D Graphics Engine
USE_ZIP= yes
USE_DOS2UNIX= yes
-USE_GL= yes
+USE_GL= gl glut
USE_GMAKE= yes
USE_LDCONFIG= yes
@@ -26,8 +26,8 @@ MAKEFILE= makefile.wm${MV}
ALL_TARGET= build
MAKE_ARGS= CFG=${CONFIG} SYS=${OPSYS:L} GRF=${GRF}
MAKE_ENV= CC=${CXX} GCC=${CXX} AR=${AR} EGL=${EGL} EGL0=glx EGL1=Glx \
- INCPATH="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LIBPATH="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+ INCPATH="-I${LOCALBASE}/include" \
+ LIBPATH="-L${LOCALBASE}/lib" \
XLIBS="-lX11 -lXext" GLIBS="-lGL -lGLU"
PLIST_SUB= CFG=${CONFIG} GRF=${GRF} WM=Wm${MV}