aboutsummaryrefslogtreecommitdiff
path: root/graphics/xli
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>2005-06-04 07:01:13 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>2005-06-04 07:01:13 +0000
commit5514ee6daf6d434e6e7a039dbde09b041c7f0e6e (patch)
tree4c4c3871a746086f4a79d482ee38379de98674e0 /graphics/xli
parent60a578e0f55233be30da98e70e04a152c7670e00 (diff)
downloadports-5514ee6daf6d434e6e7a039dbde09b041c7f0e6e.tar.gz
ports-5514ee6daf6d434e6e7a039dbde09b041c7f0e6e.zip
Update to fix vulnerability CAN-2005-0639.
Security: CAN-2005-0639 Security: http://www.vuxml.org/freebsd/bfbbd505-3bd6-409c-8c67-445d3635cf4b.html Prodded by: nectar
Notes
Notes: svn path=/head/; revision=136779
Diffstat (limited to 'graphics/xli')
-rw-r--r--graphics/xli/Makefile14
-rw-r--r--graphics/xli/distinfo4
-rw-r--r--graphics/xli/files/patch-aa2
-rw-r--r--graphics/xli/files/patch-rlelib.c10
4 files changed, 13 insertions, 17 deletions
diff --git a/graphics/xli/Makefile b/graphics/xli/Makefile
index b1632cf8a72d..42d2e83154df 100644
--- a/graphics/xli/Makefile
+++ b/graphics/xli/Makefile
@@ -7,11 +7,12 @@
PORTNAME= xli
PORTVERSION= 1.17.0
-PORTREVISION= 1
-CATEGORIES= graphics x11
-MASTER_SITES= ${MASTER_SITE_XCONTRIB} \
- http://pantransit.reptiles.org/prog/
+PORTREVISION= 2
+CATEGORIES= graphics
+MASTER_SITES= http://pantransit.reptiles.org/prog/xli/ \
+ ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= applications
+DISTNAME= xli-${XLI_SNAPVER}
MAINTAINER= jkoshy@FreeBSD.org
COMMENT= Xli, xsetbg, xview, xlito - utilities to display images on X11
@@ -19,10 +20,15 @@ COMMENT= Xli, xsetbg, xview, xlito - utilities to display images on X11
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
+WRKSRC= ${WRKDIR}/xli-${XLI_SNAPVER}
+
+USE_XLIB= yes
USE_IMAKE= yes
USE_PERL5_BUILD=yes
MAN1= xli.1 xlito.1
+XLI_SNAPVER= 2005-02-27
+
post-patch:
@${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/Imakefile
diff --git a/graphics/xli/distinfo b/graphics/xli/distinfo
index 568d8ae5abb4..2ba49603fc77 100644
--- a/graphics/xli/distinfo
+++ b/graphics/xli/distinfo
@@ -1,2 +1,2 @@
-MD5 (xli-1.17.0.tar.gz) = 996d8cd0b2be2071332412c6802852e6
-SIZE (xli-1.17.0.tar.gz) = 200069
+MD5 (xli-2005-02-27.tar.gz) = db470da53500017fd6969457c12c98f7
+SIZE (xli-2005-02-27.tar.gz) = 201011
diff --git a/graphics/xli/files/patch-aa b/graphics/xli/files/patch-aa
index 2ea0ca5ec1dc..ddf4be1ac411 100644
--- a/graphics/xli/files/patch-aa
+++ b/graphics/xli/files/patch-aa
@@ -16,7 +16,7 @@
LOCAL_LIBRARIES = $(XLIB) $(JPEG_LDFLAGS) $(PNG_LDFLAGS) -ljpeg -lpng -lz
SYS_LIBRARIES = -lm
-DEFINES = -DHAS_MEMCPY
-+DEFINES = -DHAS_MEMCPY -DHAVE_GUNZIP
++DEFINES = -DHAS_MEMCPY -DHAVE_GUNZIP -DHAVE_BUNZIP2
EXTRA_INCLUDES = $(JPEG_INCLUDES) $(PNG_INCLUDES)
SRCS1 = bright.c clip.c cmuwmrast.c compress.c dither.c faces.c fbm.c fill.c g3.c gif.c halftone.c imagetypes.c img.c mac.c mcidas.c mc_tables.c merge.c misc.c new.c options.c path.c pbm.c pcx.c reduce.c jpeg.c rle.c rlelib.c root.c rotate.c send.c smooth.c sunraster.c value.c window.c xbitmap.c xli.c xpixmap.c xwd.c zio.c zoom.c ddxli.c tga.c bmp.c pcd.c png.c
diff --git a/graphics/xli/files/patch-rlelib.c b/graphics/xli/files/patch-rlelib.c
deleted file mode 100644
index 37d73c0a2d5a..000000000000
--- a/graphics/xli/files/patch-rlelib.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- rlelib.c-- Mon Oct 25 02:15:03 1999
-+++ rlelib.c Wed Oct 15 22:31:26 2003
-@@ -12,7 +12,6 @@
- */
-
- #include "xli.h"
--#include <varargs.h>
- #include <ctype.h>
- #include "rle.h"
-