aboutsummaryrefslogtreecommitdiff
path: root/graphics/xmandel
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-06-28 11:51:05 +0000
commit932db7c46c9a269808dfa67ea02746b350c194d8 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /graphics/xmandel
parentb9b5e71f19dfde1a969d42e0660cc786432b3500 (diff)
downloadports-932db7c46c9a269808dfa67ea02746b350c194d8.tar.gz
ports-932db7c46c9a269808dfa67ea02746b350c194d8.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Notes
Notes: svn path=/head/; revision=321957
Diffstat (limited to 'graphics/xmandel')
-rw-r--r--graphics/xmandel/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/xmandel/Makefile b/graphics/xmandel/Makefile
index 6722da6f7d24..f98244e56635 100644
--- a/graphics/xmandel/Makefile
+++ b/graphics/xmandel/Makefile
@@ -17,7 +17,7 @@ COMMENT= Window based interface to Mandelbrot sets and Julia sets
EXTRACT_CMD= ${SH}
EXTRACT_BEFORE_ARGS= # empty
EXTRACT_AFTER_ARGS= # empty
-USE_IMAKE= yes
+USES= imake
USE_XORG= ice sm x11 xaw xext xmu xt
USE_PERL5_BUILD=yes
NO_WRKSUBDIR= yes