aboutsummaryrefslogtreecommitdiff
path: root/graphics/xmms-fishmatic
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-08-29 01:14:43 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-08-29 01:14:43 +0000
commit1fe61b3507142cb36cb8ee2b3c08f49b94a1156a (patch)
tree8809211a7b310e90bbde2d77a5fba167a95950d6 /graphics/xmms-fishmatic
parent23d6fa02d1306a86a596771536550015a7cdace3 (diff)
downloadports-1fe61b3507142cb36cb8ee2b3c08f49b94a1156a.tar.gz
ports-1fe61b3507142cb36cb8ee2b3c08f49b94a1156a.zip
o Style changes in Makefile
o Improve the patch o USE_GNOMENG o No PORTREVISION bump since there were no functional changes Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=65200
Diffstat (limited to 'graphics/xmms-fishmatic')
-rw-r--r--graphics/xmms-fishmatic/Makefile19
-rw-r--r--graphics/xmms-fishmatic/files/patch-configure9
2 files changed, 11 insertions, 17 deletions
diff --git a/graphics/xmms-fishmatic/Makefile b/graphics/xmms-fishmatic/Makefile
index 5967d07ac317..23eb8c9b4ed1 100644
--- a/graphics/xmms-fishmatic/Makefile
+++ b/graphics/xmms-fishmatic/Makefile
@@ -5,11 +5,10 @@
# $FreeBSD$
#
-PORTNAME= fishmatic
+PORTNAME= xmms-fishmatic
PORTVERSION= 0.0.1
CATEGORIES= graphics
MASTER_SITES= http://stukach.com/hosted/
-PKGNAMEPREFIX= xmms-
DISTNAME= fishmatic
MAINTAINER= dyeske@yahoo.com
@@ -17,18 +16,22 @@ MAINTAINER= dyeske@yahoo.com
BUILD_DEPENDS= xmms-config:${PORTSDIR}/audio/xmms
RUN_DEPENDS= xmms:${PORTSDIR}/audio/xmms
-INSTALLS_SHLIB= yes
-USE_LIBTOOL= yes
+USE_X_PREFIX= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
USE_GMAKE= yes
-USE_GTK= yes
USE_MESA= yes
-USE_X_PREFIX= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBS="-lGL -lXext ${LIBS}"
CFLAGS+= -I${X11BASE}/include -L${X11BASE}/lib
post-patch:
@${RM} -f ${WRKSRC}/config.cache
- @${PERL} -pi -e 's@glib-config@${GLIB_CONFIG}@g;' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O2||; \
+ s|-lpthreads|${PTHREAD_LIBS:S/"//g}|g' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>
diff --git a/graphics/xmms-fishmatic/files/patch-configure b/graphics/xmms-fishmatic/files/patch-configure
index b3c7d96f737c..346c63b28577 100644
--- a/graphics/xmms-fishmatic/files/patch-configure
+++ b/graphics/xmms-fishmatic/files/patch-configure
@@ -11,15 +11,6 @@ $FreeBSD$
{ (eval echo configure:3248: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
-@@ -3275,7 +3275,7 @@
- echo $ac_n "(cached) $ac_c" 1>&6
- else
- ac_save_LIBS="$LIBS"
--LIBS="-lGL $LIBS"
-+LIBS="-lGL $PTHREAD_LIBS -lX11 -lXext $LIBS"
- cat > conftest.$ac_ext <<EOF
- #line 3281 "configure"
- #include "confdefs.h"
@@ -3364,7 +3364,7 @@
#include "confdefs.h"
#include <GL/glx.h>