aboutsummaryrefslogtreecommitdiff
path: root/graphics/xpdf4/Makefile
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2018-04-20 01:54:02 +0000
committerCy Schubert <cy@FreeBSD.org>2018-04-20 01:54:02 +0000
commitb4aef4b80b865d2bdd1d7828df5bb889f2ff3567 (patch)
treed8e3587478290fc101433e31dcc27ea1eb14e79d /graphics/xpdf4/Makefile
parentd06281fc0fdc84504aa155513bf803b8fd51c14d (diff)
downloadports-b4aef4b80b865d2bdd1d7828df5bb889f2ff3567.tar.gz
ports-b4aef4b80b865d2bdd1d7828df5bb889f2ff3567.zip
Add xpdf.desktop files to both xpdf ports so that it is possible to set
xpdf to be the default PDF viewer via xdg-mime. PR: 227627 Submitted by: 0mp@
Notes
Notes: svn path=/head/; revision=467809
Diffstat (limited to 'graphics/xpdf4/Makefile')
-rw-r--r--graphics/xpdf4/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/xpdf4/Makefile b/graphics/xpdf4/Makefile
index a95d08ce157c..958515498ea3 100644
--- a/graphics/xpdf4/Makefile
+++ b/graphics/xpdf4/Makefile
@@ -2,6 +2,7 @@
PORTNAME= xpdf
PORTVERSION= 4.00
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics print
MASTER_SITES= https://xpdfreader-dl.s3.amazonaws.com/
@@ -45,10 +46,12 @@ GUI_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Widgets:BOOL=TRUE
GUI_DESC= QT5 interface
GUI_CMAKE_ARGS+= -DNO_TEXT_SELECT:BOOL=OFF
GUI_USE= QT5=buildtools_build,qmake_build,concurrent,core,gui,widgets,printsupport,svg
+GUI_PLIST_SUB= DESKTOPDIR="${DESKTOPDIR}"
+GUI_USES= desktop-file-utils
PRINT_CMAKE_ON= -DXPDFWIDGET_PRINTING:BOOL=ON -DCUPS:BOOL=ON
PRINT_CMAKE_OFF= -DXPDFWIDGET_PRINTING:BOOL=OFF -DCUPS:BOOL=OFF
-PRINT_DESC= Print support (CUPS dependency)
+PRINT_DESC= Print support (CUPS dependency)
PRINT_LDFLAGS= -L${LOCALBASE}/lib
PRINT_LIB_DEPENDS= libcups.so:print/cups
@@ -60,4 +63,7 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/xpdf-man.conf \
${STAGEDIR}${PREFIX}/etc/man.d/xpdf.conf
+post-install-GUI-on:
+ ${INSTALL_DATA} ${FILESDIR}/xpdf.desktop ${STAGEDIR}${DESKTOPDIR}
+
.include <bsd.port.mk>