aboutsummaryrefslogtreecommitdiff
path: root/graphics/zathura
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-01-23 19:32:29 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-01-23 19:32:29 +0000
commit0360de1526c239f34998ca9eaea21322124972f6 (patch)
treeef40bb0a45c3103a382ac94210f98f9906fa38fe /graphics/zathura
parentaf54201b3f23546b96189cd59bf642fdb4ae1759 (diff)
downloadports-0360de1526c239f34998ca9eaea21322124972f6.tar.gz
ports-0360de1526c239f34998ca9eaea21322124972f6.zip
- Update zathura [1], zathura-djvu [2] and zathura-pdf-poppler [3] to 0.2.2
- Remove ABI version number from LIB_DEPENDS [1] - Remove unneeded FETCH_ARGS [4] - Convert graphics/zathura to new options framework [5] - Remove reference to non existent port in zathura pkg-message [5] PR: ports/175506 - ports/175515 [2], ports/175513 [1] [5], ports/175516 [3] Submitted by: Alexander <alexander.4mail@gmail.com> (maintainer of graphics/zathura-djvu) Quentin Stievenart <acieroid@awesom.eu> (maintainer of graphics/zathura) Approved by: Alexander <alexander.4mail@gmail.com> [4], Quentin Stievenart <acieroid@awesom.eu> [5]
Notes
Notes: svn path=/head/; revision=310886
Diffstat (limited to 'graphics/zathura')
-rw-r--r--graphics/zathura/Makefile18
-rw-r--r--graphics/zathura/distinfo4
-rw-r--r--graphics/zathura/files/patch-render.c36
-rw-r--r--graphics/zathura/pkg-message3
4 files changed, 47 insertions, 14 deletions
diff --git a/graphics/zathura/Makefile b/graphics/zathura/Makefile
index 0c204ae61676..4156313fa374 100644
--- a/graphics/zathura/Makefile
+++ b/graphics/zathura/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= zathura
-PORTVERSION= 0.2.1
-PORTREVISION= 1
+PORTVERSION= 0.2.2
CATEGORIES= graphics print
MASTER_SITES= http://pwmt.org/projects/zathura/download/
@@ -11,32 +10,31 @@ MAINTAINER= acieroid@awesom.eu
COMMENT= Customizable lightweight pdf viewer
LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo \
- girara-gtk2.1:${PORTSDIR}/x11-toolkits/girara
+ girara-gtk2:${PORTSDIR}/x11-toolkits/girara
USE_GNOME= glib20 gtk20
USE_GMAKE= yes
MAKE_ENV= SFLAGS="${STRIP}"
-FETCH_ARGS= -Fpr
-OPTIONS= SQLITE "Support sqlite database backend" off
+OPTIONS_DEFINE= DOCS NLS SQLITE
.include <bsd.port.options.mk>
-.if !defined(WITHOUT_SQLITE)
+.if ${PORT_OPTIONS:MSQLITE}
LIB_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3
MAKE_ENV+= WITH_SQLITE=1
.else
MAKE_ENV+= WITH_SQLITE=0
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
BUILD_DEPENDS+= rst2html:${PORTSDIR}/textproc/py-docutils
MAN1+= zathura.1
MAN5+= zathurarc.5
MAKE_ENV+= RSTTOMAN=${LOCALBASE}/bin/rst2man
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
@@ -49,13 +47,13 @@ post-patch: .SILENT
${WRKSRC}/Makefile
${REINPLACE_CMD} -e 's|PLUGINDIR ?= .*$$|PLUGINDIR ?= ${PREFIX}/lib/zathura|'\
${WRKSRC}/config.mk
-.if defined(NOPORTDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e 's|install-manpages$$||'\
${WRKSRC}/Makefile
${REINPLACE_CMD} -e 's|RSTTOMAN ?= /usr/bin/rst2man|RSTTOMAN ?= ""|'\
${WRKSRC}/config.mk
.endif
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
${REINPLACE_CMD} -e '/-C po/d'\
${WRKSRC}/Makefile
.endif
diff --git a/graphics/zathura/distinfo b/graphics/zathura/distinfo
index 53cddf28b657..efc81c1d7d58 100644
--- a/graphics/zathura/distinfo
+++ b/graphics/zathura/distinfo
@@ -1,2 +1,2 @@
-SHA256 (zathura-0.2.1.tar.gz) = 075b9def201c77ca738dc9e15b252bc23c085b7c4671a1810d1d962e8d0bd790
-SIZE (zathura-0.2.1.tar.gz) = 95179
+SHA256 (zathura-0.2.2.tar.gz) = 6506237ba76ce1611dc24ddd870853d753b5e70e5200d75d2a2257ff7c9242c9
+SIZE (zathura-0.2.2.tar.gz) = 108240
diff --git a/graphics/zathura/files/patch-render.c b/graphics/zathura/files/patch-render.c
new file mode 100644
index 000000000000..3475f7b1b9d3
--- /dev/null
+++ b/graphics/zathura/files/patch-render.c
@@ -0,0 +1,36 @@
+--- render.c.orig 2013-01-22 17:23:39.000000000 +0100
++++ render.c 2013-01-22 17:23:03.000000000 +0100
+@@ -19,7 +19,7 @@
+
+ struct render_thread_s {
+ GThreadPool* pool; /**< Pool of threads */
+- GMutex mutex; /**< Render lock */
++ GStaticMutex mutex; /**< Render lock */
+ bool about_to_close; /**< Render thread is to be freed */
+ };
+
+@@ -51,7 +51,7 @@
+
+ render_thread->about_to_close = false;
+ g_thread_pool_set_sort_function(render_thread->pool, render_thread_sort, zathura);
+- g_mutex_init(&render_thread->mutex);
++ g_static_mutex_init(&render_thread->mutex);
+
+ return render_thread;
+
+@@ -328,7 +328,7 @@
+ return;
+ }
+
+- g_mutex_lock(&render_thread->mutex);
++ g_static_mutex_lock(&render_thread->mutex);
+ }
+
+ void
+@@ -338,5 +338,5 @@
+ return;
+ }
+
+- g_mutex_unlock(&render_thread->mutex);
++ g_static_mutex_unlock(&render_thread->mutex);
+ }
diff --git a/graphics/zathura/pkg-message b/graphics/zathura/pkg-message
index c1cdbe5beb96..baa39f5e6958 100644
--- a/graphics/zathura/pkg-message
+++ b/graphics/zathura/pkg-message
@@ -2,7 +2,6 @@
In order to read documents, zathura need at least one plugin. Such
plugins are in graphics/zathura-* ports. If you want to read pdf files,
- install the graphics/zathura-pdf-poppler or graphics/zathura-pdf-mupdf
- port.
+ install the graphics/zathura-pdf-poppler port.
===============================================================================