aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-10-03 18:30:09 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-10-03 18:30:09 +0000
commit57d3e544f480a10c5c9f7e3faa70fd8b62e61a36 (patch)
tree74fd13e368215fa139eea53dd69d7a493ad44ee2 /graphics
parentc0074c48ed5582adb12a836a43029d44a4148aeb (diff)
downloadports-57d3e544f480a10c5c9f7e3faa70fd8b62e61a36.tar.gz
ports-57d3e544f480a10c5c9f7e3faa70fd8b62e61a36.zip
Crazy Eddie's GUI System is a free library providing windowing and widgets for
graphics APIs / engines where such functionality is not natively available, or severely lacking. WWW: http://www.cegui.org.uk/
Notes
Notes: svn path=/head/; revision=144093
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/cegui/Makefile54
-rw-r--r--graphics/cegui/distinfo2
-rw-r--r--graphics/cegui/pkg-descr7
-rw-r--r--graphics/cegui/pkg-plist192
-rw-r--r--graphics/cegui04/Makefile54
-rw-r--r--graphics/cegui04/distinfo2
-rw-r--r--graphics/cegui04/pkg-descr7
-rw-r--r--graphics/cegui04/pkg-plist192
9 files changed, 511 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 5dd400dbd2a3..02142cf04403 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -42,6 +42,7 @@
SUBDIR += camediaplay
SUBDIR += cbrpager
SUBDIR += cbview
+ SUBDIR += cegui
SUBDIR += chbg
SUBDIR += cimg
SUBDIR += cinepaint
diff --git a/graphics/cegui/Makefile b/graphics/cegui/Makefile
new file mode 100644
index 000000000000..984ab9073f9d
--- /dev/null
+++ b/graphics/cegui/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: cegui
+# Date created: 03 Oct 2005
+# Whom: Oliver Lehmann <oliver@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cegui
+PORTVERSION= 0.4.0
+CATEGORIES= graphics devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=crayzedsgui
+DISTNAME= ${PORTNAME}_mk2-${PORTVERSION}
+
+MAINTAINER= oliver@FreeBSD.org
+COMMENT= A library providing windowing and widgets for graphics APIs
+
+LIB_DEPENDS= IL.1:${PORTSDIR}/graphics/devil
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_mk2
+USE_REINPLACE= YES
+USE_LIBTOOL_VER=15
+GNU_CONFIGURE= YES
+INSTALLS_SHLIB= YES
+USE_GCC= 3.4
+USE_BZIP2= YES
+USE_X_PREFIX= YES
+USE_GNOME= gnomehack
+
+post-patch:
+ @${REINPLACE_CMD} -e ' \
+ s|"-lxerces-c.*"|"-L${LOCALBASE}/lib -lxerces-c ${PTHREAD_LIBS} $$LIBS"|g; \
+ s|"-lILU.*"|"-lm -L${LOCALBASE}/lib -lILU -lIL $$LIBS"|g; \
+ s|-lpthread|${PTHREAD_LIBS}|g; \
+ s|DevIL_CFLAGS=.*|DevIL_CFLAGS="-DUSE_DEVIL_LIBRARY -I${LOCALBASE}/include"|g' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's| Samples$$||g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
+ ${WRKSRC}/include/CEGUIDataContainer.h
+ @${REINPLACE_CMD} -e 's|__linux__)|& \|\| defined(__FreeBSD__)|g' \
+ ${WRKSRC}/include/CEGUIFactoryModule.h \
+ ${WRKSRC}/src/CEGUIFactoryModule.cpp
+ @${REINPLACE_CMD} -e 's|(linux)|& \|\| defined(__FreeBSD__)|g' \
+ ${WRKSRC}/Samples/common/src/CEGuiSample.cpp
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for docfile in README COPYING AUTHORS ChangeLog TODO
+ @${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/cegui/distinfo b/graphics/cegui/distinfo
new file mode 100644
index 000000000000..a7e94b6c7832
--- /dev/null
+++ b/graphics/cegui/distinfo
@@ -0,0 +1,2 @@
+MD5 (cegui_mk2-0.4.0.tar.bz2) = 03552c7151e9125b6f8a2496d4203488
+SIZE (cegui_mk2-0.4.0.tar.bz2) = 13500075
diff --git a/graphics/cegui/pkg-descr b/graphics/cegui/pkg-descr
new file mode 100644
index 000000000000..cc79561b9a3a
--- /dev/null
+++ b/graphics/cegui/pkg-descr
@@ -0,0 +1,7 @@
+Crazy Eddie's GUI System is a free library providing windowing and widgets for
+graphics APIs / engines where such functionality is not natively available, or
+severely lacking. The library is object orientated, written in C++, and
+targeted at games developers who should be spending their time creating great
+games, not building GUI sub-systems!
+
+WWW: http://www.cegui.org.uk
diff --git a/graphics/cegui/pkg-plist b/graphics/cegui/pkg-plist
new file mode 100644
index 000000000000..77a2e26f5407
--- /dev/null
+++ b/graphics/cegui/pkg-plist
@@ -0,0 +1,192 @@
+include/CEGUI/CEGUI.h
+include/CEGUI/CEGUIBase.h
+include/CEGUI/CEGUIColourRect.h
+include/CEGUI/CEGUIConfig.h
+include/CEGUI/CEGUIConfig_xmlHandler.h
+include/CEGUI/CEGUIDataContainer.h
+include/CEGUI/CEGUIDefaultResourceProvider.h
+include/CEGUI/CEGUIEvent.h
+include/CEGUI/CEGUIEventArgs.h
+include/CEGUI/CEGUIEventSet.h
+include/CEGUI/CEGUIExceptions.h
+include/CEGUI/CEGUIFactoryModule.h
+include/CEGUI/CEGUIFont.h
+include/CEGUI/CEGUIFontManager.h
+include/CEGUI/CEGUIFont_xmlHandler.h
+include/CEGUI/CEGUIForwardRefs.h
+include/CEGUI/CEGUIGUILayout_xmlHandler.h
+include/CEGUI/CEGUIGlobalEventSet.h
+include/CEGUI/CEGUIImage.h
+include/CEGUI/CEGUIImageset.h
+include/CEGUI/CEGUIImagesetManager.h
+include/CEGUI/CEGUIImageset_xmlHandler.h
+include/CEGUI/CEGUIInputEvent.h
+include/CEGUI/CEGUIIteratorBase.h
+include/CEGUI/CEGUILogger.h
+include/CEGUI/CEGUILua.h
+include/CEGUI/CEGUIMouseCursor.h
+include/CEGUI/CEGUIProperty.h
+include/CEGUI/CEGUIPropertyHelper.h
+include/CEGUI/CEGUIPropertySet.h
+include/CEGUI/CEGUIRect.h
+include/CEGUI/CEGUIRefPtr.h
+include/CEGUI/CEGUIRenderableElement.h
+include/CEGUI/CEGUIRenderableFrame.h
+include/CEGUI/CEGUIRenderableImage.h
+include/CEGUI/CEGUIRenderer.h
+include/CEGUI/CEGUIRenderCache.h
+include/CEGUI/CEGUIResourceProvider.h
+include/CEGUI/CEGUIScheme.h
+include/CEGUI/CEGUISchemeManager.h
+include/CEGUI/CEGUIScheme_xmlHandler.h
+include/CEGUI/CEGUIScriptModule.h
+include/CEGUI/CEGUISingleton.h
+include/CEGUI/CEGUISize.h
+include/CEGUI/CEGUIString.h
+include/CEGUI/CEGUISystem.h
+include/CEGUI/CEGUITextUtils.h
+include/CEGUI/CEGUITexture.h
+include/CEGUI/CEGUIUDim.h
+include/CEGUI/CEGUIVector.h
+include/CEGUI/CEGUIVersion.h
+include/CEGUI/CEGUIWindow.h
+include/CEGUI/CEGUIWindowFactory.h
+include/CEGUI/CEGUIWindowFactoryManager.h
+include/CEGUI/CEGUIWindowManager.h
+include/CEGUI/CEGUIWindowProperties.h
+include/CEGUI/CEGUIXMLAttributes.h
+include/CEGUI/CEGUIXMLHandler.h
+include/CEGUI/CEGUIXMLParser.h
+include/CEGUI/CEGUIcolour.h
+include/CEGUI/elements/CEGUIButtonBase.h
+include/CEGUI/elements/CEGUIButtonBaseProperties.h
+include/CEGUI/elements/CEGUICheckbox.h
+include/CEGUI/elements/CEGUICheckboxProperties.h
+include/CEGUI/elements/CEGUIComboDropList.h
+include/CEGUI/elements/CEGUICombobox.h
+include/CEGUI/elements/CEGUIComboboxProperties.h
+include/CEGUI/elements/CEGUIDragContainer.h
+include/CEGUI/elements/CEGUIDragContainerProperties.h
+include/CEGUI/elements/CEGUIEditbox.h
+include/CEGUI/elements/CEGUIEditboxProperties.h
+include/CEGUI/elements/CEGUIFrameWindow.h
+include/CEGUI/elements/CEGUIFrameWindowProperties.h
+include/CEGUI/elements/CEGUIGUISheet.h
+include/CEGUI/elements/CEGUIItemEntry.h
+include/CEGUI/elements/CEGUIItemListBase.h
+include/CEGUI/elements/CEGUIItemListBaseProperties.h
+include/CEGUI/elements/CEGUIListHeader.h
+include/CEGUI/elements/CEGUIListHeaderProperties.h
+include/CEGUI/elements/CEGUIListHeaderSegment.h
+include/CEGUI/elements/CEGUIListHeaderSegmentProperties.h
+include/CEGUI/elements/CEGUIListbox.h
+include/CEGUI/elements/CEGUIListboxItem.h
+include/CEGUI/elements/CEGUIListboxProperties.h
+include/CEGUI/elements/CEGUIListboxTextItem.h
+include/CEGUI/elements/CEGUIMenuBase.h
+include/CEGUI/elements/CEGUIMenuBaseProperties.h
+include/CEGUI/elements/CEGUIMenuItem.h
+include/CEGUI/elements/CEGUIMenuItemProperties.h
+include/CEGUI/elements/CEGUIMenubar.h
+include/CEGUI/elements/CEGUIMultiColumnList.h
+include/CEGUI/elements/CEGUIMultiColumnListProperties.h
+include/CEGUI/elements/CEGUIMultiLineEditbox.h
+include/CEGUI/elements/CEGUIMultiLineEditboxProperties.h
+include/CEGUI/elements/CEGUIPopupMenu.h
+include/CEGUI/elements/CEGUIPopupMenuProperties.h
+include/CEGUI/elements/CEGUIProgressBar.h
+include/CEGUI/elements/CEGUIProgressBarProperties.h
+include/CEGUI/elements/CEGUIPushButton.h
+include/CEGUI/elements/CEGUIPushButtonProperties.h
+include/CEGUI/elements/CEGUIRadioButton.h
+include/CEGUI/elements/CEGUIRadioButtonProperties.h
+include/CEGUI/elements/CEGUIScrollablePane.h
+include/CEGUI/elements/CEGUIScrollablePaneProperties.h
+include/CEGUI/elements/CEGUIScrollbar.h
+include/CEGUI/elements/CEGUIScrollbarProperties.h
+include/CEGUI/elements/CEGUIScrolledContainer.h
+include/CEGUI/elements/CEGUIScrolledContainerProperties.h
+include/CEGUI/elements/CEGUISlider.h
+include/CEGUI/elements/CEGUISliderProperties.h
+include/CEGUI/elements/CEGUISpinner.h
+include/CEGUI/elements/CEGUISpinnerProperties.h
+include/CEGUI/elements/CEGUIStatic.h
+include/CEGUI/elements/CEGUIStaticImage.h
+include/CEGUI/elements/CEGUIStaticImageProperties.h
+include/CEGUI/elements/CEGUIStaticProperties.h
+include/CEGUI/elements/CEGUIStaticText.h
+include/CEGUI/elements/CEGUIStaticTextProperties.h
+include/CEGUI/elements/CEGUITabButton.h
+include/CEGUI/elements/CEGUITabControl.h
+include/CEGUI/elements/CEGUITabControlProperties.h
+include/CEGUI/elements/CEGUITabPane.h
+include/CEGUI/elements/CEGUITextItem.h
+include/CEGUI/elements/CEGUITextItemProperties.h
+include/CEGUI/elements/CEGUIThumb.h
+include/CEGUI/elements/CEGUIThumbProperties.h
+include/CEGUI/elements/CEGUITitlebar.h
+include/CEGUI/elements/CEGUITitlebarProperties.h
+include/CEGUI/elements/CEGUITooltip.h
+include/CEGUI/elements/CEGUITooltipProperties.h
+include/CEGUI/falagard/CEGUIFalComponentBase.h
+include/CEGUI/falagard/CEGUIFalDimensions.h
+include/CEGUI/falagard/CEGUIFalEnums.h
+include/CEGUI/falagard/CEGUIFalFrameComponent.h
+include/CEGUI/falagard/CEGUIFalImageryComponent.h
+include/CEGUI/falagard/CEGUIFalImagerySection.h
+include/CEGUI/falagard/CEGUIFalLayerSpecification.h
+include/CEGUI/falagard/CEGUIFalNamedArea.h
+include/CEGUI/falagard/CEGUIFalPropertyDefinition.h
+include/CEGUI/falagard/CEGUIFalPropertyInitialiser.h
+include/CEGUI/falagard/CEGUIFalSectionSpecification.h
+include/CEGUI/falagard/CEGUIFalStateImagery.h
+include/CEGUI/falagard/CEGUIFalTextComponent.h
+include/CEGUI/falagard/CEGUIFalWidgetComponent.h
+include/CEGUI/falagard/CEGUIFalWidgetLookFeel.h
+include/CEGUI/falagard/CEGUIFalWidgetLookManager.h
+include/CEGUI/falagard/CEGUIFalXMLEnumHelper.h
+include/CEGUI/lauxlib.h
+include/CEGUI/lua.h
+include/CEGUI/lualib.h
+include/CEGUI/renderers/IrrlichtRenderer/IrrlichtRendererDef.h
+include/CEGUI/renderers/IrrlichtRenderer/IrrlichtResourceProvider.h
+include/CEGUI/renderers/IrrlichtRenderer/irrlichtrenderer.h
+include/CEGUI/renderers/IrrlichtRenderer/irrlichttexture.h
+include/CEGUI/renderers/OpenGLGUIRenderer/openglrenderer.h
+include/CEGUI/renderers/OpenGLGUIRenderer/opengltexture.h
+include/CEGUI/tolua++.h
+lib/libCEGUIBase.a
+lib/libCEGUIBase.so
+lib/libCEGUIBase.so.0
+lib/libCEGUIFalagardBase.a
+lib/libCEGUIFalagardBase.so
+lib/libCEGUIFalagardBase.so.0
+lib/libCEGUILuaScriptModule.a
+lib/libCEGUILuaScriptModule.so
+lib/libCEGUILuaScriptModule.so.0
+lib/libCEGUIOpenGLRenderer.a
+lib/libCEGUIOpenGLRenderer.so
+lib/libCEGUIOpenGLRenderer.so.0
+lib/libCEGUITaharezLook.a
+lib/libCEGUITaharezLook.so
+lib/libCEGUITaharezLook.so.0
+lib/libCEGUIWindowsLook.a
+lib/libCEGUIWindowsLook.so
+lib/libCEGUIWindowsLook.so.0
+lib/libCEGUIluatoluapp.a
+lib/libCEGUIluatoluapp.so
+lib/libCEGUIluatoluapp.so.0
+libdata/pkgconfig/CEGUI-OPENGL.pc
+libdata/pkgconfig/CEGUI.pc
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+@dirrm include/CEGUI/elements
+@dirrm include/CEGUI/falagard
+@dirrm include/CEGUI/renderers/IrrlichtRenderer
+@dirrm include/CEGUI/renderers/OpenGLGUIRenderer
+@dirrm include/CEGUI/renderers
+@dirrm include/CEGUI
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
diff --git a/graphics/cegui04/Makefile b/graphics/cegui04/Makefile
new file mode 100644
index 000000000000..984ab9073f9d
--- /dev/null
+++ b/graphics/cegui04/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: cegui
+# Date created: 03 Oct 2005
+# Whom: Oliver Lehmann <oliver@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cegui
+PORTVERSION= 0.4.0
+CATEGORIES= graphics devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=crayzedsgui
+DISTNAME= ${PORTNAME}_mk2-${PORTVERSION}
+
+MAINTAINER= oliver@FreeBSD.org
+COMMENT= A library providing windowing and widgets for graphics APIs
+
+LIB_DEPENDS= IL.1:${PORTSDIR}/graphics/devil
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_mk2
+USE_REINPLACE= YES
+USE_LIBTOOL_VER=15
+GNU_CONFIGURE= YES
+INSTALLS_SHLIB= YES
+USE_GCC= 3.4
+USE_BZIP2= YES
+USE_X_PREFIX= YES
+USE_GNOME= gnomehack
+
+post-patch:
+ @${REINPLACE_CMD} -e ' \
+ s|"-lxerces-c.*"|"-L${LOCALBASE}/lib -lxerces-c ${PTHREAD_LIBS} $$LIBS"|g; \
+ s|"-lILU.*"|"-lm -L${LOCALBASE}/lib -lILU -lIL $$LIBS"|g; \
+ s|-lpthread|${PTHREAD_LIBS}|g; \
+ s|DevIL_CFLAGS=.*|DevIL_CFLAGS="-DUSE_DEVIL_LIBRARY -I${LOCALBASE}/include"|g' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's| Samples$$||g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
+ ${WRKSRC}/include/CEGUIDataContainer.h
+ @${REINPLACE_CMD} -e 's|__linux__)|& \|\| defined(__FreeBSD__)|g' \
+ ${WRKSRC}/include/CEGUIFactoryModule.h \
+ ${WRKSRC}/src/CEGUIFactoryModule.cpp
+ @${REINPLACE_CMD} -e 's|(linux)|& \|\| defined(__FreeBSD__)|g' \
+ ${WRKSRC}/Samples/common/src/CEGuiSample.cpp
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for docfile in README COPYING AUTHORS ChangeLog TODO
+ @${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/cegui04/distinfo b/graphics/cegui04/distinfo
new file mode 100644
index 000000000000..a7e94b6c7832
--- /dev/null
+++ b/graphics/cegui04/distinfo
@@ -0,0 +1,2 @@
+MD5 (cegui_mk2-0.4.0.tar.bz2) = 03552c7151e9125b6f8a2496d4203488
+SIZE (cegui_mk2-0.4.0.tar.bz2) = 13500075
diff --git a/graphics/cegui04/pkg-descr b/graphics/cegui04/pkg-descr
new file mode 100644
index 000000000000..cc79561b9a3a
--- /dev/null
+++ b/graphics/cegui04/pkg-descr
@@ -0,0 +1,7 @@
+Crazy Eddie's GUI System is a free library providing windowing and widgets for
+graphics APIs / engines where such functionality is not natively available, or
+severely lacking. The library is object orientated, written in C++, and
+targeted at games developers who should be spending their time creating great
+games, not building GUI sub-systems!
+
+WWW: http://www.cegui.org.uk
diff --git a/graphics/cegui04/pkg-plist b/graphics/cegui04/pkg-plist
new file mode 100644
index 000000000000..77a2e26f5407
--- /dev/null
+++ b/graphics/cegui04/pkg-plist
@@ -0,0 +1,192 @@
+include/CEGUI/CEGUI.h
+include/CEGUI/CEGUIBase.h
+include/CEGUI/CEGUIColourRect.h
+include/CEGUI/CEGUIConfig.h
+include/CEGUI/CEGUIConfig_xmlHandler.h
+include/CEGUI/CEGUIDataContainer.h
+include/CEGUI/CEGUIDefaultResourceProvider.h
+include/CEGUI/CEGUIEvent.h
+include/CEGUI/CEGUIEventArgs.h
+include/CEGUI/CEGUIEventSet.h
+include/CEGUI/CEGUIExceptions.h
+include/CEGUI/CEGUIFactoryModule.h
+include/CEGUI/CEGUIFont.h
+include/CEGUI/CEGUIFontManager.h
+include/CEGUI/CEGUIFont_xmlHandler.h
+include/CEGUI/CEGUIForwardRefs.h
+include/CEGUI/CEGUIGUILayout_xmlHandler.h
+include/CEGUI/CEGUIGlobalEventSet.h
+include/CEGUI/CEGUIImage.h
+include/CEGUI/CEGUIImageset.h
+include/CEGUI/CEGUIImagesetManager.h
+include/CEGUI/CEGUIImageset_xmlHandler.h
+include/CEGUI/CEGUIInputEvent.h
+include/CEGUI/CEGUIIteratorBase.h
+include/CEGUI/CEGUILogger.h
+include/CEGUI/CEGUILua.h
+include/CEGUI/CEGUIMouseCursor.h
+include/CEGUI/CEGUIProperty.h
+include/CEGUI/CEGUIPropertyHelper.h
+include/CEGUI/CEGUIPropertySet.h
+include/CEGUI/CEGUIRect.h
+include/CEGUI/CEGUIRefPtr.h
+include/CEGUI/CEGUIRenderableElement.h
+include/CEGUI/CEGUIRenderableFrame.h
+include/CEGUI/CEGUIRenderableImage.h
+include/CEGUI/CEGUIRenderer.h
+include/CEGUI/CEGUIRenderCache.h
+include/CEGUI/CEGUIResourceProvider.h
+include/CEGUI/CEGUIScheme.h
+include/CEGUI/CEGUISchemeManager.h
+include/CEGUI/CEGUIScheme_xmlHandler.h
+include/CEGUI/CEGUIScriptModule.h
+include/CEGUI/CEGUISingleton.h
+include/CEGUI/CEGUISize.h
+include/CEGUI/CEGUIString.h
+include/CEGUI/CEGUISystem.h
+include/CEGUI/CEGUITextUtils.h
+include/CEGUI/CEGUITexture.h
+include/CEGUI/CEGUIUDim.h
+include/CEGUI/CEGUIVector.h
+include/CEGUI/CEGUIVersion.h
+include/CEGUI/CEGUIWindow.h
+include/CEGUI/CEGUIWindowFactory.h
+include/CEGUI/CEGUIWindowFactoryManager.h
+include/CEGUI/CEGUIWindowManager.h
+include/CEGUI/CEGUIWindowProperties.h
+include/CEGUI/CEGUIXMLAttributes.h
+include/CEGUI/CEGUIXMLHandler.h
+include/CEGUI/CEGUIXMLParser.h
+include/CEGUI/CEGUIcolour.h
+include/CEGUI/elements/CEGUIButtonBase.h
+include/CEGUI/elements/CEGUIButtonBaseProperties.h
+include/CEGUI/elements/CEGUICheckbox.h
+include/CEGUI/elements/CEGUICheckboxProperties.h
+include/CEGUI/elements/CEGUIComboDropList.h
+include/CEGUI/elements/CEGUICombobox.h
+include/CEGUI/elements/CEGUIComboboxProperties.h
+include/CEGUI/elements/CEGUIDragContainer.h
+include/CEGUI/elements/CEGUIDragContainerProperties.h
+include/CEGUI/elements/CEGUIEditbox.h
+include/CEGUI/elements/CEGUIEditboxProperties.h
+include/CEGUI/elements/CEGUIFrameWindow.h
+include/CEGUI/elements/CEGUIFrameWindowProperties.h
+include/CEGUI/elements/CEGUIGUISheet.h
+include/CEGUI/elements/CEGUIItemEntry.h
+include/CEGUI/elements/CEGUIItemListBase.h
+include/CEGUI/elements/CEGUIItemListBaseProperties.h
+include/CEGUI/elements/CEGUIListHeader.h
+include/CEGUI/elements/CEGUIListHeaderProperties.h
+include/CEGUI/elements/CEGUIListHeaderSegment.h
+include/CEGUI/elements/CEGUIListHeaderSegmentProperties.h
+include/CEGUI/elements/CEGUIListbox.h
+include/CEGUI/elements/CEGUIListboxItem.h
+include/CEGUI/elements/CEGUIListboxProperties.h
+include/CEGUI/elements/CEGUIListboxTextItem.h
+include/CEGUI/elements/CEGUIMenuBase.h
+include/CEGUI/elements/CEGUIMenuBaseProperties.h
+include/CEGUI/elements/CEGUIMenuItem.h
+include/CEGUI/elements/CEGUIMenuItemProperties.h
+include/CEGUI/elements/CEGUIMenubar.h
+include/CEGUI/elements/CEGUIMultiColumnList.h
+include/CEGUI/elements/CEGUIMultiColumnListProperties.h
+include/CEGUI/elements/CEGUIMultiLineEditbox.h
+include/CEGUI/elements/CEGUIMultiLineEditboxProperties.h
+include/CEGUI/elements/CEGUIPopupMenu.h
+include/CEGUI/elements/CEGUIPopupMenuProperties.h
+include/CEGUI/elements/CEGUIProgressBar.h
+include/CEGUI/elements/CEGUIProgressBarProperties.h
+include/CEGUI/elements/CEGUIPushButton.h
+include/CEGUI/elements/CEGUIPushButtonProperties.h
+include/CEGUI/elements/CEGUIRadioButton.h
+include/CEGUI/elements/CEGUIRadioButtonProperties.h
+include/CEGUI/elements/CEGUIScrollablePane.h
+include/CEGUI/elements/CEGUIScrollablePaneProperties.h
+include/CEGUI/elements/CEGUIScrollbar.h
+include/CEGUI/elements/CEGUIScrollbarProperties.h
+include/CEGUI/elements/CEGUIScrolledContainer.h
+include/CEGUI/elements/CEGUIScrolledContainerProperties.h
+include/CEGUI/elements/CEGUISlider.h
+include/CEGUI/elements/CEGUISliderProperties.h
+include/CEGUI/elements/CEGUISpinner.h
+include/CEGUI/elements/CEGUISpinnerProperties.h
+include/CEGUI/elements/CEGUIStatic.h
+include/CEGUI/elements/CEGUIStaticImage.h
+include/CEGUI/elements/CEGUIStaticImageProperties.h
+include/CEGUI/elements/CEGUIStaticProperties.h
+include/CEGUI/elements/CEGUIStaticText.h
+include/CEGUI/elements/CEGUIStaticTextProperties.h
+include/CEGUI/elements/CEGUITabButton.h
+include/CEGUI/elements/CEGUITabControl.h
+include/CEGUI/elements/CEGUITabControlProperties.h
+include/CEGUI/elements/CEGUITabPane.h
+include/CEGUI/elements/CEGUITextItem.h
+include/CEGUI/elements/CEGUITextItemProperties.h
+include/CEGUI/elements/CEGUIThumb.h
+include/CEGUI/elements/CEGUIThumbProperties.h
+include/CEGUI/elements/CEGUITitlebar.h
+include/CEGUI/elements/CEGUITitlebarProperties.h
+include/CEGUI/elements/CEGUITooltip.h
+include/CEGUI/elements/CEGUITooltipProperties.h
+include/CEGUI/falagard/CEGUIFalComponentBase.h
+include/CEGUI/falagard/CEGUIFalDimensions.h
+include/CEGUI/falagard/CEGUIFalEnums.h
+include/CEGUI/falagard/CEGUIFalFrameComponent.h
+include/CEGUI/falagard/CEGUIFalImageryComponent.h
+include/CEGUI/falagard/CEGUIFalImagerySection.h
+include/CEGUI/falagard/CEGUIFalLayerSpecification.h
+include/CEGUI/falagard/CEGUIFalNamedArea.h
+include/CEGUI/falagard/CEGUIFalPropertyDefinition.h
+include/CEGUI/falagard/CEGUIFalPropertyInitialiser.h
+include/CEGUI/falagard/CEGUIFalSectionSpecification.h
+include/CEGUI/falagard/CEGUIFalStateImagery.h
+include/CEGUI/falagard/CEGUIFalTextComponent.h
+include/CEGUI/falagard/CEGUIFalWidgetComponent.h
+include/CEGUI/falagard/CEGUIFalWidgetLookFeel.h
+include/CEGUI/falagard/CEGUIFalWidgetLookManager.h
+include/CEGUI/falagard/CEGUIFalXMLEnumHelper.h
+include/CEGUI/lauxlib.h
+include/CEGUI/lua.h
+include/CEGUI/lualib.h
+include/CEGUI/renderers/IrrlichtRenderer/IrrlichtRendererDef.h
+include/CEGUI/renderers/IrrlichtRenderer/IrrlichtResourceProvider.h
+include/CEGUI/renderers/IrrlichtRenderer/irrlichtrenderer.h
+include/CEGUI/renderers/IrrlichtRenderer/irrlichttexture.h
+include/CEGUI/renderers/OpenGLGUIRenderer/openglrenderer.h
+include/CEGUI/renderers/OpenGLGUIRenderer/opengltexture.h
+include/CEGUI/tolua++.h
+lib/libCEGUIBase.a
+lib/libCEGUIBase.so
+lib/libCEGUIBase.so.0
+lib/libCEGUIFalagardBase.a
+lib/libCEGUIFalagardBase.so
+lib/libCEGUIFalagardBase.so.0
+lib/libCEGUILuaScriptModule.a
+lib/libCEGUILuaScriptModule.so
+lib/libCEGUILuaScriptModule.so.0
+lib/libCEGUIOpenGLRenderer.a
+lib/libCEGUIOpenGLRenderer.so
+lib/libCEGUIOpenGLRenderer.so.0
+lib/libCEGUITaharezLook.a
+lib/libCEGUITaharezLook.so
+lib/libCEGUITaharezLook.so.0
+lib/libCEGUIWindowsLook.a
+lib/libCEGUIWindowsLook.so
+lib/libCEGUIWindowsLook.so.0
+lib/libCEGUIluatoluapp.a
+lib/libCEGUIluatoluapp.so
+lib/libCEGUIluatoluapp.so.0
+libdata/pkgconfig/CEGUI-OPENGL.pc
+libdata/pkgconfig/CEGUI.pc
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+@dirrm include/CEGUI/elements
+@dirrm include/CEGUI/falagard
+@dirrm include/CEGUI/renderers/IrrlichtRenderer
+@dirrm include/CEGUI/renderers/OpenGLGUIRenderer
+@dirrm include/CEGUI/renderers
+@dirrm include/CEGUI
+%%PORTDOCS%%@dirrm %%DOCSDIR%%