aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-09-29 05:45:34 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-09-29 05:45:34 +0000
commit90abb24f53e9d8c2428c70b483b38627d2bae3ae (patch)
tree039e88512c84bb0c19d7d2204a18150ecd6574ab /graphics
parent57ecc8add154f672ce9d853fb180da502d262718 (diff)
downloadports-90abb24f53e9d8c2428c70b483b38627d2bae3ae.tar.gz
ports-90abb24f53e9d8c2428c70b483b38627d2bae3ae.zip
BROKEN on 5.x: Does not compile
Approved by: portmgr (self)
Notes
Notes: svn path=/head/; revision=118494
Diffstat (limited to 'graphics')
-rw-r--r--graphics/teddy/Makefile8
-rw-r--r--graphics/truevision/Makefile8
-rw-r--r--graphics/tulip/Makefile4
3 files changed, 18 insertions, 2 deletions
diff --git a/graphics/teddy/Makefile b/graphics/teddy/Makefile
index aed94e07f6d2..0416d4a50030 100644
--- a/graphics/teddy/Makefile
+++ b/graphics/teddy/Makefile
@@ -29,6 +29,12 @@ USE_GMAKE= yes
PLIST_FILES= lib/libTeddy.a libdata/pkgconfig/Teddy.pc
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-extract:
@${CHMOD} +x ${WRKSRC}/configure
@@ -44,4 +50,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/libTeddy.a ${PREFIX}/lib
${INSTALL_DATA} ${WRKSRC}/Teddy.pc ${PREFIX}/libdata/pkgconfig
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/truevision/Makefile b/graphics/truevision/Makefile
index 34f706360e4c..eb2b5bb4edff 100644
--- a/graphics/truevision/Makefile
+++ b/graphics/truevision/Makefile
@@ -33,6 +33,12 @@ MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-extract:
@${FIND} ${WRKSRC} -type l -delete
@${FIND} ${WRKSRC} -name "*.o" -delete
@@ -44,4 +50,4 @@ post-install:
${TAR} -C ${PREFIX}/share/gnome/Truevision --unlink -xf -
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/gnome/Truevision
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/tulip/Makefile b/graphics/tulip/Makefile
index 3c861d536b5c..8a8be11691f4 100644
--- a/graphics/tulip/Makefile
+++ b/graphics/tulip/Makefile
@@ -39,6 +39,10 @@ LDFLAGS= -Wl,-export-dynamic -L${LOCALBASE}/lib -L${X11BASE}/lib \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
BROKEN= "Does not compile on amd64 or ia64 (missing -fPIC from shared library objects)"
.endif