aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-09-29 16:47:42 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-09-29 16:47:42 +0000
commitc33884e328a6c10bb9c8f88426bf048a54e6d925 (patch)
treea89e5b286503ee86168f8046728180359887bfbf /graphics
parent7391d9efa907ec764a1a6f5d1ef12327bd7cb360 (diff)
downloadports-c33884e328a6c10bb9c8f88426bf048a54e6d925.tar.gz
ports-c33884e328a6c10bb9c8f88426bf048a54e6d925.zip
Update to 0.47
PR: 222682 Approved by: demon (maintainer)
Notes
Notes: svn path=/head/; revision=450914
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gource/Makefile9
-rw-r--r--graphics/gource/distinfo5
-rw-r--r--graphics/gource/files/patch-src_dirnode.cpp11
3 files changed, 8 insertions, 17 deletions
diff --git a/graphics/gource/Makefile b/graphics/gource/Makefile
index 759289850b36..95724240d37c 100644
--- a/graphics/gource/Makefile
+++ b/graphics/gource/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gource
-PORTVERSION= 0.43
-PORTREVISION= 9
+PORTVERSION= 0.47
CATEGORIES= graphics
MASTER_SITES= https://github.com/acaudwell/Gource/releases/download/${PORTNAME}-${PORTVERSION}/
@@ -16,12 +15,14 @@ BUILD_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:math/glm
LIB_DEPENDS= libSDL_image.so:graphics/sdl_image \
libfreetype.so:print/freetype2 \
libpcre.so:devel/pcre \
- libboost_filesystem.so:devel/boost-libs
+ libboost_filesystem.so:devel/boost-libs \
+ libpng16.so:graphics/png
RUN_DEPENDS= ${LOCALBASE}/include/glm/glm.hpp:math/glm
GNU_CONFIGURE= yes
USES= gmake pkgconfig compiler:c++0x
-USE_GL= glew
+USE_GL= glew gl glu
+USE_SDL= image2 sdl2
CONFIGURE_ARGS+=--with-boost-system=boost_system \
--with-boost-filesystem=boost_filesystem
diff --git a/graphics/gource/distinfo b/graphics/gource/distinfo
index bd35fe4d85f1..00174caa102f 100644
--- a/graphics/gource/distinfo
+++ b/graphics/gource/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gource-0.43.tar.gz) = 85a40ac8e4f5c277764216465c248d6b76589ceac012541c4cc03883a24abde4
-SIZE (gource-0.43.tar.gz) = 874141
+TIMESTAMP = 1506680266
+SHA256 (gource-0.47.tar.gz) = f2b16083a01b897b6c062b363793028fb9e01cd6f888d91772ee06e56ce398d2
+SIZE (gource-0.47.tar.gz) = 876624
diff --git a/graphics/gource/files/patch-src_dirnode.cpp b/graphics/gource/files/patch-src_dirnode.cpp
deleted file mode 100644
index 81c20cb2e8d3..000000000000
--- a/graphics/gource/files/patch-src_dirnode.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/dirnode.cpp.orig 2014-10-16 02:23:22 UTC
-+++ src/dirnode.cpp
-@@ -582,7 +582,7 @@ void RDirNode::calcRadius() {
- //this->dir_radius_sqrt = sqrt(dir_radius); //dir_radius_sqrt is not used
-
- // this->parent_radius = std::max(1.0, parent_circ / PI);
-- this->parent_radius = std::max(1.0, sqrt(total_file_area) * gGourceDirPadding);
-+ this->parent_radius = std::max(1.0f, (float)sqrt(total_file_area) * gGourceDirPadding);
- }
-
- float RDirNode::distanceToParent() const{