aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-09-27 09:01:59 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-09-27 09:01:59 +0000
commitd41a65d6575572fe2e93a22a7266634b189c34c4 (patch)
tree50e981a78fc32080171806a3bcb26723a371c0bb /graphics
parent561190179f2bc48bbe2f730c0ec510a687538a23 (diff)
downloadports-d41a65d6575572fe2e93a22a7266634b189c34c4.tar.gz
ports-d41a65d6575572fe2e93a22a7266634b189c34c4.zip
- Add NO_ARCH
- Switch to options helpers - Unsilence installation commands Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=450724
Diffstat (limited to 'graphics')
-rw-r--r--graphics/py-stltools/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/graphics/py-stltools/Makefile b/graphics/py-stltools/Makefile
index efd5efeccd37..d1f9c5a45eba 100644
--- a/graphics/py-stltools/Makefile
+++ b/graphics/py-stltools/Makefile
@@ -3,7 +3,7 @@
PORTNAME= stltools
PORTVERSION= 3.2
-PORTREVISION= 1
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= http://rsmith.home.xs4all.nl/files/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,27 +17,25 @@ RUN_DEPENDS= ${PYNUMPY}
USES= zip python:2.7
USE_PYTHON= distutils
+NO_ARCH= yes
DOCS= README.txt
EXAMPLES= test/cube.stl test/cube_bin.stl
-OPTIONS_DEFINE= PYCAIRO DOCS
+OPTIONS_DEFINE= PYCAIRO DOCS EXAMPLES
PYCAIRO_DESC= Use (py)Cairo to enable stl2pdf to function.
+PYCAIRO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cairo>1.8:graphics/py-cairo
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPYCAIRO}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}cairo>1.8:graphics/py-cairo
-.endif
-
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
+
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for i in ${EXAMPLES}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${EXAMPLESDIR}
.endfor
.include <bsd.port.mk>