aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-07-04 18:03:05 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-07-04 18:03:05 +0000
commit681a343fc244114631c8a003b786e75c8d6045c5 (patch)
tree6afaf904da5e782d446e23c8ffe0c44a552bd812 /graphics
parent2a0b64c7341e1c013ce6958160a24e2452a4c6c9 (diff)
downloadports-681a343fc244114631c8a003b786e75c8d6045c5.tar.gz
ports-681a343fc244114631c8a003b786e75c8d6045c5.zip
Upgrade to 1.5.9.
Notes
Notes: svn path=/head/; revision=360643
Diffstat (limited to 'graphics')
-rw-r--r--graphics/cimg/Makefile12
-rw-r--r--graphics/cimg/distinfo4
-rw-r--r--graphics/cimg/files/patch-examples::Makefile41
-rw-r--r--graphics/cimg/pkg-plist102
4 files changed, 89 insertions, 70 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index 5657efb1e1e7..e91e75bc265e 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cimg
-PORTVERSION= 1.5.8
-PORTREVISION= 2
+PORTVERSION= 1.5.9
PORTEPOCH= 3
CATEGORIES= graphics devel
MASTER_SITES= SF/${PORTNAME} \
@@ -72,6 +71,10 @@ LIB_DEPENDS+= libavformat.so:${PORTSDIR}/multimedia/ffmpeg
USES+= fortran
. endif
+. if defined(WITH_XSHM)
+USE_XORG+= xext
+. endif
+
DOCBASE= README.txt
PROGS= CImg_demo captcha curve_editor2d dtmri_view3d \
edge_explorer2d fade_images gaussian_fit1d generate_loop_macros \
@@ -120,6 +123,11 @@ pre-configure:
-e 's|-lblas -llapack|${LAPACK_LIB}|' \
${BUILD_WRKSRC}/Makefile
. endif
+. if defined(WITH_XSHM)
+ ${REINPLACE_CMD} -e 's|CIMG_XSHM_CFLAGS = #|CIMG_XSHM_CFLAGS =|' \
+ -e 's|CIMG_XSHM_LDFLAGS = #|CIMG_XSHM_LDFLAGS =|' \
+ ${BUILD_WRKSRC}/Makefile
+. endif
${REINPLACE_CMD} -e 's|-pedantic|${CFLAGS}|' \
-e 's|-lpthread|${PTHREAD_LIBS}|' ${BUILD_WRKSRC}/Makefile
diff --git a/graphics/cimg/distinfo b/graphics/cimg/distinfo
index 01d9d3452c45..c5fb1dfd3459 100644
--- a/graphics/cimg/distinfo
+++ b/graphics/cimg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cimg-1.5.8_2/CImg-1.5.8.zip) = 66b0766d6dd97149fce2870848624fe08cb34aafe4a33a9818d413ce08d950cc
-SIZE (cimg-1.5.8_2/CImg-1.5.8.zip) = 11555033
+SHA256 (cimg-1.5.9_0/CImg-1.5.9.zip) = 2cb224987cbe498a8b95121a880fb0f527529b93bf82fb95024484b0473af4d7
+SIZE (cimg-1.5.9_0/CImg-1.5.9.zip) = 11586436
diff --git a/graphics/cimg/files/patch-examples::Makefile b/graphics/cimg/files/patch-examples::Makefile
index fe78c971d385..6695684f45b9 100644
--- a/graphics/cimg/files/patch-examples::Makefile
+++ b/graphics/cimg/files/patch-examples::Makefile
@@ -1,9 +1,9 @@
---- examples/Makefile.orig 2014-04-17 15:41:13.000000000 +0200
-+++ examples/Makefile 2014-04-20 21:51:43.000000000 +0200
-@@ -84,8 +84,8 @@
+--- examples/Makefile.orig 2014-07-03 12:15:02.000000000 +0200
++++ examples/Makefile 2014-07-04 18:54:56.000000000 +0200
+@@ -85,8 +85,8 @@
# Set correct variables and paths
#---------------------------------
- CIMG_VERSION = 1.5.8
+ CIMG_VERSION = 1.5.9
-X11PATH = /usr/X11R6
-CC = g++
+#X11PATH = $(X11PATH)
@@ -11,7 +11,7 @@
EXEPFX =
CCVER = $(CC)
ifeq ($(CC),g++)
-@@ -99,8 +99,8 @@
+@@ -100,8 +100,8 @@
CFLAGS = -I..
LDFLAGS =
else
@@ -22,16 +22,19 @@
endif
#--------------------------------------------------
-@@ -125,7 +125,7 @@
- ifeq ($(CC),icc)
+@@ -127,9 +127,9 @@
CIMG_OPT_CFLAGS = -O3 -ipo -no-prec-div
else
+ ifeq ($(CC),g++)
-CIMG_OPT_CFLAGS = -O3 -fno-tree-pre
+CIMG_OPT_CFLAGS =
+ else
+-CIMG_OPT_CFLAGS = -O3
++CIMG_OPT_CFLAGS =
+ endif
endif
- # Flags to enable OpenMP support.
-@@ -136,7 +136,7 @@
+@@ -141,7 +141,7 @@
endif
# Flags to enable OpenCV support.
@@ -40,7 +43,7 @@
CIMG_OPENCV_LDFLAGS = -lopencv_core -lopencv_highgui
#CIMG_OPENCV_LDFLAGS = -lcv -lhighgui #-> Use this for OpenCV < 2.2.0
-@@ -147,7 +147,7 @@
+@@ -152,7 +152,7 @@
# (X11 is used by CImg to handle display windows)
# !!! For 64bits systems : replace -L$(X11PATH)/lib by -L$(X11PATH)/lib64 !!!
CIMG_X11_CFLAGS = -I$(X11PATH)/include
@@ -49,7 +52,7 @@
# Flags to enable fast image display, using the XSHM library (when using X11).
# !!! Seems to randomly crash when used on MacOSX and 64bits systems, so use it only when necessary !!!
-@@ -177,7 +177,7 @@
+@@ -182,7 +182,7 @@
# Flags to enable native support for TIFF image files, using the TIFF library.
# ( http://www.libtiff.org/ )
CIMG_TIFF_CFLAGS = -Dcimg_use_tiff
@@ -58,7 +61,7 @@
# Flags to enable native support for MINC2 image files, using the MINC2 library.
# ( http://en.wikibooks.org/wiki/MINC/Reference/MINC2.0_Users_Guide )
-@@ -186,7 +186,7 @@
+@@ -191,12 +191,12 @@
# Flags to enable native support for EXR image files, using the OpenEXR library.
# ( http://www.openexr.com/ )
@@ -67,7 +70,13 @@
CIMG_EXR_LDFLAGS = -lIlmImf -lHalf
# Flags to enable native support for various video files, using the FFMPEG library.
-@@ -201,8 +201,8 @@
+ # ( http://www.ffmpeg.org/ )
+-CIMG_FFMPEG_CFLAGS = -Dcimg_use_ffmpeg -D__STDC_CONSTANT_MACROS -I/usr/include/libavcodec -I/usr/include/libavformat -I/usr/include/libswscale -I/usr/include/ffmpeg
++CIMG_FFMPEG_CFLAGS = -Dcimg_use_ffmpeg -D__STDC_CONSTANT_MACROS -I$(LOCALBASE)/include/libavcodec -I$(LOCALBASE)/include/libavformat -I$(LOCALBASE)/include/libswscale -I$(LOCALBASE)/include/ffmpeg
+ CIMG_FFMPEG_LDFLAGS = -lavcodec -lavformat -lswscale
+
+ # Flags to enable native support for compressed .cimgz files, using the Zlib library.
+@@ -206,8 +206,8 @@
# Flags to enable native support of most classical image file formats, using the Magick++ library.
# ( http://www.imagemagick.org/Magick++/ )
@@ -78,7 +87,7 @@
# Flags to enable faster Discrete Fourier Transform computation, using the FFTW3 library
# ( http://www.fftw.org/ )
-@@ -215,14 +215,17 @@
+@@ -220,14 +220,17 @@
# Flags to enable the use of LAPACK routines for matrix computation
# ( http://www.netlib.org/lapack/ )
@@ -99,7 +108,7 @@
# Flags to compile on Sun Solaris
CIMG_SOLARIS_LDFLAGS = -R$(X11PATH)/lib -lrt -lnsl -lsocket
-@@ -366,6 +369,7 @@
+@@ -372,6 +375,7 @@
$(CIMG_ZLIB_CFLAGS) \
$(CIMG_OPENCV_CFLAGS) \
$(CIMG_MAGICK_CFLAGS) \
@@ -107,7 +116,7 @@
$(CIMG_FFTW3_CFLAGS)" \
"CONF_LDFLAGS = \
$(CIMG_X11_LDFLAGS) \
-@@ -376,6 +380,7 @@
+@@ -382,6 +386,7 @@
$(CIMG_PNG_LDFLAGS) \
$(CIMG_JPEG_LDFLAGS) \
$(CIMG_ZLIB_LDFLAGS) \
diff --git a/graphics/cimg/pkg-plist b/graphics/cimg/pkg-plist
index 9dc3c1ad7d29..53bf1948d8d0 100644
--- a/graphics/cimg/pkg-plist
+++ b/graphics/cimg/pkg-plist
@@ -40,6 +40,7 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/favicon.png
%%PORTDOCS%%%%DOCSDIR%%/footer.html
%%PORTDOCS%%%%DOCSDIR%%/header.html
+%%PORTDOCS%%%%DOCSDIR%%/header2.html
%%PORTDOCS%%%%DOCSDIR%%/header_reference.html
%%PORTDOCS%%%%DOCSDIR%%/img/CImgLogo.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/CImg_flyer.jpg
@@ -312,58 +313,58 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2splitbar.png
%%PORTDOCS%%%%DOCSDIR%%/reference/ftv2vertline.png
%%PORTDOCS%%%%DOCSDIR%%/reference/functions.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x62.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x63.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x64.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x65.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x66.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x67.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x68.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x69.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x6a.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x6b.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x6c.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x6d.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x6e.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x6f.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x70.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x71.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x72.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x73.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x74.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x75.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x76.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x77.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x78.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x79.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x7e.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_b.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_c.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_d.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_e.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_f.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x62.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x63.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x64.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x65.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x66.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x67.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x68.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x69.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x6a.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x6b.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x6c.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x6d.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x6e.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x6f.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x70.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x71.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x72.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x73.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x74.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x75.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x76.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x77.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x78.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x79.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x7e.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_b.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_c.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_d.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_e.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_f.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_g.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_h.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_i.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_j.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_k.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_l.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_m.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_n.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_o.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_p.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_q.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_r.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_s.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_t.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_u.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_v.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_w.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_x.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_y.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_~.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_g.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_h.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_i.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_j.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_k.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_l.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_m.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_n.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_o.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_p.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_q.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_r.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_s.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_t.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_type.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_u.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_v.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_w.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_x.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_y.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/functions_~.html
%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__displays.html
%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__drawing.html
%%PORTDOCS%%%%DOCSDIR%%/reference/group__cimg__environment.html
@@ -489,6 +490,7 @@ include/CImg.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_draw_gradient.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_jpeg_buffer.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_nlmeans.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_patchmatch.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_skeleton.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_tiff_stream.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wavelet_atrous.cpp