aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-09-03 18:56:33 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-09-03 18:56:33 +0000
commit80d042808a4722a0ed36038d1ce5f793ca27bf2e (patch)
treeb8f22af12cf8fc426805a4fc6968505eedfa3c21 /graphics
parent7de2a188119a2f068029e15d033e9f04d1a6adc9 (diff)
downloadports-80d042808a4722a0ed36038d1ce5f793ca27bf2e.tar.gz
ports-80d042808a4722a0ed36038d1ce5f793ca27bf2e.zip
Bmp2html is a simple program that converts a bmpfile to to a html file.
PR: ports/84757 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Notes
Notes: svn path=/head/; revision=141853
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/bmp2html/Makefile39
-rw-r--r--graphics/bmp2html/distinfo2
-rw-r--r--graphics/bmp2html/pkg-descr7
4 files changed, 49 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index fc58f4c23d96..f908313ba4fc 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -34,6 +34,7 @@
SUBDIR += blender-devel
SUBDIR += bmeps
SUBDIR += bmp-rootvis
+ SUBDIR += bmp2html
SUBDIR += bugle
SUBDIR += cadubi
SUBDIR += cairo
diff --git a/graphics/bmp2html/Makefile b/graphics/bmp2html/Makefile
new file mode 100644
index 000000000000..5bba6071df21
--- /dev/null
+++ b/graphics/bmp2html/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: bmp2html
+# Date created: 10 Aug 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bmp2html
+PORTVERSION= 0.1
+CATEGORIES= graphics
+MASTER_SITES= http://critical.ch/distfiles/
+MASTER_SITES+= http://www.dasfisk.dk/bmp2html/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A bmp to html converter
+
+USE_SDL= yes
+
+LDFLAGS+= -L${LOCALBASE}/lib
+SDL_FLAGS= -I${LOCALBASE}/include/SDL11
+EXTRA_LDFLAGS= -lSDL-1.1 -pthread
+DEFINES= -D_REENTRANT
+
+PLIST_FILES= bin/bmp2html
+
+post-patch:
+ @${RM} ${WRKSRC}/${PORTNAME}
+
+do-build:
+ ${CC} ${CFLAGS} ${LDFLAGS} ${SDL_FLAGS} ${DEFINES} -c \
+ -o ${WRKSRC}/${PORTNAME}.o ${WRKSRC}/${PORTNAME}.c
+ ${CC} ${CFLAGS} ${LDFLAGS} ${SDL_FLAGS} ${EXTRA_LDFLAGS} \
+ -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.o
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/bmp2html/distinfo b/graphics/bmp2html/distinfo
new file mode 100644
index 000000000000..21dfe837080c
--- /dev/null
+++ b/graphics/bmp2html/distinfo
@@ -0,0 +1,2 @@
+MD5 (bmp2html.tar.gz) = fe4ed539e5d91a0a6b16aaf7aa9d942e
+SIZE (bmp2html.tar.gz) = 47943
diff --git a/graphics/bmp2html/pkg-descr b/graphics/bmp2html/pkg-descr
new file mode 100644
index 000000000000..cee3545ecbaa
--- /dev/null
+++ b/graphics/bmp2html/pkg-descr
@@ -0,0 +1,7 @@
+Bmp2html is a simple program that converts a bmpfile to to a html file.
+
+EXAMPLES: http://critical.ch/bmp2html/
+WWW: http://www.dasfisk.dk/bmp2html/
+
+- ehaupt
+ehaupt@critical.ch