aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-05-30 11:42:38 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-05-30 11:42:38 +0000
commitc43626e81519694d9d6ebd92255cbdd08cc46d35 (patch)
tree9206a1ec7d9146943a3eb442fb6415272a539240 /graphics
parentcc3c3f6015883df8f37e5a5713045aa1b1912ab1 (diff)
downloadports-c43626e81519694d9d6ebd92255cbdd08cc46d35.tar.gz
ports-c43626e81519694d9d6ebd92255cbdd08cc46d35.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=297770
Diffstat (limited to 'graphics')
-rw-r--r--graphics/openclipart/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/graphics/openclipart/Makefile b/graphics/openclipart/Makefile
index 6287df5c524d..a8cb40c73a52 100644
--- a/graphics/openclipart/Makefile
+++ b/graphics/openclipart/Makefile
@@ -20,11 +20,13 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}${SVGPNG}
NO_BUILD= yes
PLIST= ${WRKDIR}/pkg-plist
-OPTIONS= PNG "Install png files" on
+OPTIONS_DEFINE= PNG
+OPTIONS_DEFAULT= PNG
+PNG_DESC= Install png files
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_PNG)
+.if ${PORT_OPTIONS:MPNG}
SVGPNG= -full
.else
SVGPNG= -svgonly
@@ -45,4 +47,4 @@ do-install:
@${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} ${SHAREMODE}
@${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} ${BINMODE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>