aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-20 09:57:41 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-10-20 09:57:41 +0000
commitfbec738ceb47b0ee5fb21b24663acf43cf14194c (patch)
tree9b4d105a1744bbfd6c335c63aae32a5d6432b0ed /graphics
parent6fad764e91e00b7b0e22c452c2b2cea42c7e5de7 (diff)
downloadports-fbec738ceb47b0ee5fb21b24663acf43cf14194c.tar.gz
ports-fbec738ceb47b0ee5fb21b24663acf43cf14194c.zip
add pixelize 0.9.2
Use many scaled down images to try to duplicate another image
Notes
Notes: svn path=/head/; revision=68406
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/pixelize/Makefile33
-rw-r--r--graphics/pixelize/distinfo1
-rw-r--r--graphics/pixelize/pkg-comment1
-rw-r--r--graphics/pixelize/pkg-descr9
-rw-r--r--graphics/pixelize/pkg-plist2
6 files changed, 47 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index a3cac0810e7c..c096775a4602 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -284,6 +284,7 @@
SUBDIR += phplot
SUBDIR += picturebook
SUBDIR += piddle
+ SUBDIR += pixelize
SUBDIR += pixmap
SUBDIR += plasma-kmod
SUBDIR += plotmtv
diff --git a/graphics/pixelize/Makefile b/graphics/pixelize/Makefile
new file mode 100644
index 000000000000..0116a8f7e3e8
--- /dev/null
+++ b/graphics/pixelize/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: pixelize
+# Date created: Oct 20, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= pixelize
+PORTVERSION= 0.9.2
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+ ftp://lashwhip.com/pub/ \
+ http://lashwhip.com/pixelize/
+MASTER_SITE_SUBDIR= apps/graphics/misc
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12 imlib
+IMLIB_CONFIG= ${X11BASE}/bin/imlib-config
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|^CC|#CC|" -e "s|CFLAGS = -g|CFLAGS+= |" \
+ -e "s|gtk-config|${GTK_CONFIG}|g" \
+ -e "s|imlib-config|${IMLIB_CONFIG}|g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/make_db ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/pixelize ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/pixelize/distinfo b/graphics/pixelize/distinfo
new file mode 100644
index 000000000000..917ddc7d8802
--- /dev/null
+++ b/graphics/pixelize/distinfo
@@ -0,0 +1 @@
+MD5 (pixelize-0.9.2.tar.gz) = 8f61c0c604d7418acb3ff0b922a2be9e
diff --git a/graphics/pixelize/pkg-comment b/graphics/pixelize/pkg-comment
new file mode 100644
index 000000000000..610a7393b9a1
--- /dev/null
+++ b/graphics/pixelize/pkg-comment
@@ -0,0 +1 @@
+Use many scaled down images to try to duplicate another image
diff --git a/graphics/pixelize/pkg-descr b/graphics/pixelize/pkg-descr
new file mode 100644
index 000000000000..6f383f4d056f
--- /dev/null
+++ b/graphics/pixelize/pkg-descr
@@ -0,0 +1,9 @@
+Pixelize works by splitting up the image you want rendered (or duplicated)
+into a grid of small rectangular areas. Each area is analyzed, and replaced
+with an image chosen from a large database of images. Pixelize tries to pick
+images that best match each area.
+
+Pixelize works best when it can choose images from a very large database of
+images. With about 1000 images, Pixelize can do a reasonable job.
+
+WWW: http://lashwhip.com/pixelize.html
diff --git a/graphics/pixelize/pkg-plist b/graphics/pixelize/pkg-plist
new file mode 100644
index 000000000000..6c55f99f8eae
--- /dev/null
+++ b/graphics/pixelize/pkg-plist
@@ -0,0 +1,2 @@
+bin/make_db
+bin/pixelize