aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2003-07-14 02:53:03 +0000
commitb185046be2ec03555daaf4f26d38542c403a9955 (patch)
tree0274ce607614533de66837fc1f70d4c35770d9e1 /graphics
parent88d002074007544d532f2495aeb93729291e6275 (diff)
downloadports-b185046be2ec03555daaf4f26d38542c403a9955.tar.gz
ports-b185046be2ec03555daaf4f26d38542c403a9955.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead.
Notes
Notes: svn path=/head/; revision=84842
Diffstat (limited to 'graphics')
-rw-r--r--graphics/qiv/Makefile9
-rw-r--r--graphics/stamp/Makefile10
-rw-r--r--graphics/vp/Makefile11
-rw-r--r--graphics/yafaray/Makefile10
-rw-r--r--graphics/yafray/Makefile10
5 files changed, 23 insertions, 27 deletions
diff --git a/graphics/qiv/Makefile b/graphics/qiv/Makefile
index 7e7045b771b5..c1f9b215fc4d 100644
--- a/graphics/qiv/Makefile
+++ b/graphics/qiv/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qiv
PORTVERSION= 1.8
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.klografx.net/qiv/download/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -15,8 +16,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= trevor@FreeBSD.org
COMMENT= Small, fast GDK/Imlib image viewer
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-
+USE_GETOPT_LONG=yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= imlib
@@ -30,10 +30,9 @@ do-configure:
${WRKSRC}/qiv.1.pre_sed > ${WRKSRC}/qiv.1
@ ${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.pre_sed
@ ${SED} -e 's#\/usr\/local#${PREFIX}#' \
- -e 's#RANDOM GETOPT_LONG#RANDOM#' \
-e 's#gcc#${CC}#' \
- -e 's#-O2#${CFLAGS}#' \
- -e 's#libs-gdk`#libs-gdk` -lgnugetopt#' \
+ -e 's#-O2#${CPPFLAGS} ${CFLAGS}#' \
+ -e 's#libs-gdk`#libs-gdk` ${LDFLAGS}#' \
${WRKSRC}/Makefile.pre_sed > ${WRKSRC}/Makefile
do-install:
diff --git a/graphics/stamp/Makefile b/graphics/stamp/Makefile
index 7b230126db5f..3a3ed6b5f352 100644
--- a/graphics/stamp/Makefile
+++ b/graphics/stamp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= stamp
PORTVERSION= 2.0.8
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= stamp
@@ -14,12 +15,13 @@ MASTER_SITE_SUBDIR= stamp
MAINTAINER= billf@FreeBSD.org
COMMENT= Adds a graphical, configurable timestamp to a grayscale image
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgnugetopt"
+CPPFLAGS= -I${LOCALBASE}/include
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib"
USE_GMAKE= unfortunatly
.include <bsd.port.mk>
diff --git a/graphics/vp/Makefile b/graphics/vp/Makefile
index 36a031c21d30..d447985628f9 100644
--- a/graphics/vp/Makefile
+++ b/graphics/vp/Makefile
@@ -7,19 +7,22 @@
PORTNAME= vp
PORTVERSION= 1.5
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://math.smsu.edu/~erik/files/
MAINTAINER= markp@FreeBSD.org
COMMENT= An image viewer for X
-LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+USE_GETOPT_LONG=yes
USE_LIBTOOL= yes
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lgnugetopt" \
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ SDL_CONFIG="${SDL_CONFIG}" \
ac_cv_func_getopt_long=yes
USE_REINPLACE= yes
MAN1= vp.1
diff --git a/graphics/yafaray/Makefile b/graphics/yafaray/Makefile
index a97bcb31f2a4..f4593f46cae2 100644
--- a/graphics/yafaray/Makefile
+++ b/graphics/yafaray/Makefile
@@ -6,6 +6,7 @@
PORTNAME= yafray
PORTVERSION= 0.0.3
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.coala.uniovi.es/~jandro/noname/downloads/
@@ -14,6 +15,7 @@ COMMENT= A fast XML based raytracer
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+USE_GETOPT_LONG=yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
@@ -30,12 +32,6 @@ pre-everything::
@${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500041
-LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
's|-lpthread|${PTHREAD_LIBS}|' \
@@ -48,4 +44,4 @@ post-patch:
s|-Wall|${CXXFLAGS}|' \
${WRKSRC}/src/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/yafray/Makefile b/graphics/yafray/Makefile
index a97bcb31f2a4..f4593f46cae2 100644
--- a/graphics/yafray/Makefile
+++ b/graphics/yafray/Makefile
@@ -6,6 +6,7 @@
PORTNAME= yafray
PORTVERSION= 0.0.3
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.coala.uniovi.es/~jandro/noname/downloads/
@@ -14,6 +15,7 @@ COMMENT= A fast XML based raytracer
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+USE_GETOPT_LONG=yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
@@ -30,12 +32,6 @@ pre-everything::
@${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500041
-LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
's|-lpthread|${PTHREAD_LIBS}|' \
@@ -48,4 +44,4 @@ post-patch:
s|-Wall|${CXXFLAGS}|' \
${WRKSRC}/src/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>