aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-07-23 09:36:51 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-07-23 09:36:51 +0000
commitf935a609c53c5c6031e6848db95c7debed127e27 (patch)
tree4c3cf6af6588247c0dd3f92f9601357c33c56217 /graphics
parent703b5eb18b542fec0e78704ada72142cd2b33175 (diff)
downloadports-f935a609c53c5c6031e6848db95c7debed127e27.tar.gz
ports-f935a609c53c5c6031e6848db95c7debed127e27.zip
- Set --mandir and --infodir in CONFIGURE_ARGS if the configure script
supports them. This is determined by running ``configure --help'' in do-configure target and set the shell variable _LATE_CONFIGURE_ARGS which is then passed to CONFIGURE_ARGS. - Remove --mandir and --infodir in ports' Makefile where applicable Few ports use REINPLACE_CMD to achieve the same effect, remove them too. - Correct some manual pages location from PREFIX/man to MANPREFIX/man - Define INFO_PATH where necessary - Document that .info files are installed in a subdirectory relative to PREFIX/INFO_PATH and slightly change add-plist-info to use INFO_PATH and subdirectory detection. PR: ports/111470 Approved by: portmgr Discussed with: stas (Mk/*), gerald (info related stuffs) Tested by: pointyhat exp run
Notes
Notes: svn path=/head/; revision=196111
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ImageMagick/Makefile2
-rw-r--r--graphics/bugle/Makefile2
-rw-r--r--graphics/digikam-kde4/Makefile1
-rw-r--r--graphics/digikam/Makefile1
-rw-r--r--graphics/exif/Makefile2
-rw-r--r--graphics/exiv2/Makefile1
-rw-r--r--graphics/gimp-app-devel/Makefile2
-rw-r--r--graphics/gimp-app/Makefile1
-rw-r--r--graphics/gphoto2/Makefile2
-rw-r--r--graphics/gthumb/Makefile1
-rw-r--r--graphics/gtkam/Makefile1
-rw-r--r--graphics/gwenview-kde4/Makefile3
-rw-r--r--graphics/gwenview/Makefile3
-rw-r--r--graphics/inkscape/Makefile3
-rw-r--r--graphics/jpeginfo/Makefile2
-rw-r--r--graphics/jpegoptim/Makefile2
-rw-r--r--graphics/kipi-plugins-kde4/Makefile2
-rw-r--r--graphics/kipi-plugins/Makefile2
-rw-r--r--graphics/lcms/Makefile1
-rw-r--r--graphics/libcaca/Makefile3
-rw-r--r--graphics/libgphoto2/Makefile1
-rw-r--r--graphics/passepartout/Makefile1
-rw-r--r--graphics/poppler/Makefile3
-rw-r--r--graphics/qcomicbook/Makefile3
-rw-r--r--graphics/sane-backends/Makefile2
-rw-r--r--graphics/swftools/Makefile1
-rw-r--r--graphics/ufraw/Makefile2
-rw-r--r--graphics/xmedcon/Makefile1
-rw-r--r--graphics/xmorph/Makefile4
29 files changed, 15 insertions, 40 deletions
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index b822a31132cc..0104d95edb81 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -35,7 +35,7 @@ USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15 libltdl:15
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --enable-shared --mandir=${MANPREFIX}/man --without-dps
+CONFIGURE_ARGS= --enable-shared --without-dps
USE_LDCONFIG= yes
MAN1= ImageMagick.1 Magick++-config.1 Magick-config.1 Wand-config.1 \
diff --git a/graphics/bugle/Makefile b/graphics/bugle/Makefile
index 2d05b8a0d553..fcfab7b645e6 100644
--- a/graphics/bugle/Makefile
+++ b/graphics/bugle/Makefile
@@ -26,7 +26,7 @@ USE_AUTOTOOLS= libltdl:15
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/${PORTNAME}
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS=--enable-ltdl-install=no --mandir=${MANPREFIX}/man
+CONFIGURE_ARGS=--enable-ltdl-install=no
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib" \
GL_LIBS="-L${X11BASE}/lib"
diff --git a/graphics/digikam-kde4/Makefile b/graphics/digikam-kde4/Makefile
index 3d454a026000..f8c85edc0e10 100644
--- a/graphics/digikam-kde4/Makefile
+++ b/graphics/digikam-kde4/Makefile
@@ -26,7 +26,6 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
-CONFIGURE_ARGS= --mandir=${PREFIX}/man
USE_GMAKE= yes
USE_KDELIBS_VER=3
USE_GETTEXT= yes
diff --git a/graphics/digikam/Makefile b/graphics/digikam/Makefile
index 3d454a026000..f8c85edc0e10 100644
--- a/graphics/digikam/Makefile
+++ b/graphics/digikam/Makefile
@@ -26,7 +26,6 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
-CONFIGURE_ARGS= --mandir=${PREFIX}/man
USE_GMAKE= yes
USE_KDELIBS_VER=3
USE_GETTEXT= yes
diff --git a/graphics/exif/Makefile b/graphics/exif/Makefile
index 87cf22eb4081..128044330db3 100644
--- a/graphics/exif/Makefile
+++ b/graphics/exif/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= exif.12:${PORTSDIR}/graphics/libexif \
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-popt-prefix=${LOCALBASE} --mandir=${PREFIX}/man
+CONFIGURE_ARGS= --with-popt-prefix=${LOCALBASE}
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
diff --git a/graphics/exiv2/Makefile b/graphics/exiv2/Makefile
index 9d159e33d34f..33ffbe3317ff 100644
--- a/graphics/exiv2/Makefile
+++ b/graphics/exiv2/Makefile
@@ -20,7 +20,6 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
MAN1= exiv2.1
ALLTARGET= all
-CONFIGURE_ARGS= --mandir=${PREFIX}/man
USE_GCC= 3.4+
post-patch:
diff --git a/graphics/gimp-app-devel/Makefile b/graphics/gimp-app-devel/Makefile
index 25f12a11a683..289e041b1e12 100644
--- a/graphics/gimp-app-devel/Makefile
+++ b/graphics/gimp-app-devel/Makefile
@@ -122,8 +122,6 @@ post-patch:
${WRKSRC}/plug-ins/pygimp/Makefile.in
@${REINPLACE_CMD} -e 's|"libpng"|"libpng12"|' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|@mandir@|${PREFIX}/man|' \
- ${WRKSRC}/docs/Makefile.in
post-install:
.if !defined(GIMP_SLAVE)
diff --git a/graphics/gimp-app/Makefile b/graphics/gimp-app/Makefile
index acbf73b65439..79e73164ca22 100644
--- a/graphics/gimp-app/Makefile
+++ b/graphics/gimp-app/Makefile
@@ -48,7 +48,6 @@ CONFIGURE_ARGS= --disable-perl \
--docdir=${PREFIX}/share/doc/gimp \
--disable-gtk-doc \
--enable-static \
- --mandir=${PREFIX}/man \
--disable-print
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
diff --git a/graphics/gphoto2/Makefile b/graphics/gphoto2/Makefile
index 434810fb75dd..b35bd4d3b85f 100644
--- a/graphics/gphoto2/Makefile
+++ b/graphics/gphoto2/Makefile
@@ -25,7 +25,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --without-cdk --mandir=${PREFIX}/man
+CONFIGURE_ARGS= --without-cdk
MAN1= gphoto2.1
diff --git a/graphics/gthumb/Makefile b/graphics/gthumb/Makefile
index 4addcc74d2f1..c3e2133fbe2b 100644
--- a/graphics/gthumb/Makefile
+++ b/graphics/gthumb/Makefile
@@ -26,7 +26,6 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
-CONFIGURE_ARGS= --mandir=${PREFIX}/man
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/graphics/gtkam/Makefile b/graphics/gtkam/Makefile
index b1065624278f..7e71664909f3 100644
--- a/graphics/gtkam/Makefile
+++ b/graphics/gtkam/Makefile
@@ -22,7 +22,6 @@ USE_XLIB= yes
WANT_GNOME= yes
USE_GNOME= gnomehack gnomehier gnometarget gtk20
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --mandir=${PREFIX}/man
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/graphics/gwenview-kde4/Makefile b/graphics/gwenview-kde4/Makefile
index 2100508080dc..30d0b7449132 100644
--- a/graphics/gwenview-kde4/Makefile
+++ b/graphics/gwenview-kde4/Makefile
@@ -23,8 +23,7 @@ USE_GMAKE= yes
USE_KDELIBS_VER=3
USE_AUTOTOOLS= libtool:15
-CONFIGURE_ARGS+=--enable-kipi \
- --mandir=${MANPREFIX}/man
+CONFIGURE_ARGS+=--enable-kipi
MAN1= gwenview.1
diff --git a/graphics/gwenview/Makefile b/graphics/gwenview/Makefile
index 2100508080dc..30d0b7449132 100644
--- a/graphics/gwenview/Makefile
+++ b/graphics/gwenview/Makefile
@@ -23,8 +23,7 @@ USE_GMAKE= yes
USE_KDELIBS_VER=3
USE_AUTOTOOLS= libtool:15
-CONFIGURE_ARGS+=--enable-kipi \
- --mandir=${MANPREFIX}/man
+CONFIGURE_ARGS+=--enable-kipi
MAN1= gwenview.1
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index ef994c62485a..6de1506285c1 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -28,8 +28,7 @@ USE_GNOME= gnomehack desktopfileutils intlhack libxslt
USE_GETTEXT= yes
GNU_CONFIGURE= yes
USE_GCC= 3.4+
-CONFIGURE_ARGS= --with-popt \
- --mandir=${PREFIX}/man
+CONFIGURE_ARGS= --with-popt
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
diff --git a/graphics/jpeginfo/Makefile b/graphics/jpeginfo/Makefile
index 646a60d41a91..a5f6192e82c4 100644
--- a/graphics/jpeginfo/Makefile
+++ b/graphics/jpeginfo/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-MAKE_ARGS= mandir=${PREFIX}/man
+MAKE_ARGS= mandir=${MANPREFIX}/man
MAN1= jpeginfo.1
PLIST_FILES= bin/jpeginfo
diff --git a/graphics/jpegoptim/Makefile b/graphics/jpegoptim/Makefile
index c3d3fa8ab5b4..18136ecc39ee 100644
--- a/graphics/jpegoptim/Makefile
+++ b/graphics/jpegoptim/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-libjpeg=${LOCALBASE}
-MAKE_ARGS= mandir=${PREFIX}/man
+MAKE_ARGS= mandir=${MANPREFIX}/man
MAN1= jpegoptim.1
PLIST_FILES= bin/jpegoptim
diff --git a/graphics/kipi-plugins-kde4/Makefile b/graphics/kipi-plugins-kde4/Makefile
index 303cf0d58018..1de4e318dcfe 100644
--- a/graphics/kipi-plugins-kde4/Makefile
+++ b/graphics/kipi-plugins-kde4/Makefile
@@ -48,8 +48,6 @@ USE_KDELIBS_VER=3
USE_GETTEXT= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --mandir=${PREFIX}/man
-
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_ACQUIREIMAGES)
diff --git a/graphics/kipi-plugins/Makefile b/graphics/kipi-plugins/Makefile
index 303cf0d58018..1de4e318dcfe 100644
--- a/graphics/kipi-plugins/Makefile
+++ b/graphics/kipi-plugins/Makefile
@@ -48,8 +48,6 @@ USE_KDELIBS_VER=3
USE_GETTEXT= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --mandir=${PREFIX}/man
-
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_ACQUIREIMAGES)
diff --git a/graphics/lcms/Makefile b/graphics/lcms/Makefile
index 589944307a20..d00b95c43cda 100644
--- a/graphics/lcms/Makefile
+++ b/graphics/lcms/Makefile
@@ -22,7 +22,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --mandir="${PREFIX}/man/"
USE_LDCONFIG= yes
OPTIONS= TIFFICC "Build color profile applier for tiff" off \
diff --git a/graphics/libcaca/Makefile b/graphics/libcaca/Makefile
index b90e3d3a514d..9de73ccb64e2 100644
--- a/graphics/libcaca/Makefile
+++ b/graphics/libcaca/Makefile
@@ -20,8 +20,7 @@ USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lm -lncurses"
CONFIGURE_ARGS= --disable-doc \
- --enable-ncurses \
- --mandir=${PREFIX}/man
+ --enable-ncurses
DOCS= AUTHORS COPYING COPYING.GPL COPYING.LGPL ChangeLog NEWS \
NOTES README THANKS TODO
diff --git a/graphics/libgphoto2/Makefile b/graphics/libgphoto2/Makefile
index 9114e131636a..8bb1b502c9eb 100644
--- a/graphics/libgphoto2/Makefile
+++ b/graphics/libgphoto2/Makefile
@@ -22,7 +22,6 @@ USE_GNOME= gnometarget pkgconfig ltverhack
USE_GETOPT_LONG= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
-CONFIGURE_ARGS= --mandir=${PREFIX}/man
LIBTOOLFILES= configure libgphoto2_port/configure
USE_LDCONFIG= yes
PLIST_SUB= VERSION="${PORTVERSION}" VERSION_PORT=0.7.1
diff --git a/graphics/passepartout/Makefile b/graphics/passepartout/Makefile
index 8998c7db4037..18b0adfa08e3 100644
--- a/graphics/passepartout/Makefile
+++ b/graphics/passepartout/Makefile
@@ -25,7 +25,6 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnometarget
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
CONFIGURE_ENV= CFALGS=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib
diff --git a/graphics/poppler/Makefile b/graphics/poppler/Makefile
index 72b0680b6a32..a7549c19f4c9 100644
--- a/graphics/poppler/Makefile
+++ b/graphics/poppler/Makefile
@@ -23,8 +23,7 @@ USE_GNOME= gnomehack gnometarget libxml2
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-zlib \
--enable-xpdf-headers \
- --with-html-dir=${DOCSDIR} \
- --mandir=${PREFIX}/man
+ --with-html-dir=${DOCSDIR}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
diff --git a/graphics/qcomicbook/Makefile b/graphics/qcomicbook/Makefile
index e813603089c1..484d47554f2f 100644
--- a/graphics/qcomicbook/Makefile
+++ b/graphics/qcomicbook/Makefile
@@ -23,8 +23,7 @@ USE_QT_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man \
- --with-Qt-dir="${QT_PREFIX}"
+CONFIGURE_ARGS= --with-Qt-dir="${QT_PREFIX}"
MAN1= qcomicbook.1
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index cbc9bb837adb..86fb6e1d9bda 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -32,7 +32,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --mandir=${PREFIX}/man --with-docdir=${DOCSDIR} \
+CONFIGURE_ARGS= --with-docdir=${DOCSDIR} \
--disable-locking
MAKE_ENV= NOPORTDOCS=${NOPORTDOCS}
diff --git a/graphics/swftools/Makefile b/graphics/swftools/Makefile
index 91277d71a068..947d82ea8713 100644
--- a/graphics/swftools/Makefile
+++ b/graphics/swftools/Makefile
@@ -25,7 +25,6 @@ USE_GCC= 3.4+
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
MAN1= font2swf.1 gif2swf.1 jpeg2swf.1 pdf2swf.1 png2swf.1 \
swfbbox.1 swfc.1 swfcombine.1 swfdump.1 swfextract.1 \
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index 8984147e6878..e9faa9ca2fa8 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -30,7 +30,7 @@ WANT_GNOME= yes
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CPPFLAGS= -I${LOCALBASE}/include
CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man --enable-mime
+CONFIGURE_ARGS= --enable-mime
.ifndef WITHOUT_EXIF
LIB_DEPENDS+= exif:${PORTSDIR}/graphics/libexif
diff --git a/graphics/xmedcon/Makefile b/graphics/xmedcon/Makefile
index 1942e84a14ea..e8923370f704 100644
--- a/graphics/xmedcon/Makefile
+++ b/graphics/xmedcon/Makefile
@@ -36,7 +36,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --includedir=${PREFIX}/include/xmedcon \
- --mandir=${MANPREFIX}/man \
--enable-llcheck
USE_LDCONFIG= yes
diff --git a/graphics/xmorph/Makefile b/graphics/xmorph/Makefile
index 77486652583b..b07498fcd6ce 100644
--- a/graphics/xmorph/Makefile
+++ b/graphics/xmorph/Makefile
@@ -30,9 +30,7 @@ USE_XORG= xbitmaps
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-CONFIGURE_ARGS= --infodir=${PREFIX}/${INFO_PATH} \
- --mandir=${MANPREFIX}/man \
- --without-waili
+CONFIGURE_ARGS= --without-waili
USE_LDCONFIG= yes
MAN1= gtkmorph.1 xmorph.1