aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2010-08-15 19:39:34 +0000
committerJuergen Lock <nox@FreeBSD.org>2010-08-15 19:39:34 +0000
commitd939de544045f64094a88821f1b3fbff85df6daf (patch)
tree60edc561f3132ccdf9cacf79ddfd85428ef1ba5e /graphics
parent61b31f74b45ae151e324b183ddfe33e659c6da57 (diff)
downloadports-d939de544045f64094a88821f1b3fbff85df6daf.tar.gz
ports-d939de544045f64094a88821f1b3fbff85df6daf.zip
- Update graphics/wxsvg to 1.0.5 and wx 2.8 which thus needs an Mk/bsd.wx.mk
change. - Update multimedia/dvdstyler to 1.8.1 which seems to be the only port in the tree using wxsvg. Approved by: kwm (for -multimedia), portmgr (pav, for Mk/bsd.wx.mk)
Notes
Notes: svn path=/head/; revision=259319
Diffstat (limited to 'graphics')
-rw-r--r--graphics/wxsvg/Makefile20
-rw-r--r--graphics/wxsvg/distinfo6
-rw-r--r--graphics/wxsvg/files/patch-configure.in11
-rw-r--r--graphics/wxsvg/pkg-plist10
4 files changed, 19 insertions, 28 deletions
diff --git a/graphics/wxsvg/Makefile b/graphics/wxsvg/Makefile
index e494f9dd4817..668bea2d62d6 100644
--- a/graphics/wxsvg/Makefile
+++ b/graphics/wxsvg/Makefile
@@ -6,20 +6,24 @@
# $MCom: ports/graphics/wxsvg/Makefile,v 1.1 2006/09/22 01:48:33 ahze Exp $
PORTNAME= wxsvg
-DISTVERSION= 1.0b7_2
-PORTREVISION= 5
+DISTVERSION= 1.0.5
CATEGORIES= graphics
-MASTER_SITES= SF/${PORTNAME}/OldFiles
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ library to create, manipulate, and render SVG files
-AUTOMAKE_ARGS= --add-missing
+LIB_DEPENDS+= avformat.1:${PORTSDIR}/multimedia/ffmpeg
+
+USE_BZIP2= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool:22 automake:15 autoconf:262
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-wx-config=${LOCALBASE}/bin/wxgtk2-2.8-config
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
USE_GNOME= libartlgpl2
USE_GMAKE= yes
-USE_WX= 2.6
+USE_WX= 2.8
post-patch:
@cd ${WRKSRC} && \
@@ -27,8 +31,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|WX_CONFIG_NAME=wx-config|WX_CONFIG_NAME=${WX_CONFIG}|' \
${WRKSRC}/*.m4
-pre-configure:
- @cd ${WRKSRC}; ${SETENV} ${AUTOMAKE_ENV} ${ACLOCAL} -I .; \
- ${SETENV} ${SCRIPTS_ENV} ${LIBTOOLIZE} --automake
-
.include <bsd.port.mk>
diff --git a/graphics/wxsvg/distinfo b/graphics/wxsvg/distinfo
index f37ac97f7e5c..082d8bea7a9e 100644
--- a/graphics/wxsvg/distinfo
+++ b/graphics/wxsvg/distinfo
@@ -1,3 +1,3 @@
-MD5 (wxsvg-1.0b7_2.tar.gz) = 5700d30555a6459377c87b817b3276d7
-SHA256 (wxsvg-1.0b7_2.tar.gz) = 463ae9b3bbc4a67bc206885c7522c072ab38c0293553cbf0f9b981e94d9b1360
-SIZE (wxsvg-1.0b7_2.tar.gz) = 592442
+MD5 (wxsvg-1.0.5.tar.bz2) = 27ead41fa22fc70fc490983c6bd217cf
+SHA256 (wxsvg-1.0.5.tar.bz2) = 816ee1922b11edab450903c99ba46cd49fdc4991c2f493e3d4470b14df11871b
+SIZE (wxsvg-1.0.5.tar.bz2) = 639450
diff --git a/graphics/wxsvg/files/patch-configure.in b/graphics/wxsvg/files/patch-configure.in
deleted file mode 100644
index 3a392f9a09dc..000000000000
--- a/graphics/wxsvg/files/patch-configure.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.in.orig Thu Feb 22 18:29:47 2007
-+++ configure.in Thu Feb 22 18:30:09 2007
-@@ -3,7 +3,7 @@
- dnl initialization
- AC_PREREQ(2.57)
- AC_INIT([wxsvgtest], [1.0], [wx-svg-users@lists.sourceforge.net])
--AM_INIT_AUTOMAKE
-+AM_INIT_AUTOMAKE(wxsvg, 1.0b7)
- AM_MAINTAINER_MODE
-
- dnl options
diff --git a/graphics/wxsvg/pkg-plist b/graphics/wxsvg/pkg-plist
index 744d47d2cdf2..d33c6a86e19b 100644
--- a/graphics/wxsvg/pkg-plist
+++ b/graphics/wxsvg/pkg-plist
@@ -11,6 +11,7 @@ include/wxSVG/ElementTimeControl.h
include/wxSVG/EventTarget.h
include/wxSVG/GetSVGDocument.h
include/wxSVG/NodeList.h
+include/wxSVG/NodeListCls.h
include/wxSVG/RGBColor.h
include/wxSVG/SVGAElement.h
include/wxSVG/SVGAltGlyphDefElement.h
@@ -176,15 +177,16 @@ include/wxSVG/SVGViewElement.h
include/wxSVG/SVGViewSpec.h
include/wxSVG/SVGZoomAndPan.h
include/wxSVG/SVGZoomEvent.h
-include/wxSVG/String.h
+include/wxSVG/String_wxsvg.h
include/wxSVG/ViewCSS.h
+include/wxSVG/mediadec_ffmpeg.h
include/wxSVG/svg.h
include/wxSVG/svgctrl.h
-include/wxXML/xml.h
-include/wxXML/xmlhelpr.h
+include/wxSVGXML/svgxml.h
+include/wxSVGXML/svgxmlhelpr.h
lib/libwxsvg.a
lib/libwxsvg.la
lib/libwxsvg.so
lib/libwxsvg.so.0
-@dirrm include/wxXML
+@dirrm include/wxSVGXML
@dirrm include/wxSVG