aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2009-03-09 22:15:20 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2009-03-09 22:15:20 +0000
commit217e0a7831bcfe1c6690d7a3d3ba115fcc15a16b (patch)
treeea8fd16cb737b2111a867560a9846b9cfe1282cf /graphics
parentc737c1c0da5820505f0cf9edd287ec222bd91554 (diff)
downloadports-217e0a7831bcfe1c6690d7a3d3ba115fcc15a16b.tar.gz
ports-217e0a7831bcfe1c6690d7a3d3ba115fcc15a16b.zip
- Update to 0.0.22
- Implement OPTIONS
Notes
Notes: svn path=/head/; revision=229808
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gegl/Makefile60
-rw-r--r--graphics/gegl/distinfo6
-rw-r--r--graphics/gegl/pkg-plist15
3 files changed, 67 insertions, 14 deletions
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index ba375c933c00..64574c5f178a 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -16,14 +16,18 @@ COMMENT= A graph based image processing framework
LIB_DEPENDS= babl-0.0:${PORTSDIR}/x11/babl \
png.5:${PORTSDIR}/graphics/png \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
- IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
- cairo.2:${PORTSDIR}/graphics/cairo \
- avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
- rsvg-2.2:${PORTSDIR}/graphics/librsvg2
-USE_GNOME= glib20 gtk20 pango pkgconfig gnomehack
-USE_SDL= sdl
+OPTIONS= CAIRO "Enable Cairo" on \
+ FFMPEG "Enable ffmpeg" on \
+ GTK "Enable GTK+" on \
+ JPEG "Enable JPEG" on \
+ OPENEXR "Enable OpenEXR" on \
+ OPENRAW "Enable OpenRAW" on \
+ PANGO "Enable Pango" on \
+ RSVG "Enable RSVG" on \
+ SDL "Enable SDL" on
+
+USE_GNOME= glib20 pkgconfig gnomehack
USE_BZIP2= yes
USE_GMAKE= yes
USE_LDCONFIG= ${PREFIX}/lib/gegl-0.0
@@ -34,12 +38,50 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS+=--disable-sse \
--disable-mmx
-GEGL_MINOR= 20
+GEGL_MINOR= 22
PLIST_SUB+= GEGL_MINOR="${GEGL_MINOR}"
EXAMPLES= 2geglbuffer gegl-paint geglbuffer-add-image \
geglbuffer-clock hello-world hello-world-video
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_CAIRO)
+LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
+.endif
+
+.if !defined(WITHOUT_FFMPEG)
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+.endif
+
+.if !defined(WITHOUT_GTK)
+USE_GNOME+= gtk20
+.endif
+
+.if !defined(WITHOUT_JPEG)
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
+.endif
+
+.if !defined(WITHOUT_OPENEXR)
+LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR
+.endif
+
+.if !defined(WITHOUT_OPENRAW)
+LIB_DEPENDS+= openraw.5:${PORTSDIR}/graphics/libopenraw
+.endif
+
+.if !defined(WITHOUT_PANGO)
+USE_GNOME+= pango
+.endif
+
+.if !defined(WITHOUT_RSVG)
+LIB_DEPENDS+= rsvg-2.2:${PORTSDIR}/graphics/librsvg2
+.endif
+
+.if !defined(WITHOUT_SDL)
+USE_SDL= sdl
+.endif
+
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= a2x:${PORTSDIR}/textproc/asciidoc
.else
@@ -72,4 +114,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/gegl/distinfo b/graphics/gegl/distinfo
index dc2561f67f3a..fb80ecf4b00f 100644
--- a/graphics/gegl/distinfo
+++ b/graphics/gegl/distinfo
@@ -1,3 +1,3 @@
-MD5 (gegl-0.0.20.tar.bz2) = 2e1f97ec8abd9a4a21f458b43799bff2
-SHA256 (gegl-0.0.20.tar.bz2) = 708bb6afef9dc896caeaa618238bd67dd8548be5b774ce3c67664b716b550db7
-SIZE (gegl-0.0.20.tar.bz2) = 1224221
+MD5 (gegl-0.0.22.tar.bz2) = e2196c2016d16a4479e157f8fdee4162
+SHA256 (gegl-0.0.22.tar.bz2) = 857233c84fe4a215466582eeeac3e719059f2d467f700a9f6885c35f55caa65b
+SIZE (gegl-0.0.22.tar.bz2) = 1255087
diff --git a/graphics/gegl/pkg-plist b/graphics/gegl/pkg-plist
index 8020eebe9c89..ab3655545dfc 100644
--- a/graphics/gegl/pkg-plist
+++ b/graphics/gegl/pkg-plist
@@ -3,7 +3,9 @@ include/gegl-0.0/gegl-buffer.h
include/gegl-0.0/gegl-chant.h
include/gegl-0.0/gegl-color.h
include/gegl-0.0/gegl-curve.h
+include/gegl-0.0/gegl-matrix.h
include/gegl-0.0/gegl-paramspecs.h
+include/gegl-0.0/gegl-path.h
include/gegl-0.0/gegl-plugin.h
include/gegl-0.0/gegl-utils.h
include/gegl-0.0/gegl-simd.h
@@ -84,8 +86,6 @@ lib/gegl-0.0/exr-load.la
lib/gegl-0.0/exr-load.so
lib/gegl-0.0/ff-load.la
lib/gegl-0.0/ff-load.so
-lib/gegl-0.0/fill.la
-lib/gegl-0.0/fill.so
lib/gegl-0.0/fractal-explorer.la
lib/gegl-0.0/fractal-explorer.so
lib/gegl-0.0/gamma.la
@@ -130,10 +130,14 @@ lib/gegl-0.0/opacity.la
lib/gegl-0.0/opacity.so
lib/gegl-0.0/open-buffer.la
lib/gegl-0.0/open-buffer.so
+lib/gegl-0.0/openraw.la
+lib/gegl-0.0/openraw.so
lib/gegl-0.0/over.la
lib/gegl-0.0/over.so
lib/gegl-0.0/overlay.la
lib/gegl-0.0/overlay.so
+lib/gegl-0.0/path.la
+lib/gegl-0.0/path.so
lib/gegl-0.0/pixbuf.la
lib/gegl-0.0/pixbuf.so
lib/gegl-0.0/plus.la
@@ -205,6 +209,10 @@ lib/gegl-0.0/write-buffer.so
lib/gegl-0.0/xor.la
lib/gegl-0.0/xor.so
libdata/pkgconfig/gegl.pc
+%%PORTDOCS%%share/gtk-doc/html/gegl/operations.html
+%%PORTDOCS%%share/gtk-doc/html/gegl/api.html
+%%PORTDOCS%%share/gtk-doc/html/gegl/gegl.devhelp
+%%PORTDOCS%%share/gtk-doc/html/gegl/gegl.css
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/api.html
%%PORTDOCS%%%%DOCSDIR%%/brightness-contrast.c.html
@@ -250,6 +258,9 @@ libdata/pkgconfig/gegl.pc
@dirrm include/gegl-0.0/operation
@dirrm include/gegl-0.0
@dirrm lib/gegl-0.0
+%%PORTDOCS%%@dirrm share/gtk-doc/html/gegl
+%%PORTDOCS%%@dirrm share/gtk-doc/html
+%%PORTDOCS%%@dirrm share/gtk-doc
%%PORTDOCS%%@dirrm %%DOCSDIR%%/gallery
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/data