aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2016-12-30 17:01:49 +0000
committerMatthias Andree <mandree@FreeBSD.org>2016-12-30 17:01:49 +0000
commitb44b552c8b3d1b899ad883f44960890384f17733 (patch)
treea8520124c1a46451285b1f243961d56fd73d3eb0 /graphics
parenta512804ddb5709389a380a29d573c88d7502ec4c (diff)
downloadports-b44b552c8b3d1b899ad883f44960890384f17733.tar.gz
ports-b44b552c8b3d1b899ad883f44960890384f17733.zip
Clean up, minor options fixes and shuffling.
- drop -ffast-math from the compiler flags [1] - drop libc++ hacks for FreeBSD 9.x/10.1 and use the new gcc-c++11-lib [2] - be sure to optimize for packaging when PACKAGE_BUILDING [3] - simplify CMake OPTION_OMP passing [2] - bump PORTREVISION Reported by: Ingo Weyrich [1], jbeich@ [2], DrSlony
Notes
Notes: svn path=/head/; revision=430006
Diffstat (limited to 'graphics')
-rw-r--r--graphics/rawtherapee/Makefile37
1 files changed, 11 insertions, 26 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index 885f23b05234..dd7f8a10315b 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rawtherapee
PORTVERSION= 4.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= http://rawtherapee.com/shared/source/
@@ -22,7 +22,8 @@ LIB_DEPENDS= libgtkmm-2.4.so:x11-toolkits/gtkmm24 \
libfftw3f.so:math/fftw3-float \
libcanberra-gtk3.so:audio/libcanberra-gtk3
-USES= cmake:outsource compiler:features desktop-file-utils dos2unix jpeg pkgconfig tar:xz
+USES= cmake:outsource compiler:gcc-c++11-lib desktop-file-utils dos2unix \
+ jpeg pkgconfig tar:xz
DOS2UNIX_REGEX= .*\.(cc|h)
USE_GNOME= gtk20 glib20
USE_LDCONFIG= yes
@@ -43,6 +44,10 @@ SUB_FILES= rawtherapee
SUB_LIST= RTDIR="${RTDIR}"
INSTALLS_ICONS= yes
+.if defined(PACKAGE_BUILDING)
+CMAKE_ARGS+= -DPROC_TARGET_NUMBER="1"
+.endif
+
RTDIR= ${PREFIX}/libdata/${PORTNAME}
OPTIONS_DEFINE= OPTIMIZED_CFLAGS OPENMP
@@ -50,41 +55,21 @@ OPTIONS_DEFAULT= OPTIMIZED_CFLAGS OPENMP
OPENMP_DESC= Enable multicore processing using OpenMP
OPTIMIZED_CFLAGS_DESC= Use extra compiler optimizations (requires SSE support)
+OPENMP_CMAKE_BOOL= OPTION_OMP
+
.include <bsd.port.pre.mk>
# -------------------------------------------------------------------
-# USE_GCC must be late so the compiler feature checks work to detect
-# that the base C++ standard library switched to libc++:
-# We also must pin 4.8+ because 4.6 and 4.7 segfault on 10.0-RELEASE amd64
-# wwhen compiling improcfun.cc:
-USE_GCC= yes
-
-.if ${COMPILER_FEATURES:Mlibc++}
-LDFLAGS+= -L/usr/local/lib/c++
-CXXFLAGS+= -nostdinc++ -isystem /usr/local/include/c++/v1
-CFLAGS+= -isystem /usr/local/include/c++/v1
-BUILD_DEPENDS+= ${LOCALBASE}/lib/c++/libstdc++.so:devel/libc++
-.endif
.if ${ARCH} == "amd64" || ${ARCH} == "i386"
.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
-CFLAGS+= -O3 -ffast-math -fexpensive-optimizations \
+CFLAGS+= -O3 -fexpensive-optimizations \
-funroll-loops -msse
-CXXFLAGS+= -O3 -ffast-math \
+CXXFLAGS+= -O3 \
-funroll-loops -msse
.endif
.endif
-.if ${PORT_OPTIONS:MOPENMP}
-CMAKE_ARGS+= -DOPTION_OMP:BOOL=ON
-.else
-CMAKE_ARGS+= -DOPTION_OMP:BOOL=OFF
-.endif
-
-#.if ${OSVERSION} >= 1100000
-#BROKEN= rawtherapee is known to crash on -HEAD and requires debugging that the maintainer cannot provide.
-#.endif
-
# -------------------------------------------------------------------
post-patch: