aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-01-12 12:54:32 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-01-12 12:54:32 +0000
commitb4d2ac42d75b14c1701e169420211799bf5e16bd (patch)
treea82a16fe7e91ef33fa7fadab2d807bbc87d15f69 /graphics
parent679b9b10d2f7af4b1e0910de9e09cc871eec2238 (diff)
downloadports-b4d2ac42d75b14c1701e169420211799bf5e16bd.tar.gz
ports-b4d2ac42d75b14c1701e169420211799bf5e16bd.zip
- Update graphics/libglut to 6.4.1.
- Shared lib version and PORTREVISION bumb for all affected ports. While I'm here: - Remove USE_MESA knob where it was (35 ports). It marked as depricated for 2 years. PR: ports/90247 Submitted by: Ermal Lu?i <eri--@albabsd.org>
Notes
Notes: svn path=/head/; revision=153347
Diffstat (limited to 'graphics')
-rw-r--r--graphics/OpenEXR/Makefile6
-rw-r--r--graphics/animabob/Makefile4
-rw-r--r--graphics/blender/Makefile5
-rw-r--r--graphics/crystalentitylayer-devel/Makefile1
-rw-r--r--graphics/crystalentitylayer/Makefile1
-rw-r--r--graphics/crystalspace-devel/Makefile1
-rw-r--r--graphics/crystalspace/Makefile1
-rw-r--r--graphics/driconf/Makefile3
-rw-r--r--graphics/dynamechs/Makefile4
-rw-r--r--graphics/fv/Makefile3
-rw-r--r--graphics/gauche-gl/Makefile3
-rw-r--r--graphics/geomview/Makefile5
-rw-r--r--graphics/giram/Makefile2
-rw-r--r--graphics/gle/Makefile4
-rw-r--r--graphics/gltk/Makefile4
-rw-r--r--graphics/gltt/Makefile5
-rw-r--r--graphics/kdegraphics3/Makefile1
-rw-r--r--graphics/kdegraphics4/Makefile1
-rw-r--r--graphics/kludge3d/Makefile2
-rw-r--r--graphics/landscape/Makefile4
-rw-r--r--graphics/lib3ds/Makefile4
-rw-r--r--graphics/libaux/Makefile4
-rw-r--r--graphics/libglut/Makefile4
-rw-r--r--graphics/libglut/distinfo6
-rw-r--r--graphics/libglut/files/Makefile2
-rw-r--r--graphics/libglut/pkg-plist2
-rw-r--r--graphics/libv3d/Makefile5
-rw-r--r--graphics/libwpcg/Makefile4
-rw-r--r--graphics/lphoto/Makefile2
-rw-r--r--graphics/morpheus/Makefile6
-rw-r--r--graphics/ocaml-images/Makefile1
-rw-r--r--graphics/ocaml-lablgl/Makefile3
-rw-r--r--graphics/p5-OpenGL/Makefile4
-rw-r--r--graphics/py-cgkit/Makefile1
-rw-r--r--graphics/py-opengl/Makefile4
-rw-r--r--graphics/pyro/Makefile3
-rw-r--r--graphics/qslim/Makefile6
-rw-r--r--graphics/quat-gui/Makefile5
-rw-r--r--graphics/renderpark/Makefile7
-rw-r--r--graphics/ruby-opengl/Makefile6
-rw-r--r--graphics/threeDS/Makefile1
-rw-r--r--graphics/tulip/Makefile4
-rw-r--r--graphics/view3ds/Makefile6
-rw-r--r--graphics/visionegg/Makefile5
-rw-r--r--graphics/vvv/Makefile3
-rw-r--r--graphics/white_dune/Makefile3
-rw-r--r--graphics/xmms-dancingparticles/Makefile3
-rw-r--r--graphics/xmms-fishmatic/Makefile4
-rw-r--r--graphics/xmms-paranormal/Makefile6
49 files changed, 106 insertions, 68 deletions
diff --git a/graphics/OpenEXR/Makefile b/graphics/OpenEXR/Makefile
index 7e9f59048d75..f32a837fba24 100644
--- a/graphics/OpenEXR/Makefile
+++ b/graphics/OpenEXR/Makefile
@@ -7,7 +7,7 @@
PORTNAME= OpenEXR
PORTVERSION= 1.2.2
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= graphics devel
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= openexr
@@ -27,11 +27,11 @@ EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}-${PORTVERSION}
.if !defined(WITHOUT_X11) && defined(WITH_FLTK)
CONFIGURE_ARGS+=--with-fltk-config=${X11BASE}/bin/fltk-config
-USE_MESA= YES
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
PLIST_SUB+= WITH_FLTK=
-LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk-threads
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk-threads \
+ glut.4:${PORTSDIR}/graphics/libglut
.else
CONFIGURE_ARGS+=--with-fltk-config=${FALSE} --without-x
PLIST_SUB+= WITH_FLTK="@comment "
diff --git a/graphics/animabob/Makefile b/graphics/animabob/Makefile
index 4b120279f858..8985a97272a0 100644
--- a/graphics/animabob/Makefile
+++ b/graphics/animabob/Makefile
@@ -7,6 +7,7 @@
PORTNAME= animabob
PORTVERSION= 1.3.0b
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= #
@@ -16,8 +17,9 @@ COMMENT= Interactive 3D volume renderer
DEPRECATED= mastersite disappeared, no longer maintained by author
EXPIRATION_DATE= 2006-02-16
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
USE_IMAKE= yes
-USE_MESA= yes
USE_MOTIF= yes
USE_REINPLACE= yes
ALL_TARGET= build
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index 5cca03fff7ed..e9b5021c7645 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -7,7 +7,7 @@
PORTNAME= blender
PORTVERSION= 2.25
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics games
MASTER_SITES= http://download.blender.org/release/Publisher${PORTVERSION}/
DISTNAME= blender-publisher-${PORTVERSION}-freebsd-4.2-i386
@@ -16,10 +16,11 @@ DIST_SUBDIR= blender
MAINTAINER= dyeske@yahoo.com
COMMENT= Fully functional 3D modeling/rendering/animation/gaming package
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
USE_X_PREFIX= YES
NO_BUILD= YES
ONLY_FOR_ARCHS= i386
-USE_MESA= YES
.include <bsd.port.pre.mk>
diff --git a/graphics/crystalentitylayer-devel/Makefile b/graphics/crystalentitylayer-devel/Makefile
index 1d876e767278..6d6c8c4431c1 100644
--- a/graphics/crystalentitylayer-devel/Makefile
+++ b/graphics/crystalentitylayer-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= crystalentitylayer
PORTVERSION= 0.99
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= cel
diff --git a/graphics/crystalentitylayer/Makefile b/graphics/crystalentitylayer/Makefile
index 1d876e767278..6d6c8c4431c1 100644
--- a/graphics/crystalentitylayer/Makefile
+++ b/graphics/crystalentitylayer/Makefile
@@ -7,6 +7,7 @@
PORTNAME= crystalentitylayer
PORTVERSION= 0.99
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= cel
diff --git a/graphics/crystalspace-devel/Makefile b/graphics/crystalspace-devel/Makefile
index 435165270870..559c3a317668 100644
--- a/graphics/crystalspace-devel/Makefile
+++ b/graphics/crystalspace-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= crystalspace
PORTVERSION= 0.99
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= crystal
diff --git a/graphics/crystalspace/Makefile b/graphics/crystalspace/Makefile
index 435165270870..559c3a317668 100644
--- a/graphics/crystalspace/Makefile
+++ b/graphics/crystalspace/Makefile
@@ -7,6 +7,7 @@
PORTNAME= crystalspace
PORTVERSION= 0.99
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= crystal
diff --git a/graphics/driconf/Makefile b/graphics/driconf/Makefile
index e70bb10b0905..d8fa7b79e072 100644
--- a/graphics/driconf/Makefile
+++ b/graphics/driconf/Makefile
@@ -7,13 +7,14 @@
PORTNAME= driconf
PORTVERSION= 0.2.6
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://dri.freedesktop.org/~fxkuehl/driconf/
MAINTAINER= anholt@FreeBSD.org
COMMENT= Configuration program for DRI drivers
-LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:${PORTSDIR}/x11-toolkits/py-gtk2
USE_PYTHON= yes
diff --git a/graphics/dynamechs/Makefile b/graphics/dynamechs/Makefile
index 3966c1d4965f..89318dc6fca1 100644
--- a/graphics/dynamechs/Makefile
+++ b/graphics/dynamechs/Makefile
@@ -8,7 +8,7 @@
PORTNAME= dynamechs
PORTVERSION= 4.0.p1
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -18,7 +18,7 @@ DISTNAME= ${PORTNAME}_${PORTVERSION:S/.p/pre/}
MAINTAINER= ports@FreeBSD.org
COMMENT= A Multibody Dynamic Simulation Library
-LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
USE_BZIP2= yes
USE_GL= yes
diff --git a/graphics/fv/Makefile b/graphics/fv/Makefile
index 9d94102e5ac7..36e485db64ab 100644
--- a/graphics/fv/Makefile
+++ b/graphics/fv/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fv
PORTVERSION= 1.01
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.eaflux.com/fv/sources/
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
@@ -14,7 +15,7 @@ DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= ip@doom.homeunix.org
COMMENT= A viewer of hdr/pfm images
-LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut \
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut \
png.5:${PORTSDIR}/graphics/png
USE_ZIP= yes
diff --git a/graphics/gauche-gl/Makefile b/graphics/gauche-gl/Makefile
index 7769a64caa63..a8c3aca51ba0 100644
--- a/graphics/gauche-gl/Makefile
+++ b/graphics/gauche-gl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gl
PORTVERSION= 0.4.1
+PORTREVISION= 1
CATEGORIES= graphics scheme
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gauche
@@ -18,7 +19,7 @@ MAINTAINER= erik@smluc.org
COMMENT= OpenGL binding for Gauche
BUILD_DEPENDS= gosh:${PORTSDIR}/lang/gauche
-LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_GL= yes
diff --git a/graphics/geomview/Makefile b/graphics/geomview/Makefile
index b899c3f537c4..ba67c5c79053 100644
--- a/graphics/geomview/Makefile
+++ b/graphics/geomview/Makefile
@@ -7,7 +7,7 @@
PORTNAME= geomview
PORTVERSION= 1.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= geomview
@@ -15,9 +15,10 @@ MASTER_SITE_SUBDIR= geomview
MAINTAINER= bms@FreeBSD.org
COMMENT= An interactive viewer for 3- and 4-D geometric objects
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
USE_MOTIF= yes
USE_X_PREFIX= yes
-USE_MESA= yes
USE_AUTOTOOLS= autoconf:213
diff --git a/graphics/giram/Makefile b/graphics/giram/Makefile
index 4542d30cb1a1..2210d70d3bfb 100644
--- a/graphics/giram/Makefile
+++ b/graphics/giram/Makefile
@@ -7,7 +7,7 @@
PORTNAME= giram
PORTVERSION= 0.3.5
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= http://www.giram.org/downloads/
diff --git a/graphics/gle/Makefile b/graphics/gle/Makefile
index c1c270382319..641756935e14 100644
--- a/graphics/gle/Makefile
+++ b/graphics/gle/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gle
PORTVERSION= 3.0.3
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://linas.org/gle/pub/ \
@@ -17,8 +18,9 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@dclg.ca
COMMENT= A GL Tubing and Extrusion Library
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
USE_X_PREFIX= yes
-USE_MESA= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_AUTOTOOLS= libtool:13:inc
diff --git a/graphics/gltk/Makefile b/graphics/gltk/Makefile
index 998863f6b615..1779de261b66 100644
--- a/graphics/gltk/Makefile
+++ b/graphics/gltk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gltk
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.sgi.com/opengl/contrib/ \
ftp://ftp.u-aizu.ac.jp/pub/os/sgi/misc/ftp.sgi.com/pub/opengl/contrib/
@@ -16,8 +17,9 @@ EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
COMMENT= An OpenGL/Tk interface
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
USE_IMAKE= yes
-USE_MESA= yes
do-install:
${INSTALL_DATA} ${WRKSRC}/libtk.a ${PREFIX}/lib/libgltk.a
diff --git a/graphics/gltt/Makefile b/graphics/gltt/Makefile
index dc7ce9f1e857..dfdae5d19615 100644
--- a/graphics/gltt/Makefile
+++ b/graphics/gltt/Makefile
@@ -7,15 +7,16 @@
PORTNAME= gltt
PORTVERSION= 2.5.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://gltt.sourceforge.net/download/
MAINTAINER= ip@doom.homeunix.org
COMMENT= TrueType fonts rendering using OpenGL
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
USE_X_PREFIX= yes
-USE_MESA= yes
USE_FREETYPE= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:13:inc
diff --git a/graphics/kdegraphics3/Makefile b/graphics/kdegraphics3/Makefile
index 4b49bf3ae684..40fd6748e580 100644
--- a/graphics/kdegraphics3/Makefile
+++ b/graphics/kdegraphics3/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdegraphics
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/graphics/kdegraphics4/Makefile b/graphics/kdegraphics4/Makefile
index 4b49bf3ae684..40fd6748e580 100644
--- a/graphics/kdegraphics4/Makefile
+++ b/graphics/kdegraphics4/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdegraphics
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/graphics/kludge3d/Makefile b/graphics/kludge3d/Makefile
index 151b803e4863..2152e0164544 100644
--- a/graphics/kludge3d/Makefile
+++ b/graphics/kludge3d/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kludge3d
PORTVERSION= 20040822
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/landscape/Makefile b/graphics/landscape/Makefile
index 8d3129ac2fd0..9f449a4d5490 100644
--- a/graphics/landscape/Makefile
+++ b/graphics/landscape/Makefile
@@ -7,7 +7,7 @@
PORTNAME= landscape
PORTVERSION= 0.7
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics kde
MASTER_SITES= http://www.witchspace.com/files/
@@ -15,9 +15,9 @@ MAINTAINER= jon@witchspace.com
COMMENT= A program for generating and rendering fractal landscapes
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
PLIST_FILES= bin/landscape
-USE_MESA= yes
USE_KDELIBS_VER= 3
QTDIR?= ${X11BASE}
MAKE_ENV= QTDIR="${QTDIR}"
diff --git a/graphics/lib3ds/Makefile b/graphics/lib3ds/Makefile
index 0c5b18c8c39f..5f9a59377239 100644
--- a/graphics/lib3ds/Makefile
+++ b/graphics/lib3ds/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lib3ds
PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,7 +15,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A library for handling 3DS (3D Studio) files
-USE_MESA= yes
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
diff --git a/graphics/libaux/Makefile b/graphics/libaux/Makefile
index 224d2f341965..1ee28cd13131 100644
--- a/graphics/libaux/Makefile
+++ b/graphics/libaux/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libaux
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.freebsdbrasil.com.br/~jmelo/
DISTFILES= libaux${EXTRACT_SUFX} libtk${EXTRACT_SUFX}
@@ -14,10 +15,11 @@ DISTFILES= libaux${EXTRACT_SUFX} libtk${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= A Nano Window Toolkit and Auxiliary Library for OpenGL
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_IMAKE= yes
-USE_MESA= yes
do-install:
${INSTALL_DATA} ${WRKSRC}/libaux.a ${PREFIX}/lib
diff --git a/graphics/libglut/Makefile b/graphics/libglut/Makefile
index 590e5919bf17..65378ba801c2 100644
--- a/graphics/libglut/Makefile
+++ b/graphics/libglut/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= libglut
-PORTVERSION= 6.0.1
+PORTVERSION= 6.4.1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mesa3d
-DISTNAME= MesaDemos-${PORTVERSION}
+DISTNAME= MesaGLUT-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A graphics library similar to SGI's OpenGL
diff --git a/graphics/libglut/distinfo b/graphics/libglut/distinfo
index 07b1489d39fc..8a4242546af8 100644
--- a/graphics/libglut/distinfo
+++ b/graphics/libglut/distinfo
@@ -1,3 +1,3 @@
-MD5 (MesaDemos-6.0.1.tar.bz2) = dd6aadfd9ca8e1cfa90c6ee492bc6f43
-SHA256 (MesaDemos-6.0.1.tar.bz2) = bb8bc9c8c7b91a79635ebdeb4ff620182fde6ae0fc0d9c536125d9042248097c
-SIZE (MesaDemos-6.0.1.tar.bz2) = 915558
+MD5 (MesaGLUT-6.4.1.tar.bz2) = bd003bb4f981a4f91dee4c38644d4f3f
+SHA256 (MesaGLUT-6.4.1.tar.bz2) = 47a8c3748fb7ca9a5aa2530b115651522185499b39e70ec8ca7463ea222fb6ae
+SIZE (MesaGLUT-6.4.1.tar.bz2) = 270793
diff --git a/graphics/libglut/files/Makefile b/graphics/libglut/files/Makefile
index 0980aaecb3a0..8f3955f181bf 100644
--- a/graphics/libglut/files/Makefile
+++ b/graphics/libglut/files/Makefile
@@ -3,7 +3,7 @@
# $FreeBSD$
LIB= glut
-SHLIB_MAJOR= 3
+SHLIB_MAJOR= 4
CFLAGS+= -I../../../include -I${X11BASE}/include
LDFLAGS+= -L${X11BASE}/lib -lGLU -lX11 -lXext -lGL -lXmu -lXi
LIBDIR= ${PREFIX}/lib
diff --git a/graphics/libglut/pkg-plist b/graphics/libglut/pkg-plist
index a91d541ac8a4..24d543fed14f 100644
--- a/graphics/libglut/pkg-plist
+++ b/graphics/libglut/pkg-plist
@@ -1,4 +1,4 @@
include/GL/glut.h
lib/libglut.a
lib/libglut.so
-lib/libglut.so.3
+lib/libglut.so.4
diff --git a/graphics/libv3d/Makefile b/graphics/libv3d/Makefile
index e90197d98f15..04d28936e54d 100644
--- a/graphics/libv3d/Makefile
+++ b/graphics/libv3d/Makefile
@@ -8,7 +8,7 @@
PORTNAME= libv3d
PORTVERSION= 0.1.14
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ftp://wolfpack.twu.net/users/wolfpack/
EXTRACT_SUFX= .tgz
@@ -16,8 +16,9 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= V3D IO Library
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
USE_REINPLACE= yes
-USE_MESA= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= UNIX --prefix=${PREFIX}
USE_GMAKE= yes
diff --git a/graphics/libwpcg/Makefile b/graphics/libwpcg/Makefile
index b4e0ebf2e97d..8a388d7412ba 100644
--- a/graphics/libwpcg/Makefile
+++ b/graphics/libwpcg/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libwpcg
PORTVERSION= 0.9.3
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.paassen.tmfweb.nl/
DISTNAME= libWPCG-${PORTVERSION}
@@ -15,8 +16,9 @@ DISTNAME= libWPCG-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A basic 2D/3D computer graphics library which uses OpenGL
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
USE_GCC= 3.4
-USE_MESA= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
diff --git a/graphics/lphoto/Makefile b/graphics/lphoto/Makefile
index 41a83c391dd6..e93508465188 100644
--- a/graphics/lphoto/Makefile
+++ b/graphics/lphoto/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lphoto
PORTVERSION= 2.0.42
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://software.linspire.com/emptypool/lindowsos/pool/main/l/lphoto/
DISTNAME= ${PORTNAME}_${PORTVERSION}-0.0.0.45.lindows0.1
diff --git a/graphics/morpheus/Makefile b/graphics/morpheus/Makefile
index a1bfa3292b10..5dc107f5a96b 100644
--- a/graphics/morpheus/Makefile
+++ b/graphics/morpheus/Makefile
@@ -7,7 +7,7 @@
PORTNAME= morpheus
PORTVERSION= 0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics gnome
MASTER_SITES= http://www.winnicki.net/morpheus/meat/
@@ -15,10 +15,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A mesh (3D model) viewer for GNOME desktop
LIB_DEPENDS= morph.0:${PORTSDIR}/graphics/libmorph \
- gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
+ gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea \
+ glut.4:${PORTSDIR}/graphics/libglut
USE_X_PREFIX= yes
-USE_MESA= yes
USE_GNOME= gnomehack gnomelibs gnomeprefix
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/graphics/ocaml-images/Makefile b/graphics/ocaml-images/Makefile
index d2edad7a7f8d..aad2f2525cfb 100644
--- a/graphics/ocaml-images/Makefile
+++ b/graphics/ocaml-images/Makefile
@@ -8,6 +8,7 @@
PORTNAME= images
PORTVERSION= 2.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.inria.fr/INRIA/caml-light/bazar-ocaml/
diff --git a/graphics/ocaml-lablgl/Makefile b/graphics/ocaml-lablgl/Makefile
index b24e12a3e662..c6f1d1cde3a7 100644
--- a/graphics/ocaml-lablgl/Makefile
+++ b/graphics/ocaml-lablgl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lablgl
PORTVERSION= 1.00
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/ \
ftp://ftp.inria.fr/lang/caml-light/bazar-ocaml/
@@ -16,7 +17,7 @@ MAINTAINER= rk@ronald.org
COMMENT= OpenGL interface for Objective Caml
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
-LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
RUN_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
USE_GL= yes
diff --git a/graphics/p5-OpenGL/Makefile b/graphics/p5-OpenGL/Makefile
index 342b74940eee..710309b40f12 100644
--- a/graphics/p5-OpenGL/Makefile
+++ b/graphics/p5-OpenGL/Makefile
@@ -8,6 +8,7 @@
PORTNAME= OpenGL
PORTVERSION= 0.54
+PORTREVISION= 1
CATEGORIES= graphics perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../by-authors/id/I/IL/ILYAZ/modules
@@ -16,8 +17,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module to display 3D data using OpenGL, GLU, GLUT, and GLX
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
PERL_CONFIGURE= yes
-USE_MESA= yes
post-patch:
@${PERL} -pi -e "s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g" ${WRKSRC}/Makefile.PL
diff --git a/graphics/py-cgkit/Makefile b/graphics/py-cgkit/Makefile
index b4ff3acf639b..70e873cb1683 100644
--- a/graphics/py-cgkit/Makefile
+++ b/graphics/py-cgkit/Makefile
@@ -8,6 +8,7 @@
PORTNAME= cgkit
PORTVERSION= 2.0.0a5
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/py-opengl/Makefile b/graphics/py-opengl/Makefile
index bf94c8cab3a3..bd0c2b8dda53 100644
--- a/graphics/py-opengl/Makefile
+++ b/graphics/py-opengl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= opengl
PORTVERSION= 2.0.1.07
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= py${PORTNAME}
@@ -24,10 +24,10 @@ BUILD_DEPENDS= ${PYNUMERIC} \
RUN_DEPENDS= ${PYNUMERIC} \
${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter \
${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
USE_REINPLACE= yes
USE_GL= yes
-USE_MESA= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/graphics/pyro/Makefile b/graphics/pyro/Makefile
index b73424e0f1a3..04553e2c37ee 100644
--- a/graphics/pyro/Makefile
+++ b/graphics/pyro/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pyro
PORTVERSION= 1.5
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://nostatic.org/pyro/
EXTRACT_SUFX= .tgz
@@ -15,7 +16,7 @@ MAINTAINER= ip@doom.homeunix.org
COMMENT= A simple OpenGL-based firework simulator
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- glut.3:${PORTSDIR}/graphics/libglut
+ glut.4:${PORTSDIR}/graphics/libglut
USE_REINPLACE= yes
USE_GL= yes
diff --git a/graphics/qslim/Makefile b/graphics/qslim/Makefile
index 4e6c5265910e..363a64ac7da4 100644
--- a/graphics/qslim/Makefile
+++ b/graphics/qslim/Makefile
@@ -8,7 +8,7 @@
PORTNAME= qslim
PORTVERSION= 2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://graphics.cs.uiuc.edu/~garland/dist/
@@ -17,13 +17,13 @@ COMMENT= SlimKit Surface Modeling Tools
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
- forms.1:${PORTSDIR}/x11-toolkits/xforms
+ forms.1:${PORTSDIR}/x11-toolkits/xforms \
+ glut.4:${PORTSDIR}/graphics/libglut
CONFIGURE_WRKSRC= ${WRKSRC}/mixkit/build
BUILD_WRKSRC= ${WRKSRC}/mixkit/src
USE_GETOPT_LONG= yes
-USE_MESA= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/graphics/quat-gui/Makefile b/graphics/quat-gui/Makefile
index 4d9cea973903..bff944daf470 100644
--- a/graphics/quat-gui/Makefile
+++ b/graphics/quat-gui/Makefile
@@ -7,6 +7,7 @@
PORTNAME= quat
PORTVERSION= 1.20
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.physcip.uni-stuttgart.de/phy11733/download/
PKGNAMESUFFIX= -gui
@@ -15,10 +16,10 @@ DISTNAME= quat-${PORTVERSION:S/.p/pre/}
MAINTAINER= dyeske@yahoo.com
COMMENT= A Three-dimensional fractal creator (X11 GUI)
-LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
+ glut.4:${PORTSDIR}/graphics/libglut
USE_X_PREFIX= yes
-USE_MESA= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -L${X11BASE}/lib" \
diff --git a/graphics/renderpark/Makefile b/graphics/renderpark/Makefile
index 9f45925043cf..ddda3f90fe22 100644
--- a/graphics/renderpark/Makefile
+++ b/graphics/renderpark/Makefile
@@ -7,7 +7,7 @@
PORTNAME= renderpark
PORTVERSION= 3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.cs.kuleuven.ac.be/pub/graphics/software/RenderPark/
DISTNAME= RenderPark
@@ -19,8 +19,10 @@ DIST_SUBDIR= ${DISTNAME}
MAINTAINER= ip@doom.homeunix.org
COMMENT= System for physically based photo-realistic image synthesis
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
.ifdef (WITH_XRML)
-LIB_DEPENDS= xrml.0:${PORTSDIR}/graphics/xrml
+LIB_DEPENDS+= xrml.0:${PORTSDIR}/graphics/xrml
.endif
WRKSRC= ${WRKDIR}/${DISTNAME}
@@ -28,7 +30,6 @@ WRKSRC2= ${WRKDIR}/Scenes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_MESA= yes
USE_MOTIF= yes
USE_REINPLACE= yes
diff --git a/graphics/ruby-opengl/Makefile b/graphics/ruby-opengl/Makefile
index a58725e93615..f086955810fc 100644
--- a/graphics/ruby-opengl/Makefile
+++ b/graphics/ruby-opengl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= opengl
PORTVERSION= 0.32b
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics ruby
MASTER_SITES= http://www2.giganet.net/~yoshi/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -18,11 +18,11 @@ DIST_SUBDIR= ruby
MAINTAINER= ports@FreeBSD.org
COMMENT= OpenGL/GLU/GLUT interface modules for Ruby
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-USE_MESA= yes
-
WRKSRC= ${WRKDIR}/${PORTNAME}
CONFIGURE_ARGS= --with-ruby-dir="${LOCALBASE}" --with-x11-dir="${X11BASE}"
INSTALL_TARGET= site-install
diff --git a/graphics/threeDS/Makefile b/graphics/threeDS/Makefile
index fe3fbdc0eefd..71d3800fdb16 100644
--- a/graphics/threeDS/Makefile
+++ b/graphics/threeDS/Makefile
@@ -7,6 +7,7 @@
PORTNAME= threeDS
PORTVERSION= 0.3.1
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= http://www.demonseed.net/~jp/code/threeDS/
diff --git a/graphics/tulip/Makefile b/graphics/tulip/Makefile
index 5b45b7ede4d5..8f899b43bb2f 100644
--- a/graphics/tulip/Makefile
+++ b/graphics/tulip/Makefile
@@ -8,7 +8,7 @@
PORTNAME= tulip
PORTVERSION= 1.2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://dept-info.labri.fr/~auber/projects/tulip/download/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}-${PORTVERSION}
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A system dedicated to the visualization of huge graphs
-LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
USE_BZIP2= yes
USE_QT_VER= 3
diff --git a/graphics/view3ds/Makefile b/graphics/view3ds/Makefile
index 4467d697cce7..20d79196eff2 100644
--- a/graphics/view3ds/Makefile
+++ b/graphics/view3ds/Makefile
@@ -7,7 +7,7 @@
PORTNAME= view3ds
PORTVERSION= 1.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
@@ -19,14 +19,14 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= ports@FreeBSD.org
COMMENT= A simple realtime 3DS file previewer based on the Lib3ds Library
-LIB_DEPENDS= 3ds.1:${PORTSDIR}/graphics/lib3ds
+LIB_DEPENDS= 3ds.1:${PORTSDIR}/graphics/lib3ds \
+ glut.4:${PORTSDIR}/graphics/libglut
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_FILES= bin/view3ds
USE_X_PREFIX= yes
USE_QT_VER= 3
-USE_MESA= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_AUTOTOOLS= libtool:15
diff --git a/graphics/visionegg/Makefile b/graphics/visionegg/Makefile
index f3c65c20f0c4..149daf12757f 100644
--- a/graphics/visionegg/Makefile
+++ b/graphics/visionegg/Makefile
@@ -8,7 +8,7 @@
PORTNAME= visionegg
PORTVERSION= 0.9.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -26,8 +26,9 @@ RUN_DEPENDS= \
${PYTHON_SITELIBDIR}/PIL/Image.py:${PORTSDIR}/graphics/py-imaging \
${PYTHON_SITELIBDIR}/OpenGL/__init__.py:${PORTSDIR}/graphics/py-opengl \
${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game
+LIB_DEPENDS= \
+ glut.4:${PORTSDIR}/graphics/libglut
-USE_MESA= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_BUILDARGS= -L${X11BASE}/lib
diff --git a/graphics/vvv/Makefile b/graphics/vvv/Makefile
index 5de7aa990540..b506cf501c0e 100644
--- a/graphics/vvv/Makefile
+++ b/graphics/vvv/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vvv
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.inf.ufes.br/~thomas/graphics/vvv/ \
${MASTER_SITE_LOCAL}
@@ -18,7 +19,7 @@ MAINTAINER= ip@doom.homeunix.org
COMMENT= A tutorial tool for understanding viewing and projection in OpenGL
BUILD_DEPENDS= ${X11BASE}/lib/libglui.a:${PORTSDIR}/devel/glui
-LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
USE_REINPLACE= yes
USE_GMAKE= yes
diff --git a/graphics/white_dune/Makefile b/graphics/white_dune/Makefile
index f99b66d24803..fd75547992b5 100644
--- a/graphics/white_dune/Makefile
+++ b/graphics/white_dune/Makefile
@@ -8,6 +8,7 @@
PORTNAME= white_dune
PORTVERSION= 0.28.11
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= http://www.csv.ica.uni-stuttgart.de/vrml/dune/
@@ -17,7 +18,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Graphical VRML97 Editor and animation tool
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- glut.3:${PORTSDIR}/graphics/libglut \
+ glut.4:${PORTSDIR}/graphics/libglut \
png.5:${PORTSDIR}/graphics/png
USE_MOTIF= yes
diff --git a/graphics/xmms-dancingparticles/Makefile b/graphics/xmms-dancingparticles/Makefile
index 862a5136567c..1e265f6f98bf 100644
--- a/graphics/xmms-dancingparticles/Makefile
+++ b/graphics/xmms-dancingparticles/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dancingparticles
PORTVERSION= 0.6
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://tardyp.free.fr/dancingparticles/
PKGNAMEPREFIX= xmms-
@@ -17,7 +18,7 @@ MAINTAINER= alejandro@varnet.biz
COMMENT= Makes particles dance with very pretty neon colors
LIB_DEPENDS= t1.5:${PORTSDIR}/devel/t1lib \
- glut.3:${PORTSDIR}/graphics/libglut \
+ glut.4:${PORTSDIR}/graphics/libglut \
xmms.4:${PORTSDIR}/multimedia/xmms
USE_X_PREFIX= yes
diff --git a/graphics/xmms-fishmatic/Makefile b/graphics/xmms-fishmatic/Makefile
index 8b16fbc04578..a6b6b802a0ba 100644
--- a/graphics/xmms-fishmatic/Makefile
+++ b/graphics/xmms-fishmatic/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xmms-fishmatic
PORTVERSION= 0.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://stukach.com/hosted/
DISTNAME= fishmatic
@@ -17,12 +17,12 @@ COMMENT= An XMMS non-static OpenGL stereogram visualization plugin
BUILD_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
PLIST_FILES= lib/xmms/Visualization/libfishmatic.so
USE_X_PREFIX= yes
USE_GNOME= gtk12
USE_GMAKE= yes
-USE_MESA= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
diff --git a/graphics/xmms-paranormal/Makefile b/graphics/xmms-paranormal/Makefile
index 01604c19f1e0..a7192424b1a7 100644
--- a/graphics/xmms-paranormal/Makefile
+++ b/graphics/xmms-paranormal/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xmms-paranormal
PORTVERSION= 0.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= paranormal
@@ -16,7 +16,8 @@ DISTNAME= paranormal-${PORTVERSION:S/.p/pre/}
MAINTAINER= dyeske@yahoo.com
COMMENT= An adaptation of the "OpenGL Spectrum Analyzer" from XMMS
-LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
+ glut.4:${PORTSDIR}/graphics/libglut
BUILD_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
@@ -27,7 +28,6 @@ USE_SDL= sdl
INSTALLS_SHLIB= yes
USE_GNOME= gtk12
USE_GMAKE= yes
-USE_MESA= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes