aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-01-12 13:32:14 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-01-12 13:32:14 +0000
commitb8490f4b8c1510571b36ffb921e107fb8ed9f330 (patch)
tree129f30dbce18db2a8be7d0d65a00afa9cdef7a22 /graphics
parent1924dd20321faa563ed1d5fde0f13734a0afbbe9 (diff)
downloadports-b8490f4b8c1510571b36ffb921e107fb8ed9f330.tar.gz
ports-b8490f4b8c1510571b36ffb921e107fb8ed9f330.zip
- Author of stl2pov has replaced code with python module, py-stl
PR: ports/163698 Submitted by: Roland Smith <rsmith@xs4all.nl> (maintainer) Approved by: maintainer, gabor (mentor)
Notes
Notes: svn path=/head/; revision=289024
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile2
-rw-r--r--graphics/py-stl/Makefile41
-rw-r--r--graphics/py-stl/distinfo2
-rw-r--r--graphics/py-stl/pkg-descr11
-rw-r--r--graphics/py-stl/pkg-plist10
-rw-r--r--graphics/stl2pov/Makefile33
-rw-r--r--graphics/stl2pov/distinfo2
-rw-r--r--graphics/stl2pov/pkg-descr5
8 files changed, 65 insertions, 41 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 45a047f9d407..fe6108a5de8a 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -816,6 +816,7 @@
SUBDIR += py-seqdiag
SUBDIR += py-sorl-thumbnail
SUBDIR += py-soya3d
+ SUBDIR += py-stl
SUBDIR += py-visual
SUBDIR += py-webcolors
SUBDIR += pygts
@@ -920,7 +921,6 @@
SUBDIR += squish
SUBDIR += sswf
SUBDIR += stamp
- SUBDIR += stl2pov
SUBDIR += structuresynth
SUBDIR += svg2pdf
SUBDIR += svg2png
diff --git a/graphics/py-stl/Makefile b/graphics/py-stl/Makefile
new file mode 100644
index 000000000000..913e5ff518b3
--- /dev/null
+++ b/graphics/py-stl/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: py-stl
+# Date created: 28 Dec 2011
+# Whom: rsmith@xs4all.nl
+#
+# $FreeBSD$
+
+PORTNAME= stl
+PORTVERSION= 3.0
+CATEGORIES= graphics python
+MASTER_SITES= http://rsmith.home.xs4all.nl/software/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py-${PORTNAME}-${GITVER}
+
+MAINTAINER= rsmith@xs4all.nl
+COMMENT= Converts STL models to POV-Ray meshes or PostScript/PDF images
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}reportlab2>2:${PORTSDIR}/print/py-reportlab2
+
+GITVER= 31a5b12
+
+USE_ZIP= YES
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= YES
+
+CONFLICTS= stl2pov-[0-9]*
+
+MAN1= stl2ps.1 stlinfo.1 stl2pdf.1
+
+NO_BUILD= YES
+
+post-install:
+ @${INSTALL_MAN} ${WRKSRC}/stl2ps.1 ${MANPREFIX}/man/man1
+ @${INSTALL_MAN} ${WRKSRC}/stlinfo.1 ${MANPREFIX}/man/man1
+ @${INSTALL_MAN} ${WRKSRC}/stl2pdf.1 ${MANPREFIX}/man/man1
+ @${MV} ${PREFIX}/bin/stl2ps.py ${PREFIX}/bin/stl2ps
+ @${MV} ${PREFIX}/bin/stl2pov.py ${PREFIX}/bin/stl2pov
+ @${MV} ${PREFIX}/bin/stlinfo.py ${PREFIX}/bin/stlinfo
+ @${MV} ${PREFIX}/bin/stl2pdf.py ${PREFIX}/bin/stl2pdf
+ @${MV} ${PYTHON_SITELIBDIR}/py_stl-${GITVER}-py${PYTHON_VER}.egg-info ${PYTHON_SITELIBDIR}/${PYDISTUTILS_EGGINFO}
+
+.include <bsd.port.mk>
diff --git a/graphics/py-stl/distinfo b/graphics/py-stl/distinfo
new file mode 100644
index 000000000000..7d36a5e5ed74
--- /dev/null
+++ b/graphics/py-stl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (py-stl-31a5b12.zip) = 117bd90aeea8aea6febe8b154b5ee9590cf0cec9a129023db31c122d7f595269
+SIZE (py-stl-31a5b12.zip) = 93478
diff --git a/graphics/py-stl/pkg-descr b/graphics/py-stl/pkg-descr
new file mode 100644
index 000000000000..2dea5fd8243f
--- /dev/null
+++ b/graphics/py-stl/pkg-descr
@@ -0,0 +1,11 @@
+The python modules stl.py and xform.py are for reading, creating and
+transforming STL (STereoLithography) files. These modules are used by the
+following scripts;
+
+stl2pov: Converts the STL model to a mesh usable with the POV-ray raytracer.
+stl2ps: Creates a view of the STL model in scalable PostScript.
+stl2pdf: Creates a view of the STL model as a PDF. Requires print/py-reportlab2
+sltinfo: Either displays some information about a STL file or prints it in
+ text format.
+
+WWW: http://rsmith.home.xs4all.nl/software/index.html
diff --git a/graphics/py-stl/pkg-plist b/graphics/py-stl/pkg-plist
new file mode 100644
index 000000000000..d13e79eee148
--- /dev/null
+++ b/graphics/py-stl/pkg-plist
@@ -0,0 +1,10 @@
+%%PYTHON_SITELIBDIR%%/stl.py
+%%PYTHON_SITELIBDIR%%/stl.pyc
+%%PYTHON_SITELIBDIR%%/stl.pyo
+%%PYTHON_SITELIBDIR%%/xform.py
+%%PYTHON_SITELIBDIR%%/xform.pyc
+%%PYTHON_SITELIBDIR%%/xform.pyo
+bin/stl2pdf
+bin/stl2pov
+bin/stl2ps
+bin/stlinfo
diff --git a/graphics/stl2pov/Makefile b/graphics/stl2pov/Makefile
deleted file mode 100644
index bc834f2ffaca..000000000000
--- a/graphics/stl2pov/Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
-# New ports collection makefile for: stl2pov
-# Date created: 9 May 2005
-# Whom: rsmith@xs4all.nl
-#
-# $FreeBSD$
-
-PORTNAME= stl2pov
-PORTVERSION= 2.5.0
-CATEGORIES= graphics
-MASTER_SITES= http://rsmith.home.xs4all.nl/software/
-
-MAINTAINER= rsmith@xs4all.nl
-COMMENT= Converts STL models to POV-Ray meshes
-
-PLIST_FILES= bin/stl2pov
-
-MAKE_JOBS_SAFE= yes
-
-MAN1= stl2pov.1
-MANCOMPRESSED= yes
-
-.if defined(NOPORTDOCS)
-MAKE_ENV= NOPORTDOCS=yes
-.else
-PORTDOCS= LICENSE README INSTALL
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|-pipe||; s|-fmerge-constants||; s|--fast-math||' \
- ${WRKSRC}/Makefile
-
-.include <bsd.port.mk>
diff --git a/graphics/stl2pov/distinfo b/graphics/stl2pov/distinfo
deleted file mode 100644
index 23dc41c39e97..000000000000
--- a/graphics/stl2pov/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (stl2pov-2.5.0.tar.gz) = 6a22915b7577db1166b03805ceb1aa01d2aa4afff67267fd4ef0246b701e3ab2
-SIZE (stl2pov-2.5.0.tar.gz) = 14341
diff --git a/graphics/stl2pov/pkg-descr b/graphics/stl2pov/pkg-descr
deleted file mode 100644
index 569659431a3e..000000000000
--- a/graphics/stl2pov/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-The stl2pov program creates POV-Ray mesh object from the STL files that can
-be exported from most CAD programs. This makes it easy to incorporate CAD
-models in POV-Ray scenes.
-
-WWW: http://www.xs4all.nl/~rsmith/software/