aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-22 20:06:14 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-22 20:06:14 +0000
commitffd97a0193e0238aa21bc32b570fd052292e0fe5 (patch)
treeb368198f913179c06dafd19ac72527fcf9836f6d /graphics
parentccbdf54cacb9796580726f8d5278fe3fa53d5e53 (diff)
downloadports-ffd97a0193e0238aa21bc32b570fd052292e0fe5.tar.gz
ports-ffd97a0193e0238aa21bc32b570fd052292e0fe5.zip
- convert USE_CMAKE to USES
- while here clean up some ports from CMAKE_VERBOSE, which is intended for users Approved by: portmgr (miwi)
Notes
Notes: svn path=/head/; revision=314960
Diffstat (limited to 'graphics')
-rw-r--r--graphics/apvlv/Makefile2
-rw-r--r--graphics/aqsis/Makefile4
-rw-r--r--graphics/autopano-sift-c/Makefile2
-rw-r--r--graphics/blender/Makefile3
-rw-r--r--graphics/converseen/Makefile2
-rw-r--r--graphics/cuneiform/Makefile3
-rw-r--r--graphics/darktable/Makefile3
-rw-r--r--graphics/digikam-kde4/Makefile.common2
-rw-r--r--graphics/eos-movrec/Makefile2
-rw-r--r--graphics/glosm/Makefile2
-rw-r--r--graphics/graphite2/Makefile2
-rw-r--r--graphics/hugin-devel/Makefile3
-rw-r--r--graphics/hugin/Makefile3
-rw-r--r--graphics/k3d/Makefile3
-rw-r--r--graphics/kcoloredit/Makefile2
-rw-r--r--graphics/kgraphviewer/Makefile2
-rw-r--r--graphics/kiconedit/Makefile2
-rw-r--r--graphics/kphotoalbum-kde4/Makefile2
-rw-r--r--graphics/kpovmodeler/Makefile2
-rw-r--r--graphics/kuickshow-kde4/Makefile2
-rw-r--r--graphics/libprojectm/Makefile2
-rw-r--r--graphics/lprof-devel/Makefile2
-rw-r--r--graphics/luminance/Makefile2
-rw-r--r--graphics/luxrender/Makefile4
-rw-r--r--graphics/nomacs/Makefile2
-rw-r--r--graphics/nvidia-texture-tools/Makefile2
-rw-r--r--graphics/ogre3d/Makefile2
-rw-r--r--graphics/opencolorio/Makefile4
-rw-r--r--graphics/opencv/Makefile2
-rw-r--r--graphics/opengtl/Makefile2
-rw-r--r--graphics/openimageio/Makefile4
-rw-r--r--graphics/openjpeg/Makefile2
-rw-r--r--graphics/openshadinglanguage/Makefile5
-rw-r--r--graphics/osg-devel/Makefile2
-rw-r--r--graphics/osg/Makefile2
-rw-r--r--graphics/picviz/Makefile3
-rw-r--r--graphics/png/Makefile2
-rw-r--r--graphics/podofo/Makefile2
-rw-r--r--graphics/prison/Makefile2
-rw-r--r--graphics/projectm-libvisual/Makefile2
-rw-r--r--graphics/qgis/Makefile3
-rw-r--r--graphics/qtgtl/Makefile2
-rw-r--r--graphics/rawtherapee/Makefile2
-rw-r--r--graphics/scantailor/Makefile2
-rw-r--r--graphics/shiva-collections/Makefile2
-rw-r--r--graphics/showimage/Makefile2
-rw-r--r--graphics/skanlite/Makefile2
-rw-r--r--graphics/tulip/Makefile3
-rw-r--r--graphics/vigra/Makefile2
-rw-r--r--graphics/yagf/Makefile2
-rw-r--r--graphics/zint/Makefile2
51 files changed, 51 insertions, 71 deletions
diff --git a/graphics/apvlv/Makefile b/graphics/apvlv/Makefile
index 3d56a1a26d8f..078a83cc3a64 100644
--- a/graphics/apvlv/Makefile
+++ b/graphics/apvlv/Makefile
@@ -19,7 +19,7 @@ LICENSE= GPLv2
LIB_DEPENDS= poppler-glib.8:${PORTSDIR}/graphics/poppler-glib
USE_GNOME= gtk20
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
CMAKE_ARGS+= -DSYSCONFDIR=${PREFIX}/etc \
-DMANDIR=${MANPREFIX}/man \
diff --git a/graphics/aqsis/Makefile b/graphics/aqsis/Makefile
index 6d77aeb18df6..6305b1c3ccd8 100644
--- a/graphics/aqsis/Makefile
+++ b/graphics/aqsis/Makefile
@@ -23,9 +23,7 @@ LIB_DEPENDS= IlmImf:${PORTSDIR}/graphics/OpenEXR \
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-USE_CMAKE= yes
-CMAKE_OUTSOURCE= yes
-CMAKE_VERBOSE= yes
+USES= cmake:outsource
USE_QT4= opengl qmake_build moc_build rcc_build uic_build
PLIST_SUB+= LIBVERS=${PORTVERSION:R}
diff --git a/graphics/autopano-sift-c/Makefile b/graphics/autopano-sift-c/Makefile
index 28b6ed36bb28..711e9dbdef93 100644
--- a/graphics/autopano-sift-c/Makefile
+++ b/graphics/autopano-sift-c/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
CONFLICTS= autopano-sift-[0-9]*
USE_GNOME= libxml2
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/autopano bin/autopano-c-complete.sh \
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index 750d9a0f4281..1642e230a2b4 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -17,13 +17,12 @@ LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
USE_XORG= x11 xext xmu
USE_GL= glew
-USE_CMAKE= yes
+USES= cmake:outsource
USE_PYTHON= 3.3
WANT_GNOME= yes
MAKE_JOBS_SAFE= yes
-CMAKE_OUTSOURCE= yes
CMAKE_ARGS+= -DWITH_PYTHON_INSTALL:BOOL=OFF \
-DWITH_PYTHON_INSTALL_NUMPY:BOOL=OFF
diff --git a/graphics/converseen/Makefile b/graphics/converseen/Makefile
index 41424aac84d0..014ce878ac22 100644
--- a/graphics/converseen/Makefile
+++ b/graphics/converseen/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
USE_BZIP2= yes
USE_AUTOTOOLS= libltdl
-USE_CMAKE= yes
+USES= cmake
USE_ICONV= yes
USE_GETTEXT= yes
USE_XORG= ice sm x11 xau xdmcp xext xrender xt
diff --git a/graphics/cuneiform/Makefile b/graphics/cuneiform/Makefile
index 25ff7910b3e8..ee561c718f9b 100644
--- a/graphics/cuneiform/Makefile
+++ b/graphics/cuneiform/Makefile
@@ -18,9 +18,8 @@ COMMENT= OCR system developed and open sourced by Cognitive technologies
ONLY_FOR_ARCHS= i386 amd64
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake:outsource
USE_LDCONFIG= yes
-CMAKE_OUTSOURCE= yes
CPPFLAGS+= -I${LOCALBASE}/include
CFLAGS+= -I${LOCALBASE}/include
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index d44a509f60f7..43ba1d36790c 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -23,8 +23,7 @@ ONLY_FOR_ARCHS_REASON= uses SSE extensions
MAKE_JOBS_SAFE= yes
-USE_CMAKE= yes
-CMAKE_OUTSOURCE= yes
+USES= cmake:outsource
USE_GNOME= librsvg2
USE_SQLITE= yes
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
diff --git a/graphics/digikam-kde4/Makefile.common b/graphics/digikam-kde4/Makefile.common
index bf7d6508d91f..d580dea6621d 100644
--- a/graphics/digikam-kde4/Makefile.common
+++ b/graphics/digikam-kde4/Makefile.common
@@ -15,7 +15,7 @@ DISTNAME= digikam-${DIGIKAM_VER}
LICENSE?= GPLv2
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_KDE4+= automoc4 kdehier kdeprefix kdelibs
USE_QT4+= qmake_build moc_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/graphics/eos-movrec/Makefile b/graphics/eos-movrec/Makefile
index 0cc0a936eedc..9818882b1fa5 100644
--- a/graphics/eos-movrec/Makefile
+++ b/graphics/eos-movrec/Makefile
@@ -20,7 +20,7 @@ LICENSE= GPLv2
LIB_DEPENDS= gphoto2:${PORTSDIR}/graphics/libgphoto2
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_QT4= qmake_build moc_build rcc_build uic_build gui
PLIST_FILES= bin/eos_movrec \
diff --git a/graphics/glosm/Makefile b/graphics/glosm/Makefile
index 2381b5cccb31..f9b442459f0f 100644
--- a/graphics/glosm/Makefile
+++ b/graphics/glosm/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
expat.6:${PORTSDIR}/textproc/expat2
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_GL= gl
USE_SDL= sdl
MAKE_JOBS_SAFE= yes
diff --git a/graphics/graphite2/Makefile b/graphics/graphite2/Makefile
index a4d679335539..41b98ef4ed5b 100644
--- a/graphics/graphite2/Makefile
+++ b/graphics/graphite2/Makefile
@@ -9,7 +9,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= office@FreeBSD.org
COMMENT= Rendering capabilities for complex non-Roman writing systems
-USE_CMAKE= yes
+USES= cmake
USE_ICONV= yes
USE_LDCONFIG= yes
LDFLAGS+= -L${LOCALBASE}/lib -liconv
diff --git a/graphics/hugin-devel/Makefile b/graphics/hugin-devel/Makefile
index a7b331d32476..1a8456882163 100644
--- a/graphics/hugin-devel/Makefile
+++ b/graphics/hugin-devel/Makefile
@@ -36,10 +36,9 @@ USE_BZIP2= yes
OPTIONS= PANOMATIC "Install graphics/panomatic" on \
AUTOPANOSIFTC "Install graphics/autopano-sift-c" on
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DwxWidgets_CONFIG_EXECUTABLE=${WX_CONFIG}
-CMAKE_VERBOSE= yes
USE_WX= 2.8+
WX_UNICODE= yes
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 42ea0c9e90cc..2325e9c58d76 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -31,10 +31,9 @@ USE_BZIP2= yes
OPTIONS= PANOMATIC "Install graphics/panomatic" on \
AUTOPANOSIFTC "Install graphics/autopano-sift-c" on
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DwxWidgets_CONFIG_EXECUTABLE=${WX_CONFIG}
-CMAKE_VERBOSE= yes
USE_WX= 2.8+
WX_UNICODE= yes
diff --git a/graphics/k3d/Makefile b/graphics/k3d/Makefile
index 27cb28848287..da9626faf21b 100644
--- a/graphics/k3d/Makefile
+++ b/graphics/k3d/Makefile
@@ -40,8 +40,7 @@ USE_DOS2UNIX= *.hpp
USE_GCC= 4.6+
USE_PYTHON= yes
USE_GETTEXT= yes
-USE_CMAKE= yes
-CMAKE_OUTSOURCE=yes
+USES= cmake:outsource
CMAKE_ARGS= -DK3D_INTL_INCLUDE_DIRS:STRING="-I${LOCALBASE}/include" \
-DK3D_INTL_LIBS:STRING="-L${LOCALBASE}/lib -lintl" \
-DK3D_BUILD_CARVE_MODULE:BOOL=OFF \
diff --git a/graphics/kcoloredit/Makefile b/graphics/kcoloredit/Makefile
index 080018aaa3fc..b43c0041244a 100644
--- a/graphics/kcoloredit/Makefile
+++ b/graphics/kcoloredit/Makefile
@@ -20,7 +20,7 @@ COMMENT= Palette files editor for KDE
USE_BZIP2= yes
USE_KDE4= kdelibs kdeprefix kdehier automoc4
USE_QT4= corelib qmake_build moc_build rcc_build uic_build
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
APP_VER= 2.0.0
diff --git a/graphics/kgraphviewer/Makefile b/graphics/kgraphviewer/Makefile
index c72756acc1e9..e6fce3f46026 100644
--- a/graphics/kgraphviewer/Makefile
+++ b/graphics/kgraphviewer/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= gvc:${PORTSDIR}/graphics/graphviz
USE_BZIP2= yes
USE_KDE4= kdelibs pimlibs kdeprefix kdehier automoc4
USE_QT4= corelib qmake_build moc_build rcc_build uic_build
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
APP_VER= 2.0.2
diff --git a/graphics/kiconedit/Makefile b/graphics/kiconedit/Makefile
index 60ee0dedf9a7..c08b61b5e4c7 100644
--- a/graphics/kiconedit/Makefile
+++ b/graphics/kiconedit/Makefile
@@ -19,7 +19,7 @@ COMMENT= A KDE icon editor
USE_BZIP2= yes
USE_KDE4= kdelibs kdeprefix kdehier automoc4
USE_QT4= corelib qmake_build moc_build rcc_build uic_build
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
EXTRA_VER= 4.4.0
diff --git a/graphics/kphotoalbum-kde4/Makefile b/graphics/kphotoalbum-kde4/Makefile
index 76d686b62e90..29d2dbae92d1 100644
--- a/graphics/kphotoalbum-kde4/Makefile
+++ b/graphics/kphotoalbum-kde4/Makefile
@@ -18,7 +18,7 @@ USE_KDE4= kdehier kdelibs kdeprefix libkdcraw libkipi automoc4
USE_QT4= corelib qt3support \
qmake_build moc_build rcc_build uic_build
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
LATEST_LINK= ${PORTNAME}-kde4
diff --git a/graphics/kpovmodeler/Makefile b/graphics/kpovmodeler/Makefile
index 446cfdf250ff..f1d95a01c056 100644
--- a/graphics/kpovmodeler/Makefile
+++ b/graphics/kpovmodeler/Makefile
@@ -18,7 +18,7 @@ USE_BZIP2= yes
USE_GL= glu
USE_KDE4= kdelibs kdeprefix kdehier automoc4
USE_QT4= corelib opengl qmake_build moc_build rcc_build uic_build
-USE_CMAKE= yes
+USES= cmake
USE_GETTEXT= yes
MAKE_JOBS_SAFE= yes
diff --git a/graphics/kuickshow-kde4/Makefile b/graphics/kuickshow-kde4/Makefile
index b9364849548b..d001c1cba572 100644
--- a/graphics/kuickshow-kde4/Makefile
+++ b/graphics/kuickshow-kde4/Makefile
@@ -21,7 +21,7 @@ USE_BZIP2= yes
USE_GNOME= imlib
USE_KDE4= kdelibs kdeprefix kdehier automoc4
USE_QT4= corelib opengl qmake_build moc_build rcc_build uic_build
-USE_CMAKE= yes
+USES= cmake
USE_GETTEXT= yes
MAKE_JOBS_SAFE= yes
diff --git a/graphics/libprojectm/Makefile b/graphics/libprojectm/Makefile
index e8732ec82cf1..0ee21c4225cb 100644
--- a/graphics/libprojectm/Makefile
+++ b/graphics/libprojectm/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= ftgl:${PORTSDIR}/graphics/ftgl \
GLEW:${PORTSDIR}/graphics/glew \
freetype:${PORTSDIR}/print/freetype2
-USE_CMAKE= yes
+USES= cmake
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
USE_LDCONFIG= yes
diff --git a/graphics/lprof-devel/Makefile b/graphics/lprof-devel/Makefile
index c874e7ee07e1..20d6b7ee1fb3 100644
--- a/graphics/lprof-devel/Makefile
+++ b/graphics/lprof-devel/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms \
USE_BZIP2= yes
USE_XORG= x11 xext sm ice xxf86vm
USE_QT4= corelib gui qt3support assistantclient linguist_build qmake_build moc_build uic_build rcc_build
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
CMAKE_ARGS= -DQTTRANS_LRELEASE_EXECUTABLE="${LOCALBASE}/bin/lrelease-qt4"
diff --git a/graphics/luminance/Makefile b/graphics/luminance/Makefile
index e8f4b3f139ec..91b282ecdb2b 100644
--- a/graphics/luminance/Makefile
+++ b/graphics/luminance/Makefile
@@ -26,7 +26,7 @@ LIB_DEPENDS= fftw3f:${PORTSDIR}/math/fftw3-float \
raw_r:${PORTSDIR}/graphics/libraw
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_QT4= gui sql webkit xml linguist_build moc_build qmake_build \
rcc_build uic_build imageformats_run
INSTALLS_ICONS= yes
diff --git a/graphics/luxrender/Makefile b/graphics/luxrender/Makefile
index 57d44cee6f7d..832d6165fec1 100644
--- a/graphics/luxrender/Makefile
+++ b/graphics/luxrender/Makefile
@@ -26,9 +26,7 @@ LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs \
HG_NODEID= 9206b3ba7011
USE_BZIP2= yes
-USES= bison
-USE_CMAKE= yes
-CMAKE_VERBOSE= yes
+USES= bison cmake
WRKSRC= ${WRKDIR}/lux-${HG_NODEID}
MAKE_JOBS_SAFE= yes
diff --git a/graphics/nomacs/Makefile b/graphics/nomacs/Makefile
index f54531eaaaf2..29c037460168 100644
--- a/graphics/nomacs/Makefile
+++ b/graphics/nomacs/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= exiv2:${PORTSDIR}/graphics/exiv2 \
sysinfo:${PORTSDIR}/devel/libsysinfo
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_QT4= gui network linguist_build moc_build \
qmake_build rcc_build uic_build
LDFLAGS+= -lsysinfo -lkvm
diff --git a/graphics/nvidia-texture-tools/Makefile b/graphics/nvidia-texture-tools/Makefile
index 7f75d962be48..656cf7a36159 100644
--- a/graphics/nvidia-texture-tools/Makefile
+++ b/graphics/nvidia-texture-tools/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
IlmImf:${PORTSDIR}/graphics/OpenEXR
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DNVTT_SHARED=TRUE
MAKE_JOBS_SAFE= yes
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
index 4a5bfc423940..b527f17f17b2 100644
--- a/graphics/ogre3d/Makefile
+++ b/graphics/ogre3d/Makefile
@@ -18,7 +18,7 @@ OPTIONS_DEFINE= BOOST
USE_LDCONFIG= YES
USE_BZIP2= YES
-USE_CMAKE= YES
+USES= cmake
USE_SDL= sdl
USE_XORG= xaw
MAKE_JOBS_SAFE= yes
diff --git a/graphics/opencolorio/Makefile b/graphics/opencolorio/Makefile
index 736b97070d76..9d81febb5519 100644
--- a/graphics/opencolorio/Makefile
+++ b/graphics/opencolorio/Makefile
@@ -22,9 +22,7 @@ USE_PYTHON= 2.6+
USE_LDCONFIG= yes
.endif
-USE_CMAKE= yes
-CMAKE_VERBOSE= yes
-CMAKE_OUTSOURCE= yes
+USES= cmake:outsource
CMAKE_ARGS?= -DOCIO_BUILD_APPS:BOOL=OFF \
-DOCIO_BUILD_JNIGLUE:BOOL=OFF \
-DOCIO_BUILD_NUKE:BOOL=OFF \
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index 3e3b06ec63af..3301843b071a 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -18,7 +18,7 @@ USE_GNOME= pkgconfig
WANT_GSTREAMER= yes
MAKE_JOBS_UNSAFE= yes
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/OpenCV-${DISTVERSION}
diff --git a/graphics/opengtl/Makefile b/graphics/opengtl/Makefile
index 749d8e78920b..baa585063785 100644
--- a/graphics/opengtl/Makefile
+++ b/graphics/opengtl/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= yes
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
diff --git a/graphics/openimageio/Makefile b/graphics/openimageio/Makefile
index b6c5cf598107..da476a77435d 100644
--- a/graphics/openimageio/Makefile
+++ b/graphics/openimageio/Makefile
@@ -28,9 +28,7 @@ WRKSRC= ${WRKDIR}/OpenImageIO-oiio-${GH_COMMIT}/src
# fbm also installs bin/idiff
CONFLICTS= fbm-[0-9]*
-USE_CMAKE= yes
-CMAKE_VERBOSE= yes
-CMAKE_OUTSOURCE= yes
+USES= cmake:outsource
CMAKE_ARGS?= -DBUILDSTATIC:BOOL=OFF \
-DLINKSTATIC:BOOL=OFF \
-DNOTHREADS:BOOL=OFF \
diff --git a/graphics/openjpeg/Makefile b/graphics/openjpeg/Makefile
index 977d29da7a10..aaa4f97a694f 100644
--- a/graphics/openjpeg/Makefile
+++ b/graphics/openjpeg/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
lcms2:${PORTSDIR}/graphics/lcms2
GNU_CONFIGURE= yes
-USE_CMAKE= yes
+USES= cmake
USE_LDCONFIG= yes
MAN1= image_to_j2k.1 j2k_dump.1 j2k_to_image.1
diff --git a/graphics/openshadinglanguage/Makefile b/graphics/openshadinglanguage/Makefile
index e3a36ac3e3be..884a4ac4d07f 100644
--- a/graphics/openshadinglanguage/Makefile
+++ b/graphics/openshadinglanguage/Makefile
@@ -26,14 +26,11 @@ GH_COMMIT= d722707
WRKSRC= ${WRKDIR}/imageworks-OpenShadingLanguage-${GH_COMMIT}/src
-USE_CMAKE= yes
-CMAKE_VERBOSE= yes
-CMAKE_OUTSOURCE= yes
CMAKE_ARGS= -DFLEX_EXECUTABLE:STRING=${LOCALBASE}/bin/flex \
-DUSE_TBB:BOOL=OFF
CXXFLAGS+= -I${LOCALBASE}/include/flex
USE_LDCONFIG= yes
-USES= bison
+USES= bison cmake:outsource
MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index fae9c96b0df2..63d322f68da7 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
CONFLICTS= osg-[0-9]*
USE_ZIP= yes
-USE_CMAKE= yes
+USES= cmake
USE_GL= gl glu
USE_GNOME= pkgconfig
USE_XORG= x11
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index fba5ee711537..311e5b27bec3 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -24,7 +24,7 @@ CONFLICTS= osg-devel-[0-9]*
USE_GCC= any
USE_ZIP= yes
-USE_CMAKE= yes
+USES= cmake
USE_GL= gl glu
USE_GNOME= pkgconfig
USE_XORG= x11
diff --git a/graphics/picviz/Makefile b/graphics/picviz/Makefile
index 9d6da1728234..efbee763129e 100644
--- a/graphics/picviz/Makefile
+++ b/graphics/picviz/Makefile
@@ -14,9 +14,8 @@ COMMENT= Parallel coordinates plotter
LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre \
cairo.2:${PORTSDIR}/graphics/cairo
-USE_CMAKE= yes
USE_LDCONFIG= yes
-USES= bison
+USES= bison cmake
MAN1= pcv.1
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index ca98a5235f2f..9777a6d74d3d 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -15,7 +15,7 @@ MAKE_JOBS_SAFE= yes
USE_XZ= yes
GNU_CONFIGURE= yes
-USE_CMAKE= yes
+USES= cmake
USE_LDCONFIG= yes
CMAKE_ARGS+= -DPNG_MAN_DIR:STRING=man
diff --git a/graphics/podofo/Makefile b/graphics/podofo/Makefile
index f8b01b70bae9..f1408ee66fbc 100644
--- a/graphics/podofo/Makefile
+++ b/graphics/podofo/Makefile
@@ -20,7 +20,7 @@ OPTIONS_DEFINE= JPEG TIFF PNG IMPOSE
OPTIONS_DEFAULT= JPEG TIFF PNG
IMPOSE_DESC= Build impose tool (needs Lua)
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DPODOFO_BUILD_SHARED:BOOL=TRUE \
-DPODOFO_BUILD_STATIC:BOOL=FALSE \
-DOPENSSL_INCLUDE_DIR:PATH="${OPENSSLINC}" \
diff --git a/graphics/prison/Makefile b/graphics/prison/Makefile
index 2a8469cc36f8..b1cb54268b53 100644
--- a/graphics/prison/Makefile
+++ b/graphics/prison/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= dmtx.0:${PORTSDIR}/graphics/libdmtx \
qrencode.3:${PORTSDIR}/graphics/libqrencode
USE_QT4= corelib gui qmake_build moc_build rcc_build uic_build
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
diff --git a/graphics/projectm-libvisual/Makefile b/graphics/projectm-libvisual/Makefile
index c9800098c61f..545cc4961825 100644
--- a/graphics/projectm-libvisual/Makefile
+++ b/graphics/projectm-libvisual/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= projectM:${PORTSDIR}/graphics/libprojectm \
visual-${LIBVISUAL_VER}:${PORTSDIR}/graphics/libvisual${LIBVISUAL_VER:S/.//} \
SDL:${PORTSDIR}/devel/sdl12
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS+= -DLIBVISUAL_LIBRARIES=visual-${LIBVISUAL_VER}
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
USE_LDCONFIG= yes
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index 6e4bf32c49a0..29526f43f3bb 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -20,8 +20,7 @@ LIB_DEPENDS= geos:${PORTSDIR}/graphics/geos \
USE_BZIP2= yes
USE_PYTHON= yes
-USES= bison
-USE_CMAKE= yes
+USES= bison cmake
USE_SQLITE= yes
USE_QT4= gui svg xml network sql designer linguist_build \
qmake_build moc_build rcc_build uic_build
diff --git a/graphics/qtgtl/Makefile b/graphics/qtgtl/Makefile
index aec1068e6e2d..f371ad88b063 100644
--- a/graphics/qtgtl/Makefile
+++ b/graphics/qtgtl/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= GTLCore.0:${PORTSDIR}/graphics/opengtl
USE_PKGCONFIG= build
USE_QT4= gui moc_build qmake_build rcc_build uic_build
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index 855017e14819..484dd1ac7352 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
tiff:${PORTSDIR}/graphics/tiff \
sigc-2.0:${PORTSDIR}/devel/libsigc++20
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
USE_XZ= yes
USE_GNOME= gtk20 glib20
diff --git a/graphics/scantailor/Makefile b/graphics/scantailor/Makefile
index b3e7f0cc0608..db60aa95cd31 100644
--- a/graphics/scantailor/Makefile
+++ b/graphics/scantailor/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
-USE_CMAKE= yes
+USES= cmake
USE_ICONV= yes
USE_GETTEXT= yes
USE_QT4= gui xml qmake_build uic_build moc_build rcc_build \
diff --git a/graphics/shiva-collections/Makefile b/graphics/shiva-collections/Makefile
index fc44f1d9004f..374cd1e93e82 100644
--- a/graphics/shiva-collections/Makefile
+++ b/graphics/shiva-collections/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= avilla@FreeBSD.org
COMMENT= Collection of kernels for OpenGTL
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
NO_BUILD= yes
.include <bsd.port.mk>
diff --git a/graphics/showimage/Makefile b/graphics/showimage/Makefile
index 86d9d50c3f50..d6aa4623e8f4 100644
--- a/graphics/showimage/Makefile
+++ b/graphics/showimage/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= rnejdl@ringofsaturn.com
COMMENT= ShowImage is a simple KDE based image viewer
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
USE_KDE4= automoc4 kdeprefix kdelibs
USE_QT4= qmake_build moc_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
diff --git a/graphics/skanlite/Makefile b/graphics/skanlite/Makefile
index 5d90f7e0a013..331565aec775 100644
--- a/graphics/skanlite/Makefile
+++ b/graphics/skanlite/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= ksane.0:${PORTSDIR}/graphics/libksane
USE_BZIP2= yes
USE_KDE4= kdelibs kdeprefix kdehier automoc4
USE_QT4= qmake_build moc_build rcc_build uic_build
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
# Fix build with no-default PREFIX
diff --git a/graphics/tulip/Makefile b/graphics/tulip/Makefile
index c9d26e73a539..5e897efa5cc7 100644
--- a/graphics/tulip/Makefile
+++ b/graphics/tulip/Makefile
@@ -27,8 +27,7 @@ USE_QT4= corelib moc_build uic_build rcc_build gui opengl xml network qmake_buil
USE_GL= glew glut
USE_GNOME= libxml2
USE_PYTHON= yes
-USE_CMAKE= yes
-CMAKE_OUTSOURCE=yes
+USES= cmake:outsource
CMAKE_ARGS+= -DLOCALBASE:PATH=${LOCALBASE} \
-DPYTHON_INCLUDEDIR:PATH=${PYTHON_INCLUDEDIR}
USE_LDCONFIG= ${PREFIX}/lib/tlp
diff --git a/graphics/vigra/Makefile b/graphics/vigra/Makefile
index 2aca42aa2753..8b10a591f3ac 100644
--- a/graphics/vigra/Makefile
+++ b/graphics/vigra/Makefile
@@ -15,7 +15,7 @@ LICENSE= MIT
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DDEPENDENCY_SEARCH_PREFIX:PATH=${LOCALBASE} \
-DDOCINSTALL:PATH=${DOCSDIR_REL}
diff --git a/graphics/yagf/Makefile b/graphics/yagf/Makefile
index 99a0e9ce3e6b..673968f8f74d 100644
--- a/graphics/yagf/Makefile
+++ b/graphics/yagf/Makefile
@@ -21,7 +21,7 @@ TESSERACT_DESC= Tesseract OCR engine
OPTIONS_DEFAULT= CUNEIFORM
-USE_CMAKE= yes
+USES= cmake
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
USE_PKGCONFIG= build
diff --git a/graphics/zint/Makefile b/graphics/zint/Makefile
index dec670651a4e..7fa410c96310 100644
--- a/graphics/zint/Makefile
+++ b/graphics/zint/Makefile
@@ -18,7 +18,7 @@ LICENSE= GPLv3
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
-USE_CMAKE= yes
+USES= cmake
USE_LDCONFIG= yes
USE_QT4= gui xml qmake_build uic_build moc_build rcc_build designer
MAKE_JOBS_SAFE= yes